Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does my webcam transmit fine in html5 in Chrome, but not in Firefox?

  • 6 replies
  • 4 have this problem
  • 123 views
  • Last reply by guigs

more options

On every website I try, Firefox does not support getusermedia, so I cannot transmit audio and video data from my Windows 8.1 tablet in html5. Thus, I cannot use Firefox Hello. I have tried tinkering with numerous settings in about:config, but nothing works. I have exactly the same problem as this guy: http://stackoverflow.com/questions/25280592/webcam-video-stream-working-in-chrome-but-not-firefox In Google Chrome, however, there are no problems with this. This is not an add-ons issue, as I have uninstalled all addons and have re-installed Firefox anew twice. On a friend's Windows 8.1 laptop, however, there is no such problem. So what, exactly, can I do to remedy this situation?

All Replies (6)

more options

Is your driver up to date? For webgl and for the webcam? Upgrade your graphics drivers to use hardware acceleration and WebGL

more options

You may need this: Media Feature Pack for Windows 8.1 N and Windows 8.1 KN Editions: April 2014:

more options

I've just updated my drivers. The problem continues.

more options

I have this same problem, but i'm on Ubuntu 14.04 using Firefox Developer Edition 37.0a2 and also tested in Firefox 35.0.1.

You can reproduce the problem:

  1. visiting: mozilla.github.io/webrtc-landing/gum_test.html
  2. When Firefox ask to share the webcam, share it
  3. See the message: InternalError: Starting video failed

Due this, i can't use Firefox Hello Service.

more options

@jgomo3 I get a HARDWARE_UNAVAILABLE error when I visit that page.

more options

Are you using a bluetooth webcam? If not, please post the example url in with an explanation of what happens, what is expected, and the steps and ingredients in an open issue: in this component