Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox doesn't let me copy the web address from the address bar using the context menu with second button in mouse or trackpad

  • 7 replies
  • 2 have this problem
  • 123 views
  • Last reply by Raima

more options

Hello!

I write to report a problem I have with the new update v35 and v35.0.1 Firefox on address bar

With the new version 35 of Firefox on Mac OSX Yosemite, clicking directly with the right mouse button in the address bar to copy the web address, context menu NOT allowed to copy the link, it shaded in gray, inactive ... you have to click on another browser free zone before returning to click a second time and be able to copy the link from the context menu

I mean, with the first right click in the address bar context menu that appears don't allow me to copy the link directly, you have to click on another area and then clicking again with the right mouse button in the address bar to copy the web address (happens to all pages)

I tried to open Firefox with inactive complements and plugins, and reset Firefox to first time use (like the first install) and the problem is here again... With or without complements and plugins the problem is here

This happens before and then when I format my computer

Here I put a screenshot that explains the problem better than my words http://i.imgur.com/QxKd8P1.gif

I hope you can help me

Chosen solution

Hello

I just want to inform you that with new version 36 of Firefox this problem has been fixed in my browser Now, I can access the Copy option from the context menu directly in the address bar Thanks for the replies

Read this answer in context 👍 0

All Replies (7)

more options

The icons that show up when you right click in that image do not look like the default version of Firefox, even with the Spanish Dictionary/Language pack.

Is there an add on that is still located in your profile that is adding these icons? Check to see if they show up in a new profileProfile Manager - Create, remove, or switch Firefox profiles If they do, it may be another program or third party changing this feature.

Try to boot your Mac in Safe Mode.

   *Starting up in Safe Mode: http://support.apple.com/kb/HT1455
more options

Here is a work around;

deskCut {web link} This extension adds desktop shortcut creation to the context-menu for Windows, Linux and Mac.

more options

guigs2 said

The icons that show up when you right click in that image do not look like the default version of Firefox, even with the Spanish Dictionary/Language pack.

Hello The icons in the screenshot is from Linux OS, because I don't know how to capture screen, and somebody in Linux OS made it to show the problem that I was talking about

I don't have any icon addons only have 2 plugins, quicktime (integrated in OS) and adobe Flash, updated both Before I format my Mac, I upgraded Firefox to v35 and here came this error Then I format my Mac after days, by subjects of hard disk space, etc... when I install Firefox 35 (new install) the problem was here again

I tried to Open Firefox with disabled Add-ons, and Reset Firefox to an install version, but the problem is here always

more options

FredMcD said

Here is a work around; deskCut {web link} This extension adds desktop shortcut creation to the context-menu for Windows, Linux and Mac.

Hello I would like to resolve the error without having to install any plugin or any addon, just only as was always Firefox

Modified by Raima

more options

You can use it until the problem is solved.

Try this, Create a bookmark, open the Bookmarks Manager, then move the entry to the desktop, or a folder.

more options

Hello

I hope with the next update v36 of Firefox next February 24, this problem will be fixed I'm still having the same problem not fixed

more options

Chosen Solution

Hello

I just want to inform you that with new version 36 of Firefox this problem has been fixed in my browser Now, I can access the Copy option from the context menu directly in the address bar Thanks for the replies