X
Tap here to go to the mobile version of the site.

Support Forum

Spaces or Icons missing?

Posted

I am wondering if anyone else has seen this issue within Firefox. I have used Firefox for so many years and just recently I started noticing that on some web pages there are little boxes with E6 followed by a series of numbers in place of icons or spaces. Attached is a screenshot of what I am talking about. I am curious if anyone else has seen this and if so does anyone know if there are plans to fix it?

Phil

I am wondering if anyone else has seen this issue within Firefox. I have used Firefox for so many years and just recently I started noticing that on some web pages there are little boxes with E6 followed by a series of numbers in place of icons or spaces. Attached is a screenshot of what I am talking about. I am curious if anyone else has seen this and if so does anyone know if there are plans to fix it? Phil
Attached screenshots

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • ActiveX hosting plugin for Firefox r39
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Citrix Online App Detector Plugin
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Nitro PDF plugin for Firefox and Chrome
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.6.156
  • 5.1.31211.0
  • VMware Remote Console Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

I think it means the web page wants to display something, but the browser does not know how.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

I think it means the web page wants to display something, but the browser does not know how. Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart. --------------------- Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.'''
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Helpful Reply

Good Morning, thank you for the reply FredMcD and cor-el. I checked those settings and they are set correctly. I have cleared all history, cookies, cache, etc. and still get the same results.

Thanks,

Phil

Good Morning, thank you for the reply FredMcD and cor-el. I checked those settings and they are set correctly. I have cleared all history, cookies, cache, etc. and still get the same results. Thanks, Phil
mrbunnylamakins 9 solutions 140 answers

cor-el had it right I had that issue for over a Year and Photobucket and other sites it was doing that to me know one knew why.

cor-el had it right I had that issue for over a Year and Photobucket and other sites it was doing that to me know one knew why.
FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

Load the web page. After, hold down the <Shift> key, and press Reload.

Load the web page. After, hold down the '''<Shift>''' key, and press '''Reload.'''

Question owner

Thank you again for the quick responses. I tried holding the Shift Key and pressing reload, as well as loading the page in a private session, both with no success :-(.

Thank you again for the quick responses. I tried holding the Shift Key and pressing reload, as well as loading the page in a private session, both with no success :-(.
FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

This is a last resort. If you still have problems, please post a web link. NO Personal Information Please.

Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

This is a last resort. If you still have problems, please post a web link. NO Personal Information Please. '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Question owner

FredMcD,

Sure, the site I am going to is http://ptukey.deviantart.com/. I tried what you suggested "Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings." And I still have the same issue :-(.

Thanks,

Phil

FredMcD, Sure, the site I am going to is http://ptukey.deviantart.com/. I tried what you suggested "Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings." And I still have the same issue :-(. Thanks, Phil
FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

I had no trouble with the site.

Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox. Is the problem still there?

I had no trouble with the site. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift ''(Mac Options)'' >''' key, and then starting Firefox. Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

That is font file that need to be downloaded from the server. So if you do not see the icon font, but see boxes with the hex code then either you are preventing Firefox from using remote fonts or other software is blocking this font.

You can open the Web Console (Firefox/Tools > Web Developer) and check for error messages related to downloading fonts. Also check on the Network tab if CSS and Font content is blocked and has a file size 0 (zero). You need to reload the page (F5 or Ctrl+F5) to generate the net log.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

That is font file that need to be downloaded from the server. So if you do not see the icon font, but see boxes with the hex code then either you are preventing Firefox from using remote fonts or other software is blocking this font. You can open the Web Console (Firefox/Tools > Web Developer) and check for error messages related to downloading fonts. Also check on the Network tab if CSS and Font content is blocked and has a file size 0 (zero). You need to reload the page (F5 or Ctrl+F5) to generate the net log. *https://developer.mozilla.org/Tools/Web_Console Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Question owner

This is what I get (if it means anything to anyone) when I go to the page with the Web Console Web Developer:

"Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/misc/symbols/deviantart-symbols3.woff. This can be fixed by moving the resource to the same domain or enabling CORS. deviantart-symbols3.woff

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/fonts/feed-v2/icons.woff. This can be fixed by moving the resource to the same domain or enabling CORS. icons.woff

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/misc/symbols/deviantart-symbols3.ttf. This can be fixed by moving the resource to the same domain or enabling CORS. deviantart-symbols3.ttf

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/fonts/feed-v2/icons.ttf. This can be fixed by moving the resource to the same domain or enabling CORS. icons.ttf"

Does this mean that the issue on the websites end?

Thanks

Phil

This is what I get (if it means anything to anyone) when I go to the page with the Web Console Web Developer: "Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/misc/symbols/deviantart-symbols3.woff. This can be fixed by moving the resource to the same domain or enabling CORS. deviantart-symbols3.woff Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/fonts/feed-v2/icons.woff. This can be fixed by moving the resource to the same domain or enabling CORS. icons.woff Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/misc/symbols/deviantart-symbols3.ttf. This can be fixed by moving the resource to the same domain or enabling CORS. deviantart-symbols3.ttf Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://st.deviantart.net/fonts/feed-v2/icons.ttf. This can be fixed by moving the resource to the same domain or enabling CORS. icons.ttf" Does this mean that the issue on the websites end? Thanks Phil
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

Helpful Reply

Yes, that looks like a problem with the server that doesn't obey current security requirements regarding CORS that Firefox uses.

Yes, that looks like a problem with the server that doesn't obey current security requirements regarding CORS that Firefox uses. *https://developer.mozilla.org/Web/HTTP/Access_control_CORS
MJB7 0 solutions 2 answers

FOR MAC OWNERS USING FF: PREF / CONTENT / ADVANCED / Select "Allow pages to choose their own fonts, instead of my selections above". - This will bring back your icons.

FOR MAC OWNERS USING FF: PREF / CONTENT / ADVANCED / Select "Allow pages to choose their own fonts, instead of my selections above". - This will bring back your icons.