Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox does not recreate or change prefs.js

  • 55 replies
  • 3 have this problem
  • 5398 views
  • Last reply by AliceWyman

more options

After deleting prefs.js file Firefox does not create a new one.

Firefox does not save any of my settings so i tried all the method described in the following articles:

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save#w_unable-to-save-any-preferences-or-settings

finally I uninstalled FF completely, deleted the FF installation directory and moved my old profile. Reinstalling FF did not help in anyway. After reinstalling, the preferences were still not saved so I deleted the profs.js file. When I start Firefox it does not create a new profs.js file adn of course my setting are still not saved

What can i do? change? I'd rather fix this than install chrome instead...

Modified by karpiyon

Chosen solution

cor-el said

Can you post a screenshot that shows the content of the profile folder in details view? Did you try to remove the entire Mozilla folder in both locations to reset the entire file structure?

yes i tried removing the entire Mozilla folder in both locations after, again, uninstalling FF.

Thank you for your time - i gave up - switched to chrome.

Read this answer in context 👍 0

All Replies (20)

more options

There should always be a prefs.js file in the Firefox profile folder.

Are you sure that you are in the correct location?

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Windows hides some file extensions by default. Among them are .html and .ini and .js and .txt, so you may only see file name without file extension. You can see the real file type (file extension) in the properties of the file via the right-click context menu in Windows Explorer.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thank you for the reply but I am quite sure there is no prefs.js file in my profile and this is the problem. The new prefs.js file is not created and even if I put one there it is never changed. See the image below after I restarted FF. There is no prefs.js, only my old pref file. FF opens with my pinned tabs + its 2 default setting and pages. Actually this is the only thing it ever "remembers" - my pinned tabs. I think the 2 default tabs are the "what's new" page and the default home page.

I've already tried resetting everything and creating a new profile. As I mentioned before I also deleted everything, including the profile folder, and reinstalled but it did not help.

What can prevent the prefs.js from being created? Where are the default prefs written? Perhaps some weird registry entry is causing this?

Any yes, the permission on the pref folder is as it should be and i am the owner. ???

Modified by karpiyon

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button.

At the top of the screen is a search bar. Type browser.newtab.url

Change this to something else. Close Firefox. Check the file date/time stamp.

Restart Firefox. Is the setting still the same?

more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

FredMcD said

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.newtab.url Change this to something else. Close Firefox. Check the file date/time stamp. Restart Firefox. Is the setting still the same? FredMcD said
Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.newtab.url Change this to something else. Close Firefox. Check the file date/time stamp. Restart Firefox. Is the setting still the same?

Thank you for the reply. Unfortunately I already tries this in the past. when had a prefs.js file the file date never changed, even when i changed prefs using about:config. When i start FF the changes were not saved. After removing the prefs.js the date of this file did not change because it is never recreated.

Any other suggestions?

more options

cor-el said

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

I've done this already and it did not help. As I wrote I've also uninstalled and deleted the previous profile and it still can't write to prefs.js or create a new on if i delete this file.

Does FF have a hidden debug log somewhere? Perhaps this file will mention a failing access to the prefs.js file which can point me to the source of this problem.

more options

Does FF have a hidden debug log somewhere? Perhaps this file will mention a failing access to the prefs.js file which can point me to the source of this problem.

more options

FredMcD said

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.newtab.url Change this to something else. Close Firefox. Check the file date/time stamp. Restart Firefox. Is the setting still the same? FredMcD said
Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.newtab.url Change this to something else. Close Firefox. Check the file date/time stamp. Restart Firefox. Is the setting still the same?

Yes. Still the same

more options

Try this Microsoft Sysinternals utility:

more options

cor-el said

Try this Microsoft Sysinternals utility:

I am familiar with this application and I've already used it in the past for various other reasons. It shows tons of activity actions; processes, entries, regkeys etc - what am I looking for?

more options

Still not working if you have any suggestion please let me know.

more options

Does that utility show that Firefox tries to create or at least access the prefs.js file?

more options

cor-el said

Does that utility show that Firefox tries to create or at least access the prefs.js file?

no

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I have an idea. Firefox the program or the profile is causing the problem. So lets get rid of both.

  • 1

Download Firefox Full Installer For All languages And Systems {web link}. Save the file someplace safe.

Close Firefox.

  • 2

Open the file browser / explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar;

Windows: %AppData%\Mozilla\ C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\ http://kb.mozillazine.org/Profile_folder_-_Firefox#Windows Linux: ~/.mozilla/ http://kb.mozillazine.org/Profile_folder_-_Firefox#Linux Mac: ~/Library/Application Support/ http://kb.mozillazine.org/Profile_folder_-_Firefox#Mac

Rename the Firefox folder by adding .old to it. Then;

  • 3

Using your file browser, open the Programs folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

Look for, and rename any Mozilla and Firefox folders by adding .old to them.

  • 4

Now run the full installer.

  • 5

Then restart Firefox. It should create a new profile. Test it. If everything looks to be working, you can then copy some files from the old profile to the new. Copy Only the password, history, & bookmarks. Do Not copy any settings files. As to the add-ons, copy Only a handful at a time. Start FF to see if there are any issues. Close FF and copy more Add-ons. Repeat.

more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

It did not help. It still does not recreate prefs.js file. As mentioned earlier I changed it's name to prefs_OLD.js hoping FF would recreate it. FF does not recreate this file, as it should, when i start it.

Modified by karpiyon

more options

FredMcD said

I have an idea. Firefox the program or the profile is causing the problem. So lets get rid of both.
  • 1
Download Firefox Full Installer For All languages And Systems {web link}. Save the file someplace safe. Close Firefox.
  • 2
Open the file browser / explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar; Windows: %AppData%\Mozilla\ C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\ http://kb.mozillazine.org/Profile_folder_-_Firefox#Windows Linux: ~/.mozilla/ http://kb.mozillazine.org/Profile_folder_-_Firefox#Linux Mac: ~/Library/Application Support/ http://kb.mozillazine.org/Profile_folder_-_Firefox#Mac Rename the Firefox folder by adding .old to it. Then;
  • 3
Using your file browser, open the Programs folder on your computer. Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual. Look for, and rename any Mozilla and Firefox folders by adding .old to them.
  • 4
Now run the full installer.
  • 5
Then restart Firefox. It should create a new profile. Test it. If everything looks to be working, you can then copy some files from the old profile to the new. Copy Only the password, history, & bookmarks. Do Not copy any settings files. As to the add-ons, copy Only a handful at a time. Start FF to see if there are any issues. Close FF and copy more Add-ons. Repeat.

Thank you for your time and effort. Unfortunately i already did this, before i opened this forum thread. i completely uninstalled, renamed the profile, deleted the Mozilla folder under program files and re installed. that did not work. the only difference from your suggestion is that i installed the English version, not the Full Installer For All languages as you suggested. do you think this can make a difference?

Modified by karpiyon

more options

If you make settings changes, such as choosing a different home page, does Firefox honor them during your session or ignore them? If they are ignored, you might have some malware named SearchProtect on your system.

more options

jscher2000 said

If you make settings changes, such as choosing a different home page, does Firefox honor them during your session or ignore them? If they are ignored, you might have some malware named SearchProtect on your system.

during the session they are honored. if i start a new FF window without closing all FF windows these settings are still honored. when i close ALL FF windows and then reopen, the home screen returns to default as well as all other changed settings. The ONLY thing it can 'remember' are the pinned taps

more options

karpiyon said

cor-el said
Does that utility show that Firefox tries to create or at least access the prefs.js file?

no

I checked this in another computer and processmonitor clearly shows access to prefs.js. On my problematic computer there is not access to this file AT ALL

  1. 1
  2. 2
  3. 3