X
Tap here to go to the mobile version of the site.

Support Forum

How do you stop HTML5 video from autoplaying?

Posted

I don't want video to play automatically. Flashblock achieves this for flash videos, but there doesn't seem to be a way to do the same thing for html5 video (on vine, for example).

None of the about:config settings appear to have any effect, and html5 isn't handled by a plugin so click to activate doesn't do anything either.

I don't want video to play automatically. Flashblock achieves this for flash videos, but there doesn't seem to be a way to do the same thing for html5 video (on vine, for example). None of the about:config settings appear to have any effect, and html5 isn't handled by a plugin so click to activate doesn't do anything either.

Additional System Details

Installed Plug-ins

  • Version: 5.38.6.0
  • The IcedTea-Web Plugin executes Java applets.
  • Shockwave Flash 11.2 r202

Application

  • Iceweasel 34.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0 Iceweasel/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0/Linux/en-US/

Extensions

  • Classic Theme Restorer 1.2.8.2 (ClassicThemeRestorer@ArisT2Noia4dev)
  • DOM Inspector 2.0.15 (inspector@mozilla.org)
  • Flashblock 1.5.18 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Lightbeam 1.1.0 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Open in Browser 1.15 (openinbrowser@www.spasche.net)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • XPath Checker 0.4.4 ({7eb3f691-25b4-4a85-9038-9e57e2bcd537})
  • Flash Block 4.20.13 ({95ab36d4-fb6f-47b0-8b8d-e5f3bd547953}) (Inactive)
  • QuickJava 2.0.6 ({E6C1199F-E687-42da-8C24-E7770CC3AE66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 10.2.1
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.enablesound: False
  • accessibility.typeaheadfind.flashBar: 0
  • accessibility.typeaheadfind.soundURL: none
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 4
  • browser.display.background_color: #000000
  • browser.display.foreground_color: #CCFFFF
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141203180037
  • browser.startup.homepage_override.buildID: 20141018042246
  • browser.startup.homepage_override.mstone: ignore
  • browser.tabs.drawInTitlebar: True
  • browser.tabs.onTop: True
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0
  • font.default.x-western: sans-serif
  • font.minimum-size.x-western: 9
  • font.name.sans-serif.x-western: DejaVu Sans Mono
  • font.name.serif.x-western: monospace
  • font.size.fixed.x-western: 16
  • gfx.blacklist.suggested-driver-version: <Anything with EXT_texture_from_pixmap support>
  • media.autoplay.enabled: False
  • media.gmp-gmpopenh264.lastUpdate: 1415062414
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1418127359
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1420334188
  • places.history.expiration.transient_current_max_pages: 100839
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.disable_button.openCertManager: False
  • security.enable_java: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1418478447
  • webgl.force-enabled: True
  • webgl.prefer-native-gl: True

Misc

  • User JS: No
  • Accessibility: No
Diego Victor 658 solutions 4175 answers

Hello,

One thread to you try in about:config:

Other old thread with many ideas:

Hello, One thread to you try in about:config: *[https://support.mozilla.org/questions/1012943#answer-611047 questions/1012943] Other old thread with many ideas: *[https://support.mozilla.org/questions/961940 questions/961940]

Modified by Diego Victor

Question owner

Flashblock can stop the HTML5 video from playing at all, but does not just stop autoplay.

I have already tried about:config approach, none of the settings appear to have any effect.

Flashblock can stop the HTML5 video from playing at all, but does not just stop autoplay. I have already tried about:config approach, none of the settings appear to have any effect.
FredMcD
  • Top 10 Contributor
4314 solutions 60573 answers
I found these at the '''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]''' {web link} (There’s a lot of good stuff here) There may be others. https://addons.mozilla.org/en-US/firefox/addon/stop-tube/ https://addons.mozilla.org/en-US/firefox/addon/flash-control/

Question owner

The flash control thing is almost there - occasionally I get a brief burst of noise and video before it stomps on the playback but still a lot better than before, thanks.

The flash control thing is almost there - occasionally I get a brief burst of noise and video before it stomps on the playback but still a lot better than before, thanks.
kozaki 0 solutions 14 answers

I confirm `flash-control`stops autoplay for html5 and old Flash videos (attached screen), plus it has a comprehensive little FAQ right on the extension page :) Unlike `about:config` and other extensions I tried in vain. Thanks @FredMcD @fledermaus for mentionning the former.

https://addons.mozilla.org/en-US/firefox/addon/flash-control/

I confirm `flash-control`stops autoplay for html5 and old Flash videos (attached screen), plus it has a comprehensive little FAQ right on the extension page :) Unlike `about:config` and other extensions I tried in vain. Thanks @FredMcD @fledermaus for mentionning the former. https://addons.mozilla.org/en-US/firefox/addon/flash-control/