Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Having issues with saving and history

  • 35 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

"Save Link as" isn't working at all. When I try it, either nothing happens at all, or when something does happen, I can't save a file. When something does happen and the folder location where I'm trying to save it opens, it just says "dwn" in the filename box. And I can't save anything I try to save.

And when I "left click" when trying to save something, it just says "connecting..." and after a couple minutes, it will let me save the file I'm attempting to save. But if what I'm trying to save a file and the link has a limit, it always expires before I get to save it.

I've tried Safe Mode, restarting Firefox to factory state, I've uninstalled it completely and reinstalled it, cleared history, cache, and cookies, but nothing has worked.

And also when I cleared the history, my address bar wasn't cleared at all.

Please help me with this, it's getting really frustrating.

All Replies (15)

more options

Didn't work.

Same issues.

more options

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Is doing all that scanning really the only option I have?

Part of me still thinks has something to do with the plugins. Because I had it working for a short time last night after editing the actions of certain content types. Everything was the way it was before it started acting up.

more options

kmc524 said

Part of me still thinks has something to do with the plugins.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Now set everything to Ask To Activate.

more options

I should have been more specific. I think it has something to do with the VLC Plugin.

Because after editing the actions of certain content types in "Applications" to "Use VLC Media Player 2.1.5", saving was working again.

But Firefox still says that it has "2.1.3" and that I need an update and it's "Vulnerable". And I think that if Firefox recognized "2.1.5", it would work again.

Is there any way to get Firefox to recognize "2.1.5"?

more options

Would restoring the system to it's factory state do the trick?

I have my Important Files for my Job saved on USB Drives, and I do need my Computer to actually do something for the next couple days.

more options

Is its saying that it is vulnerable on the plugin check webpage or is it saying that it is vulnerable in the about:addons page. If in the plugin check, you can ignore for now.

Oh I see, the VLC media player is version 2.1.5, and the most updated web plugin player is 2.1.3.

more options


So what do you suggest I do?

Because what's going on now is,

When I try do download a File via a Link , if I left Click it just says "Connecting.." and it does nothing. Or it will do nothing for a random period of time and then the "You have chosen to Open" Box will appear.

If I right click and try to "Save Link As", either nothing will happen at all, or if something does happen, it just says

"videoplayback" in the "Filename" Box "Firefox HTML Document" in the "Save As Type" Box

It seems that it only happens with Download Links.

"Save Image As" works just fine.

more options

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

more options

Didn't change anything.

I tried to download something by Left Clicking, it still said "Connecting..." for about a minute or two, then the "You have chosen to Open" message came up. And I hit save, and it downloads without any problems.

And Right Clicking and trying to "Save Link As, all I got was:

"dwn" in the Filename Box "Firefox HTML Document" in the Save as Type Box

more options

I'm sorry, but I'm out of ideas.

more options

Well thanks anyway.

I was hoping that the VLC Plugin was the issue. Because like I said, after I changed some download options to " Use Vlc Media Player 2.1.5", it was working like it was before all of this happened. Everything was working just fine. Then it just started acting up again.

And it is just Links with Files in them that's giving me issues. If I download a Video File without a link, it's fine.

Would resting the entire thing to it's factory state solve the problem? I'd rather not have to resort to that, but if that's all I have left, I'll do it.

Modified by kmc524

more options

I just don't know.

more options

I ended up resetting the whole system, and everything works again.

So I don't know what the problem was.

more options

If it works, don't fix it. Hopefully the problem will stay gone.

Please flag your last post as Solved Problem so other will know.

  1. 1
  2. 2