X
Tap here to go to the mobile version of the site.

Support Forum

Can't edit Bookmarks toolbar

Posted

Hello,

A few updates ago, for Firefox, made it so that I cannot edit my bookmarks toolbar. I can't delete anything on them, but I can add them and move them if I open up the sidebar. I can't move them around any other way. Instead of a drop box asking for what I want to do, like normal, whenever I right click a bookmark a little white square pops up over the bookmark instead and won't let me do anything.

I just installed the latest Mozilla update and it did not fix the issue. I tried the following:

1) Remove all extensions, add ons, themes and other things. Restart Firefox. 2) Clear cache of computer 3) Updated

The only thing I haven't done is reinstall, because I don't want to lose my bookmarks, especially those in the quick access toolbar (the one I can't edit).

I uploaded an image of what it does. I circled the box in red.

Thank you for reading and for any and all help.

Hello, A few updates ago, for Firefox, made it so that I cannot edit my bookmarks toolbar. I can't delete anything on them, but I can add them and move them if I open up the sidebar. I can't move them around any other way. Instead of a drop box asking for what I want to do, like normal, whenever I right click a bookmark a little white square pops up over the bookmark instead and won't let me do anything. I just installed the latest Mozilla update and it did not fix the issue. I tried the following: 1) Remove all extensions, add ons, themes and other things. Restart Firefox. 2) Clear cache of computer 3) Updated The only thing I haven't done is reinstall, because I don't want to lose my bookmarks, especially those in the quick access toolbar (the one I can't edit). I uploaded an image of what it does. I circled the box in red. Thank you for reading and for any and all help.

Chosen solution

@cor-el

Safe mode allows me to edit my toolbar. I went through disabling all my plugins afterward, restart Firefox but still cannot edit outside of Safe-Mode.

edit

Okay, it was a Mozilla theme that was causing the problem. I deleted, restarted and everything works fine!

Thanks for the help guys, appreciate it. Didn't want to move browsers or reinstall. :)

@FredMcD

Okay, thank you! I successfully deleted the older version of the player. :)

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Battlelog Game Launcher (2.6.2)
  • Google Update
  • Happy Cloud Web Plugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • Mozilla PMangFX Session Plugin_1.1.0.25
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151
  • 5.1.31211.0
  • Unity Player 4.5.0f6
  • VLC media player Web Plugin 2.1.3
  • VLC media player Web Plugin 2.1.0
  • Plugin for Wacom tablets.
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

FredMcD
  • Top 10 Contributor
4339 solutions 61028 answers

Separate Issue; Your System Details shows;

Installed Plug-ins

VLC media player Web Plugin 2.1.3 VLC media player Web Plugin 2.1.0

Having more than one version of a program may cause issues.


Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

Separate Issue; Your System Details shows; Installed Plug-ins VLC media player Web Plugin 2.1.3 VLC media player Web Plugin 2.1.0 Having more than one version of a program may cause issues. ----------------------- Problems with bookmarks and history not working properly can be caused by a corrupted '''places.sqlite''' database file. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the file. Then rename or delete it. Restart Firefox.

Question owner

Hello and thanks for the reply! :)

How can I remove previous versions of a plugin? It seems to remove them all.

I did as you suggested and removed the file. However, upon restarting Firefox the issue was not resolved.

Hello and thanks for the reply! :) How can I remove previous versions of a plugin? It seems to remove them all. I did as you suggested and removed the file. However, upon restarting Firefox the issue was not resolved.
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

Make sure to remove all places files including the places.sqlite-shm and places.sqlite-wal files.

You can check for problems with the places.sqlite database file in the Firefox profile folder.

Make sure to remove all places files including the places.sqlite-shm and places.sqlite-wal files. You can check for problems with the <b>places.sqlite</b> database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *Places Maintenance: https://addons.mozilla.org/firefox/addon/places-maintenance/

Question owner

Hello,

I assumed "FredMcD" meant to remove them all and I did just that. All it did was remove the icons of my bookmarks. Still unable to right click and delete them.

I'm looking over the links right now. And in case the image never uploaded—doesn't look like it—I uploaded it again.

Hello, I assumed "FredMcD" meant to remove them all and I did just that. All it did was remove the icons of my bookmarks. Still unable to right click and delete them. I'm looking over the links right now. And in case the image never uploaded—doesn't look like it—I uploaded it again.

Question owner

Hello,

Update. Read through the links. Followed all the instructions. I got to the suggestions if you find a "corrupt" file. I did find one. However, deleting it as directed and restarted Firefox only respawns the corrupted file.

I tried the extensions to fix the problem, but it didn't solve anything. I noticed that it said CCleaner could be a problem. I have that installed. How can I fix the issue? Is it a setting in CCleaner?

Trying the chkdsk solution now.

Hello, Update. Read through the links. Followed all the instructions. I got to the suggestions if you find a "corrupt" file. I did find one. However, deleting it as directed and restarted Firefox only respawns the corrupted file. I tried the extensions to fix the problem, but it didn't solve anything. I noticed that it said CCleaner could be a problem. I have that installed. How can I fix the issue? Is it a setting in CCleaner? Trying the chkdsk solution now.
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

Did you try Safe Mode?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Did you try Safe Mode? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
FredMcD
  • Top 10 Contributor
4339 solutions 61028 answers

Twixmonkey said

How can I remove previous versions of a plugin? It seems to remove them all.

Type about:plugins<enter> in the address bar. Now search for the plug-in.

Example; Adobe Acrobat File: nppdf32.dll,nppdf32.dll Path: C:\Program Files (x86)\Adobe\Reader 11.0\Reader\browser\nppdf32.dll,C:\Program Files (x86)\Adobe\Reader 11.0\Reader\AIR\nppdf32.dll Version: 11.0.9.29 State: Enabled Adobe PDF Plug-In For Firefox and Netscape 11.0.9

This will show you the path to that program. Copy the Path Only. Also note the name of the file, and remember it. Now Close Firefox. Open your file browser and paste the path in the address bar. Find the file, and delete it. Now you can restart Firefox. Warning ! Remember to delete the right program.

''Twixmonkey [[#answer-672487|said]]'' <blockquote> How can I remove previous versions of a plugin? It seems to remove them all. </blockquote> Type '''about:plugins'''<enter> in the address bar. Now search for the plug-in. Example; '''Adobe Acrobat''' '''File:''' nppdf32.dll,nppdf32.dll '''Path:''' C:\Program Files (x86)\Adobe\Reader 11.0\Reader\browser\nppdf32.dll,C:\Program Files (x86)\Adobe\Reader 11.0\Reader\AIR\nppdf32.dll '''Version:''' 11.0.9.29 '''State:''' Enabled Adobe PDF Plug-In For Firefox and Netscape 11.0.9 This will show you the path to that program. Copy the '''Path Only.''' Also note the name of the file, and remember it. Now '''Close Firefox.''' Open your file browser and paste the path in the address bar. Find the file, and delete it. Now you can restart Firefox. '''Warning !''' Remember to delete the right program.

Chosen Solution

@cor-el

Safe mode allows me to edit my toolbar. I went through disabling all my plugins afterward, restart Firefox but still cannot edit outside of Safe-Mode.

edit

Okay, it was a Mozilla theme that was causing the problem. I deleted, restarted and everything works fine!

Thanks for the help guys, appreciate it. Didn't want to move browsers or reinstall. :)

@FredMcD

Okay, thank you! I successfully deleted the older version of the player. :)

@cor-el Safe mode allows me to edit my toolbar. I went through disabling all my plugins afterward, restart Firefox but still cannot edit outside of Safe-Mode. edit Okay, it was a Mozilla theme that was causing the problem. I deleted, restarted and everything works fine! Thanks for the help guys, appreciate it. Didn't want to move browsers or reinstall. :) @FredMcD Okay, thank you! I successfully deleted the older version of the player. :)

Modified by Twixmonkey

FredMcD
  • Top 10 Contributor
4339 solutions 61028 answers

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default http://kb.mozillazine.org/Preferences_not_saved

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default http://kb.mozillazine.org/Preferences_not_saved