Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Force google.com search instead of google.fr

  • 6 replies
  • 11 have this problem
  • 16 views
  • Last reply by kroman

more options

I get redirected to google.fr instead of staying on google.com when I use the search bar. Installing another plugin from here http://mycroftproject.com/google-search-plugins.html doesn't fix the problem.

Older versions of Firefox didn't have this behavior. I'm using FF34.

Is there a way to force the search engine to google.com?

All Replies (6)

more options

Thank you for your question about the search changes in Firefox. There's been a lot of exciting news and we are happy to assist you.

What has changed?
In the US and Canada, the default search engine has been changed from Google to Yahoo. In Russia, Yandex Search will become the default search and in China, Baidu will continue to be the default search. However, all other search engines will still be available in these regions. You will notice this change in Firefox 34.

Would you like to know more about the change?
See the blog post written by Chris Beard, New Search Strategy for Firefox: Promoting Choice & Innovation and the News Release, Yahoo and Mozilla Form Strategic Partnership.

Do you want to change your default search engine?
In Firefox 33 or below, you would change your default search engine from the Search bar, as shown in this animation. Starting in Firefox 34, you can use one of these methods:
Note: The following may not apply to localized versions of Firefox.

  • Click the menu button New Fx Menu and choose Options on Windows or Preferences on Mac or Linux, then select the Search settings panel.
  • Click on the magnifying glass icon in the Search bar, then click on Change Search Settings, as shown here:
search prefs 34

In the Search settings panel that opens, select a different search engine from the drop-down menu (see this screenshot).

For more information, see the article Search with the Firefox address bar.

Let us know if this answers your questions. If you have any other questions, we are happy to help.

more options

Thank you for your answer but that doesn't help me. My problem is being directed to google.fr instead of google.com with Firefox's search engine whatever I try.

Modified by kroman

more options

have you tried manually typing in the google address in the url box and then searching?

more options

I have to go on http://www.google.com/ncr to avoid redirection to google.fr But that's not a convenient solution since it doesn't make the search bar work

more options

Are you using an anonymizer, such as an anonymous proxy or AnonymoX?

more options

No, I'm not.