Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

As of Version 33, Firefox comes up with a blank gray screen and ....

  • 17 replies
  • 3 have this problem
  • Last reply by hogwaump

more options

As of Version 33, Firefox regularly comes up with a blank gray screen and will not exit normally. It has to be killed manually. Starting in safe mode makes no difference. Turning off hardware acceleration makes no difference.

To add insult to injury, Mozilla now wants you to use a crap downloader stub to get a new copy, and does not save what has been downloaded in case you need to try again.

I love Firefox. I have been using it since back in the Netscape dark ages. But these rapid updates and ridiculous failures are getting to be a bit much. I ask in all seriousness: is it time to abandon Firefox and work with Chrome or Internet Explorer instead?

Edited the title of this thread to provide a description of the issue at hand.

Modified by the-edmeister

All Replies (17)

more options

What i like about firefox is the addons and bookmarks and toolbars ,that type of customizability. I too like a less-buggy software like anyone else and I don't mind rapid updates, if they give us a better product. I'm not sure i understand the reason for the new backwards and forwards buttons on the right click menu though.

more options


The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: After resetting Firefox, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Reset Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Reset Firefox" that looks like this: Button reset . Click on it.
  3. Firefox will close and reset. After it is done, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

I hesitate to reset Firefox because I have it so heavily customized. I would have to rebuild all my permissions for noscript and such. But I don't think it would do any good. When this gray-screen happens, it is persistent, but after enough resets or power down/up cycles I can get it back. There is something very flawed about version 33+ on this particular hardware.

more options

To find the correct solution to your problem, we need some more non-personal information from you. Please do the following:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.
  2. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
  3. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

more options

If you have a lot of plugins one of them may be the problem. Safe mode does not effect plugins so please refer to this page and see if this helps, if not please report back and I will see what I can do

more options

Application Basics

Name: Firefox Version: 34.0.5 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days

All Crash Reports


Name: Adblock Plus Version: 2.6.6 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Classic Theme Restorer Version: Enabled: true ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: DownloadHelper Version: 4.9.24 Enabled: true ID: {b9db16a4-6edc-47ec-a1f4-b86292ed211d}

Name: Flash and Video Download Version: 1.64 Enabled: true ID: {bee6eb20-01e0-ebd1-da83-080329fb9a3a}

Name: InlineDisposition Version: Enabled: true ID: {123647d5-da43-4344-bfe2-fc093bdf8f5e}

Name: NoScript Version: Enabled: true ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Password Exporter Version: 1.2.1 Enabled: true ID: {B17C1C5A-04B1-11DB-9804-B622A1EF5492}

Name: RequestPolicy Version: 0.5.28 Enabled: true ID:

Name: Troubleshooter Version: 1.1a Enabled: true ID:

Name: WordWeb one-click lookup Version: 5.0.4406 Enabled: true ID:

Name: WOT Version: 20131118 Enabled: true ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}

Name: URL Tooltip Version: 1.2.2 Enabled: false ID:


Adapter Description: ATI Mobility Radeon HD 4500 Series Adapter Drivers: atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 1024 Device ID: 0x9553 DirectWrite Enabled: false (6.2.9200.16492) Driver Date: 8-17-2009 Driver Version: 8.632.1.2000 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic (OMTC) Subsys ID: 00000000 Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4500 Series Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences

accessibility.typeaheadfind: true accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 4 browser.places.smartBookmarksVersion: 7 false true browser.sessionstore.restore_on_demand: false browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045 browser.startup.homepage: browser.startup.homepage_override.buildID: 20141126041045 browser.startup.homepage_override.mstone: 34.0.5 browser.tabs.onTop: false browser.tabs.warnOnClose: false dom.mozApps.used: true extensions.lastAppVersion: 34.0.5 font.internaluseonly.changed: false general.autoScroll: false gfx.direct2d.disabled: true layers.acceleration.disabled: true media.gmp-gmpopenh264.lastUpdate: 1413847813 media.gmp-gmpopenh264.version: 1.1 media.gmp-manager.lastCheck: 1419824799 network.cookie.prefsMigrated: true network.dns.disablePrefetch: true network.prefetch-next: false places.database.lastMaintenance: 1419790064 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npctrl: 2 plugins.notifyMissingFlash: false print.printer_HP_Deskjet_3840_Series_(LiDiL).print_bgcolor: false print.printer_HP_Deskjet_3840_Series_(LiDiL).print_bgimages: false print.printer_HP_Deskjet_3840_Series_(LiDiL).print_colorspace: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_command: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_downloadfonts: false print.printer_HP_Deskjet_3840_Series_(LiDiL).print_duplex: 1515870810 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_edge_bottom: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_edge_left: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_edge_right: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_edge_top: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_evenpages: true print.printer_HP_Deskjet_3840_Series_(LiDiL).print_footercenter: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_footerleft: &PT print.printer_HP_Deskjet_3840_Series_(LiDiL).print_footerright: &D print.printer_HP_Deskjet_3840_Series_(LiDiL).print_headercenter: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_headerleft: &T print.printer_HP_Deskjet_3840_Series_(LiDiL).print_headerright: &U print.printer_HP_Deskjet_3840_Series_(LiDiL).print_in_color: true print.printer_HP_Deskjet_3840_Series_(LiDiL).print_margin_bottom: 0.5 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_margin_left: 0.5 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_margin_right: 0.5 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_margin_top: 0.5 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_oddpages: true print.printer_HP_Deskjet_3840_Series_(LiDiL).print_orientation: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_page_delay: 50 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_paper_data: 1 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_paper_height: 11.00 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_paper_name: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_paper_size_type: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_paper_size_unit: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_paper_width: 8.50 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_plex_name: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_resolution: 1515870810 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_resolution_name: print.printer_HP_Deskjet_3840_Series_(LiDiL).print_reversed: false print.printer_HP_Deskjet_3840_Series_(LiDiL).print_scaling: 1.00 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_shrink_to_fit: true print.printer_HP_Deskjet_3840_Series_(LiDiL).print_to_file: false print.printer_HP_Deskjet_3840_Series_(LiDiL).print_unwriteable_margin_bottom: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_unwriteable_margin_left: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_unwriteable_margin_right: 0 print.printer_HP_Deskjet_3840_Series_(LiDiL).print_unwriteable_margin_top: 0 privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1417850903

Important Locked Preferences


Incremental GC: true


Activated: false Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.10.7 Version in use: 4.10.7

NSS Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSSMIME Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSSSL Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSUTIL Expected minimum version: 3.17.2 Version in use: 3.17.2

Experimental Features

more options

Please check if all your plugins are up-to-date. To do this, go to the Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each yellow or red button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

I have disabled the plugins that I rarely use. This problem is sporadic, so it will be time consuming to eliminate suspicion of all plugins. It seems to happen upon restart of FF after an incremental update is received.

Modified by hogwaump

more options

All plugins are up to date or disabled.

more options

It would help a lot if you could take a screenshot of the grey screen, this would let me see what might be wrong. If you are unable to let me know and I will try to help you.

more options

All my screenshot tools are FF addons, so I have no way to do it easily. I can describe the window fairly accurately though: It is more or less a standard Windows affair, with a toolbar space allocated at the top. Both the window and the toolbar are essentially empty, just a solid gray color -- brightish gray, not a grayed-out kind of gray. As I recall, the only things visible are the usual 3 Windows buttons at top right for closing the window or minimizing, or maximizing. In this state, clicking on the X will seem to close the app, but on checking with Process Explorer I see that FF is still running. It does immediately respond to a Kill request, so it is not hung tightly.

more options

Try disabling all your plugins and see if it loads. If so activate your plugins one by one to see what works and what doesn't. If this does not work at all please report back.

more options

Unfortunately, soon after I started this dialogue, a (yet another) restart brought FF to life. I will report back when the problem can be replicated. Thanks, GamerFreak, for taking time to look into this with me.

more options

hogwaump said

I ask in all seriousness: is it time to abandon Firefox and work with Chrome or Internet Explorer instead?

I would like to go on record saying that Google Chrome has had a surprising drop in performance since they started supported Windows 8.1, and although IE 11 is good, it will never be as customizable as people need.

hogwaump said

To add insult to injury, Mozilla now wants you to use a crap downloader stub to get a new copy, and does not save what has been downloaded in case you need to try again.

Downloader stubs are the new thing. They allow you to quickly download an installation for later use without waiting for some huge download to complete (even though the stub itself downloads the rest of the installation).

However, not to worry. A full, offline installer still exists for Firefox. Just go to and you can find actual installers for all languages and OS.

more options

The stub installer for Windows is certainly not a new thing as claimed above as it has been available ever since Firefox 18.0 was released back in early Jan 2013 so almost two years now. It is new compared to the full setup yes.

more options

Firefox 33 introduced a new layout component that might be having a compatibility problem with your systerm. You could try turning it off:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false.

I think you might need to exit Firefox and start it up again before that takes effect.

Also, the next time you get the gray screen, could you try opening a new window using Ctrl+n to see whether that one displays correctly?

more options

Thanks, Jscher2000, giving that a try.