Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How does strange email address get into my Mozilla form autofill?

  • 7 replies
  • 1 has this problem
  • 42 views
  • Last reply by GlowFish

more options

Started within the last 3 weeks. in addition to my email address, a strange address shows up when I double click to autofill a form. I'll clear all browsing history, cookies, cache, form data, etc., but in a day or two its back. Norton Symantec has twice scanned and scrubbed my computer, but it was clean. I've even deleted and reloaded my Firefox browser. How is this slipping in and what browser settings are needed to block it? Thanks.

Started within the last 3 weeks. in addition to my email address, a strange address shows up when I double click to autofill a form. I'll clear all browsing history, cookies, cache, form data, etc., but in a day or two its back. Norton Symantec has twice scanned and scrubbed my computer, but it was clean. I've even deleted and reloaded my Firefox browser. How is this slipping in and what browser settings are needed to block it? Thanks.

All Replies (7)

more options

What is the address?

more options

FredMcD said

What is the address?

Addresses: ngxtest@earthsciences.com noreply@earthsciences.com

Thank you for your interest and help.

more options

Where is this taking place? Web site? Does that site use autofill? Do you have any autofill add-ons, or just the Firefox internal one?

Open you password manager. look carefully at all of the entries. Is the address listed in there?

Is earthsciences.com something you know or communicate with?

more options

Never heard of earthsciences.com.

There are no saved passwords in password manager. It is empty.

Websites where it appeared in forms: https://pop-in-nordstrom.venturaassociates.net/ https://popeyes.promo.eprize.com/bahamasbowl2014/ http://www.esquire.com/sweepstakes/28852

Modified by GlowFish

more options

Note that form data is not site specific like with the passwords. The name of the field is used, so if the name of the input field is a commonly used name then Firefox will show those suggestions on both multiple web pages.

Use these steps to remove saved (form) data from a drop-down list:

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Modified by cor-el

more options

Try this out; The next time it shows up . . . . . STOP ! ! ! ! Click the input field. Now <Control> A to highlight the whole entry. Now press the n once. n as in noreply@earth Does a list show up? Is earthsciences anything on the list. Using your arrow key, highlight the entry and press Delete. Now repeat.

Modified by FredMcD

more options

Thank you for your replies. I downloaded Malwarebites. Seven hits were quarantined & deleted. Hopefully the problem is resolved.