X
Tap here to go to the mobile version of the site.

Support Forum

In V34, why does a grey bar with, "Firefox prevented this page from automatically reloading"?

Posted

The answer to this question on your website seems to only apply to V33. I'm using V34 on a Mac and nearly every page displayed in Firefox has the grey bar at the top with the words, "Firefox prevented this page from automatically reloading". How do I get rid of this annoying statement?

The answer to this question on your website seems to only apply to V33. I'm using V34 on a Mac and nearly every page displayed in Firefox has the grey bar at the top with the words, "Firefox prevented this page from automatically reloading". How do I get rid of this annoying statement?

Chosen solution

You can also access this via:

  • Firefox > Preferences > Advanced > General : Accessibility :
    [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.10
  • Conduit Plugin 1_0_0
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.20913.0
  • iPhoto6

Application

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0.5/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AutoProxy 0.4b2.2013051811 (autoproxy@autoproxy.org)
  • Bluhell Firewall 2.5.0 ({6BB5760D-F97E-421B-AF5B-8457A90C3CED})
  • Cinema + pro1.1 0.95.12 (FNILGZ81840990@OKCZ70157576.com)
  • DownThemAll! 2.0.17 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Empty Cache Button 2.7 ({4cc4a13b-94a6-7568-370d-5f9de54a9c7f})
  • Print Edit 13.5 (printedit@DW-dev)
  • Print/Print Preview 0.9 ({19EB90DC-A456-458b-8AAC-616D91AAFCE1})
  • Thumbnail Zoom Plus 3.2 (thumbnailZoom@dadler.github.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Video Resumer 1.1.3 (videoresumer@jetpack)
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • YouTube High Definition 34.2 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind: True
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 4
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: http://search.conduit.com/?ctid=CT3330843&SearchSource=55&CUI=MC00100010203155036&UM=2
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.loadInBackground: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0.5
  • font.internaluseonly.changed: True
  • font.language.group: x-western
  • font.name.serif.x-western: Arial
  • keyword.URL: http://search.conduit.com/Results.aspx?ctid=CT3330843&searchsource=56&CUI=MC00100010203155036&UM=2&q=
  • media.gmp-gmpopenh264.lastUpdate: 1417435466
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1419594593
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1419528190
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.csp.enable: False
  • security.OCSP.enabled: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1417954331

Misc

  • User JS: Yes
  • Accessibility: No
Tim 14 solutions 101 answers

Helpful Reply

Hi there,

Try this:

  1. Click the menu button New Fx Menu
  2. Click Options
  3. Click Advanced
  4. Click General
  5. Uncheck the option called "Warn me when web sites try to redirect or reload the page"

Did this work?

Tim

Hi there, Try this: # Click the menu button [[Image:New Fx Menu]] # Click Options # Click Advanced # Click General # Uncheck the option called "Warn me when web sites try to redirect or reload the page" Did this work? Tim
cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160821 answers

Chosen Solution

You can also access this via:

  • Firefox > Preferences > Advanced > General : Accessibility :
    [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

You can also access this via: *Firefox > Preferences > Advanced > General : Accessibility :<br />[ ] "Warn me when web sites try to redirect or reload the page" The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting. See also: *https://support.mozilla.org/kb/settings-network-updates-and-encryption#w_general-tab *http://kb.mozillazine.org/accessibility.blockautorefresh *http://kb.mozillazine.org/Accessibility_features_of_Firefox

Helpful Reply

Tim said

Hi there, Try this:
  1. Click the menu button New Fx Menu
  2. Click Options
  3. Click Advanced
  4. Click General
  5. Uncheck the option called "Warn me when web sites try to redirect or reload the page"
Did this work? Tim

When I click the '3 Bar' icon, there is no "Option" to select.

''Tim [[#answer-669429|said]]'' <blockquote> Hi there, Try this: # Click the menu button [[Image:New Fx Menu]] # Click Options # Click Advanced # Click General # Uncheck the option called "Warn me when web sites try to redirect or reload the page" Did this work? Tim </blockquote> When I click the '3 Bar' icon, there is no "Option" to select.

Question owner

When I click the '3 Bar' icon there is no "Option" to select.

When I click the '3 Bar' icon there is no "Option" to select.
cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160821 answers

On Mac and Linux that would be Preferences instead of Options (Windows)

On Mac and Linux that would be Preferences instead of Options (Windows)
RobStow 0 solutions 9 answers

I'm having the same problem as the original poster but the solution here is not safe: in order to enable automatically reloading - such as for a sports scoreboard - you have to enable redirects.

So how can I enable automatic reloading without also doing something as stupidly dangerous as allowing redirects?

I'm having the same problem as the original poster but the solution here is not safe: in order to enable automatically reloading - such as for a sports scoreboard - you have to enable redirects. So how can I enable automatic reloading without also doing something as stupidly dangerous as allowing redirects?
cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160821 answers

This setting in "Options/Preferences > Advanced" is an accessibility setting and not a security setting like I wrote above and allowing this redirect is enabled by default in Firefox. Changing settings that affect blocking content in Firefox from the default should always be done with care as it can cause websites to malfunction. This also only works for some redirects via a location response header and not all other ways a server can redirect. You would need an extension that covers all redirects if you feel unsafe about a website redirecting you.

This setting in "Options/Preferences > Advanced" is an accessibility setting and not a security setting like I wrote above and allowing this redirect is enabled by default in Firefox. Changing settings that affect blocking content in Firefox from the default should always be done with care as it can cause websites to malfunction. This also only works for some redirects via a location response header and not all other ways a server can redirect. You would need an extension that covers all redirects if you feel unsafe about a website redirecting you.