X
Tap here to go to the mobile version of the site.

Support Forum

why does the latest version of firefox insist flash player is out of date and blocks play back but it is the latest update

Posted

Flash Player Plugin between 11.0 and 11.7.700.169 (click-to-play) has been blocked for your protection.this is what firefox tells me but when i check the add-ons manager it says version 15.0.0.239 is installed.how can i get firefox to recognize the right version

Flash Player Plugin between 11.0 and 11.7.700.169 (click-to-play) has been blocked for your protection.this is what firefox tells me but when i check the add-ons manager it says version 15.0.0.239 is installed.how can i get firefox to recognize the right version

Chosen solution

hello, adobe has released a critical patch for a vulnerability in its flash plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794

please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Allows browsing on RealArcade sites with Mozilla browsers.
  • RealDownloader Plugin
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealPlayer Download Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 15.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • Npdsplay dll

Application

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • RealDownloader 1.3.4 ({1B12EF76-2B5E-4DA1-B587-4762D49BFE03})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • YouTube Unblocker 0.6.5 (youtubeunblocker@unblocker.yt)
  • {dd19bae9-2c8f-414e-a7a6-657c52a61b85} 0.4 ({dd19bae9-2c8f-414e-a7a6-657c52a61b85}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Video WithOut Flash 1.5.1 (vwof@drev.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce3 Ti 200 (Microsoft Corporation)
  • adapterDescription2:
  • adapterDeviceID: 0x0201
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-7-2004
  • driverDate2:
  • driverVersion: 5.6.7.3
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: http://www.bbc.co.uk/news/
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.warnOnClose: False
  • browser.urlbar.default.behavior: 1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0.5
  • media.gmp-gmpopenh264.lastUpdate: 1413484809
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1418461549
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1418477114
  • places.history.expiration.transient_current_max_pages: 20115
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npbrowserplugin: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.npwpf: 0
  • plugin.state.npystate: 0
  • plugin.state.npzylomgamesplayer: 0
  • privacy.cpd.cache: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1417613965

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5114 solutions 22659 answers

Chosen Solution

hello, adobe has released a critical patch for a vulnerability in its flash plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794

please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).

hello, adobe has released a critical patch for a vulnerability in its flash plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794 please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).
James
  • Top 25 Contributor
  • Moderator
1485 solutions 10326 answers

The Plugin check is behind on what versions is current to check for so it is useless at moment until it is updated.

This is because 15.0.0.239 is not the latest Firefox 15 version as there has been at least 15.0.0.242 which is on blocklist and 15.0.0.246 which is not on the blocklist as according to Adobe it is not affected.

Flash Player Plugin 14.0 to 15.0.0.242 https://addons.mozilla.org/en-us/firefox/blocked/p798

Flash Player Plugin 10.3.183.66 to 13.0.0.258 https://addons.mozilla.org/en-US/firefox/blocked/p794

So for Windows and Mac 16.0.0.235, 13.0.0.259 ESR and 15.0.0.246 are not vulnerable according to Adobe and are not on blocklist.


philipp you need to update your posting for this as Mozilla made a two part blocklist on Friday so as to not block the 13.0.0.258 ESR version and your link is for one of the two blocklists for Win/Mac.

The Plugin check is behind on what versions is current to check for so it is useless at moment until it is updated. This is because 15.0.0.2'''39''' is not the latest Firefox 15 version as there has been at least 15.0.0.2'''42''' which is on blocklist and 15.0.0.2'''46''' which is not on the blocklist as according to Adobe it is not affected. Flash Player Plugin 14.0 to 15.0.0.242 https://addons.mozilla.org/en-us/firefox/blocked/p798 Flash Player Plugin 10.3.183.66 to 13.0.0.258 https://addons.mozilla.org/en-US/firefox/blocked/p794 So for Windows and Mac 16.0.0.235, 13.0.0.25'''9''' ESR and 15.0.0.24'''6''' are not vulnerable according to Adobe and are not on blocklist. '''philipp''' you need to update your posting for this as Mozilla made a two part blocklist on Friday so as to not block the 13.0.0.258 ESR version and your link is for one of the two blocklists for Win/Mac.

Modified by James