X
Tap here to go to the mobile version of the site.

Support Forum

Plug-in page tells me all plug-ins are up to date, but I keep getting error messages from Firefox telling me they are not and are unstable

Posted

I keep getting error messages stating that my Adobe Flash is out of date and vulnerable. I go to the Add-ons Manager, click "update" and it takes me to the plug-in page which shows it's up to date!! Same with Java DT and Shockwave Flash. How can I update if I have the latest versions already!?! I am inclined to just allow the plug-ins to work but don't want my pc to become vulnerable. Please help!

I keep getting error messages stating that my Adobe Flash is out of date and vulnerable. I go to the Add-ons Manager, click "update" and it takes me to the plug-in page which shows it's up to date!! Same with Java DT and Shockwave Flash. How can I update if I have the latest versions already!?! I am inclined to just allow the plug-ins to work but don't want my pc to become vulnerable. Please help!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npmnqmp 989898989877
  • Allows browsing on RealArcade sites with Mozilla browsers.
  • Shockwave Flash 15.0 r0
  • 5.1.30514.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 3.2.6.20140805113039 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})
  • Dangerous Websites Blocker 14.0.0.4939 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 14.0.0.4939 (url_advisor@kaspersky.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Move Media Player 7 (moveplayer@movenetworks.com) (Inactive)
  • Virtual Keyboard 14.0.0.4939 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Quadro NVS 210S
  • adapterDescription2:
  • adapterDeviceID: 0x0241
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum
  • adapterDrivers2:
  • adapterRAM: 64
  • adapterRAM2:
  • adapterSubsysID: 01ec1028
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 12-7-2006
  • driverDate2:
  • driverVersion: 7.15.10.9746
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 4
  • browser.newtab.url: www.yahoo.com
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: www.yahoo.com
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 34.0.5
  • keyword.URL:
  • media.autoplay.enabled: False
  • media.gmp-gmpopenh264.lastUpdate: 1415630430
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1418333794
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1418397246
  • places.history.expiration.transient_current_max_pages: 51949
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1417621576

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23508 answers

Helpful Reply

hello Danagriz, unfortunately the plugin check page lags behind. adobe has released a critical patch for a vulnerability in its flash plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794

please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers).

in order to update java, go to java.com (or if you don't need the plugin you can also uninstall it though the windows control panel)

hello Danagriz, unfortunately the plugin check page lags behind. adobe has released a critical patch for a vulnerability in its flash plugin, which is reportedly already exploited in the wild. therefore firefox will block insecure versions from running by default on websites for your protection. https://helpx.adobe.com/security/products/flash-player/apsb14-27.html https://addons.mozilla.org/firefox/blocked/p794 please update to Adobe Flash Player version 16.0.0.235 as soon as possible, which you can download from http://www.adobe.com/products/flashplayer/distribution3.html (use the windows-exe for plugin-based browsers). in order to update java, go to java.com (or if you don't need the plugin you can also uninstall it though the windows control panel)
blueberry997 0 solutions 7 answers

I have/had the same problem since the last update. One thing that surprises me (as my degree is in software engineering, back in '97) is the recent trend of software being absolutely chock full of bugs and errors. One would think that in the 17 years or so since I was at uni, things might have progressed!

To get it working (for today at least) I uninstalled flash. (Google: flash uninstall)

Then download their most recent version of flash, 16.xxxx.

Then restart firefox.

As you say, when attempting to check the version through the firefox browser, the information on which version is running was inaccurate.

I repeat, I have NEVER had so much bother with the firefox browser since I first used it-the year it was released.

It also helps to have task manager running, which means you can kill firefox when it stops responding (frequently).

I have/had the same problem since the last update. One thing that surprises me (as my degree is in software engineering, back in '97) is the recent trend of software being absolutely chock full of bugs and errors. One would think that in the 17 years or so since I was at uni, things might have progressed! To get it working (for today at least) I uninstalled flash. (Google: flash uninstall) Then download their most recent version of flash, 16.xxxx. Then restart firefox. As you say, when attempting to check the version through the firefox browser, the information on which version is running was inaccurate. I repeat, I have NEVER had so much bother with the firefox browser since I first used it-the year it was released. It also helps to have task manager running, which means you can kill firefox when it stops responding (frequently).

Question owner

OK, went to Java and downloaded most current version (even though I thought I had done that yesterday! lol!) and also updated Adobe Flash from their site. Let's hope it works! Thanks!

OK, went to Java and downloaded most current version (even though I thought I had done that yesterday! lol!) and also updated Adobe Flash from their site. Let's hope it works! Thanks!