Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

tried yer fixes, videos won't play, browser not working right, chrome works

more options

When I open firefox, I get a "Do you want to allow...." message and have to click yes. This has been happening to 4 different versions of firefox I have downloaded. Firefox will not play any videos. I've tried all the fixes recommended but they don't work. Any suggestions?

All Replies (8)

more options

Firefox Asking your permission to access the plugins. Choose "Always Yes" an it won't ask. for more info

  • Type about:permissions in URL
more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

Got it. Not much to see. White where video should be. Here is screenshot. Hope someone finds out what's wrong. Edward aka Pedro Miller

more options

You've been in my browser at least 7 to 9 times.

more options

Done. Will leave firefox on for next 20 hrs.

more options

Sure would be nice to hear from a mozilla tech. Google is looking better and better.

more options

I notice that you are using this feature:

  • Firefox > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:

more options

Problem solved. Software was bad. Deleted, fixed. Thanks to all who sent suggestions. Edward, aka Pedro, Miller