X
Tap here to go to the mobile version of the site.

Support Forum

Firefox seems to have a problem with Microsoft Silverlight and mapping software such as Xpedition.

Posted

When I try to use Xpedition of the UK Ordance Survey mapping sites I get a message saying that the Microsoft Silverlight account is invalid and saying I should sign up for a devleloper account. Both sites work fine in Chrome.

When I try to use Xpedition of the UK Ordance Survey mapping sites I get a message saying that the Microsoft Silverlight account is invalid and saying I should sign up for a devleloper account. Both sites work fine in Chrome.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Garmin Communicator Plug-In 4.2.0.0 BETA
  • 5.1.30514.0
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.1.0
  • GEPlugin
  • BT DesktopHelp plug-in for Mozilla Browsers
  • BT Management plug-in for Mozilla Browsers
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Please provide the link(s) you are having problems with. Also;

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Please provide the link(s) you are having problems with. Also; Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!

Question owner

Hello

Thanks for responding to my query. I have copied a link to one of the mapping programmes I use - the UK Ordnance Survey Getamap site and a screen shot showing the problem I have.

As you can see the map has a set of immovable text across it beginning 'Invalid credentials....'

I don't have this problem when I use the same site in Chrome

http://www.getamap.ordnancesurveyleisure.co.uk/?key=qDq-3dBtJQ6S8_jlktTQoA2

Hello Thanks for responding to my query. I have copied a link to one of the mapping programmes I use - the UK Ordnance Survey Getamap site and a screen shot showing the problem I have. As you can see the map has a set of immovable text across it beginning 'Invalid credentials....' I don't have this problem when I use the same site in Chrome [http://example.com http://www.getamap.ordnancesurveyleisure.co.uk/?key=qDq-3dBtJQ6S8_jlktTQoA2]
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

I see it. You are logged in, so you should not get that type of message. Go to the main page of the site. Go to your profile and make sure that everything is okay there.

Log out, then log back in. Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

I see it. You are logged in, so you should not get that type of message. Go to the main page of the site. Go to your profile and make sure that everything is okay there. Log out, then log back in. Is the problem still there? ---------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Thanks so much for getting back to me. I followed your instructions as far as 'Cache' but don't know where to find that. I went to the Cookies page and cleared the cookies for the Getamap site. Is the 'Cache' on that same page? I couldn't see it.

Thanks so much for getting back to me. I followed your instructions as far as 'Cache' but don't know where to find that. I went to the Cookies page and cleared the cookies for the Getamap site. Is the 'Cache' on that same page? I couldn't see it.
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Look at my last message for the instructions.

Look at my last message for the instructions.

Question owner

Sorry, but I don't know how to follow the instructions you gave. I'll have to continue using Chrome instead of Firefox.

Sorry, but I don't know how to follow the instructions you gave. I'll have to continue using Chrome instead of Firefox.
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Tell me what you do not understand. All of it, part of it?

Tell me what you do not understand. All of it, part of it?

Question owner

Hello, sorry it has taken a while for me to get back to you on this. I have followed your instructions. Sorry it took me a little while to do it but I'm not familiar with looking round the things you pointed me towards and it took me a bit to work it out. But I've done the things you suggested but it hasn't made any changes. I still get the same message across the web page. Thanks for your patience with this. If you have any more thoughts I'd be happy to have them.

Hello, sorry it has taken a while for me to get back to you on this. I have followed your instructions. Sorry it took me a little while to do it but I'm not familiar with looking round the things you pointed me towards and it took me a bit to work it out. But I've done the things you suggested but it hasn't made any changes. I still get the same message across the web page. Thanks for your patience with this. If you have any more thoughts I'd be happy to have them.
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes