Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Links in emails don't open in Firefox 33.1.1

  • 12 replies
  • 2 have this problem
  • 74 views
  • Last reply by cor-el

more options

I read the previous thread about this problem under FF 32 but wasn't able to respond there, so I'm starting a new thread.

I have had this problem for some time, back under FF 32. I even downloaded and reinstalled FF and when that didn't work, did the reset procedure. The update to 33.1.1 hasn't helped.

I'm running OS X 10.6.8 and Apple Mail v. 4.6. I keep FF open on my desktop after starting it. Usually it works OK when first started but then stops opening links or becomes erratic, sometimes opening them and sometimes not.

Any help/suggestions/news about this issue will be much appreciated.

All Replies (12)

more options

Hi, MaryRB!

Let's try this first, and see if it fixes anything:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Sometimes, a link is sent as a clickable link. Other times, it is just normal type. Check and see what you are getting.

Using your mouse, mark the printed link. Right click and select Open.

more options

Thanks, Topher, I have now done that and so far the links are working again. But that usually is the case when I first start or restart FF. Will I have to keep doing this?

more options

FredMcD, all the links that weren't working should have been clickable links. They come from sites like Facebook (notices of new posts) and Daily Kos (recommended articles). They work some of the time, including right after I have started FF, but not always.

more options

No, Mary.

Starting in Safe Mode starts Firefox with certain settings turned off that could possibly cause problems.

The next step is to go through the steps of the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article. We should be able to figure out which part of your settings is causing the problems.

When you figure out which problem it is, let us know. It can be helpful for us to help out others in the future.

If you need help in figuring it out, let me know.

more options

Thanks for the help. Topher. I pent the weekend following the instructions in the troubleshooting article. Here are my results - I'd appreciate your comments.

1. Starting in Safe Mode fixed the problem. I was able to leave FF open all day and still open email links.

2. Disabling hardware acceleration did not fix the problem.

3. Disabling all Extensions did work. However, when I open the Extensions page, it doesn't show that I have any installed. I do have a lot of Plug-ins. Are they the same thing - could one of them be the problem?

If so, I guess my next move would be to follow the instructions to disable half at a time and keep narrowing it down until I find the culprit but I'd like your feedback before I start that tedious process.

more options

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

OK, Fred McD, here it is. Thanks for your help.

Application Basics


Name: Firefox Version: 33.1.1 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:33.0) Gecko/20100101 Firefox/33.0 Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Troubleshooter Version: 1.1a Enabled: true ID: troubleshooter@mozilla.org

Graphics


Device ID: 0x9488 GPU Accelerated Windows: 0/1 Basic Vendor ID: 0x1002 WebGL Renderer: ATI Technologies Inc. -- ATI Radeon HD 4670 OpenGL Engine windowLayerManagerRemote: false AzureCanvasBackend: quartz AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 1 browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407 browser.startup.homepage: http://my.iwon.com/ browser.startup.homepage_override.buildID: 20141113143407 browser.startup.homepage_override.mstone: 33.1.1 browser.tabs.loadInBackground: false dom.mozApps.used: true extensions.lastAppVersion: 33.1.1 font.internaluseonly.changed: false gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d9: 3 gfx.blacklist.webgl.msaa: 4 layers.acceleration.disabled: true media.gmp-gmpopenh264.lastUpdate: 1416166071 media.gmp-gmpopenh264.version: 1.1 media.gmp-manager.lastCheck: 1416855154 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1416862289 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flip4mac wmv plugin: 0 plugin.state.silverlight: 0 print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 1515870810 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_resolution: 1515870810 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1416169315

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.7 Version in use: 4.10.7

NSS Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSSMIME Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSSSL Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSUTIL Expected minimum version: 3.17.2 Version in use: 3.17.2

Experimental Features


more options

Name: Troubleshooter This is used by Mozilla to get your system details. That is all it does. No Personal Information Is Collected.

At this time, that is the only add-on you have.


Please follow these instructions;


It could be the work of one of your programs, or even add / mal-ware.

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Appearance. Select the Default

Now, on the left again, select Plugins Go thru the list and set everything to Ask.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

mac

Possible Mal-Ware Scan For Macs {web link}

more options

I didn't have time to continue dealing with this problem over Thanksgiving, so was very grateful to be able to restart in Safe Mode which saved my sanity - thank you for telling me how!!!

Fred McD, I have now followed the instructions about plug-ins in your last response and will let you know if that fixes the problem. However I have questions about a couple of them.

Open H264 Video Codec by Cisco Systems: the option to always ask was grayed out. Is this an important program or should I change it to Never Activate?

Flip4Mac Windows Media and Silverlight are both disabled because they were old versions. Should I consider updating them? I know what Fiip4Mac does but I've never heard of Silverlight and didn't know I had it.

I followed your link about scanning for malware. Once of the first things the article recommends is to disable Java in FireFox Preferences but I can't figure out how to do that; none of the menus under the tabs mentions Java. I do have Java 6 in my Utilities applications folder. Should I uninstall it?

As always, I really appreciate any help and suggestions you can give me. I'm not afraid to poke around and try things on my Mac but these issues are beyond my level of expertise.

more options

Open H264 Video Codec; I don't know for sure what this is.

Should I consider updating them? Even if you are not using a program, you should update it. Old data can cause problems.

https://www.mozilla.org/en-US/plugincheck/ If something is reported as out of data, follow the provided link. If something is flagged as unknown, you will have to go to the programs web page to check it.

article recommends to disable Java I have not disabled Java. Go ahead and run the scan.

more options