Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not accepting my mouse interaction

  • 7 replies
  • 2 have this problem
  • 455 views
  • Last reply by FredMcD

more options

Firefox is not allowing me to interact with certain elements on webpages. Here is a list of some of the websites that I have trouble with:

- http://railsapis.codeschool.com/levels/1/challenges/1 and http://railscasts.com/episodes/417-foundation?autoplay=true

 I can't use the video controls

- https://soundcloud.com/jo-o-anderson-1/loreen-euphoria

 I can't use the seekbar.

- http://yashry.com/search?q=iPhone

 The arrows of the price range slider don't drag. Instead, the underlying text is selected.

I tried using Firefox on a friend's Mac and it's working properly. I guess it's a problem with an entry in my about:config, but I don't even know what to search for to describe this problem.

I'm using Firefox 33.1.1 on Mac OS X 10.10.1 (14B25).

Chosen solution

Setting dom.w3c_touch_events.enabled to 0 in about:config solved it.

Read this answer in context 👍 0

All Replies (7)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default http://kb.mozillazine.org/Preferences_not_saved

You may have a corrupt cookies.sqlite file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

more options

Thanks FredMcD for your reply.

Renaming the prefs.js file to prefs-old.js seems to solve the problem, which proves that an entry in my about:config is what's causing it.

Is there a way I can just remove the individual entry/entries causing this? I don't want to lose all my configurations.

more options

What you would have to do is print out the old prefs.js file, and compair it to a clean copy. As to what to check . . . . . .

BTW; this can be opened in a Word program. BUT make no changes unless you know what is going on.

Modified by FredMcD

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Make sure that you allow pages to choose their own colors.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:

more options

@FredMcD That's what I'm currently doing. Thanks.

more options

Chosen Solution

Setting dom.w3c_touch_events.enabled to 0 in about:config solved it.

Modified by RaMin0

more options

Good work. Happy Computing.