X
Tap here to go to the mobile version of the site.

Support Forum

Why does Firefox say www.google.com is insecure?

Posted

From my Firefox homepage, I get a message saying that google's certificate is invalid and I should not continue

From my Firefox homepage, I get a message saying that google's certificate is invalid and I should not continue

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Virtual Keyboard
  • Online Banking Extension
  • Content Blocker Extension
  • 5.1.30514.0
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Nitro PDF plugin for Firefox and Chrome

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/WINNT/en-US/

Extensions

  • Dangerous Websites Blocker 4.5.0.311 (content_blocker_6418E0D362104DADA084DC312DFA8ABC@kaspersky.com)
  • Safe Money 4.5.0.311 (online_banking_69A4E213815F42BD863D889007201D82@kaspersky.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Virtual Keyboard 4.5.0.311 (virtual_keyboard_294FF26A1D5B455495946778FDE7CEDB@kaspersky.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2:
  • adapterDeviceID: 0x0416
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 10-10-2013
  • driverDate2:
  • driverVersion: 10.18.10.3325
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • dom.allow_scripts_to_close_windows: True
  • extensions.lastAppVersion: 33.1.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1416343581
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1416343580
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npcontentblocker: 2
  • plugin.state.nponlinebanking: 2
  • plugin.state.npvkplugin: 2
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: Yes
  • Accessibility: Yes
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23378 answers

hello hamster, does it make a difference when you disable the scanning of encrypted connections within your kaspersky network settings?

hello hamster, does it make a difference when you disable the scanning of encrypted connections within your kaspersky network settings?

Question owner

Not being a techie, I don't know where to find this setting. Why would this be an issue on Firefox, but not on Internet Explorer, if both are protected by Kaspersky?

Not being a techie, I don't know where to find this setting. Why would this be an issue on Firefox, but not on Internet Explorer, if both are protected by Kaspersky?
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23378 answers

it's in settings > additional > network, next to the proxy server settings that are described at http://support.kaspersky.com/11148

it's in settings > additional > network, next to the proxy server settings that are described at http://support.kaspersky.com/11148

Question owner

Thanks, Philipp, but disabling the scanning of encrypted connections in Kaspersky doesn't make a difference. And again, this appears to be a Firefox issue, since I have no problem when using internet explorer.

Thanks, Philipp, but disabling the scanning of encrypted connections in Kaspersky doesn't make a difference. And again, this appears to be a Firefox issue, since I have no problem when using internet explorer.
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23378 answers

firefox would not show this warning if there was no interference with the secure connection or something with the certificate the site is serving is wrong (which is rather unlikely at a high traffic site like google.com).

what is the error code shown under technical details on the error page?

in case the error code equals sec_error_unknown_issuer, please attempt to add an exception on the bottom of the error page (but don't add it for real & inspect the certificate (see the screenshot attached for instructions): which issuer information does the certificate contain?

thank you!

firefox would not show this warning if there was no interference with the secure connection or something with the certificate the site is serving is wrong (which is rather unlikely at a high traffic site like google.com). what is the '''error code''' shown under ''technical details'' on the error page? in case the error code equals ''sec_error_unknown_issuer'', please attempt to add an exception on the bottom of the error page (but '''don't''' add it for real & inspect the certificate (see the screenshot attached for instructions): which '''issuer information''' does the certificate contain? thank you!