X
Tap here to go to the mobile version of the site.

Support Forum

untrusted connection

Posted

Whwnever I try to connect to any website Firefox come up with cant confirm your connection is secure - invakid security certificate - not trusted etc. I have just had ti refresh my laptop (win 8) and am busy reinstalling evrything so must be something od haopening?

Whwnever I try to connect to any website Firefox come up with cant confirm your connection is secure - invakid security certificate - not trusted etc. I have just had ti refresh my laptop (win 8) and am busy reinstalling evrything so must be something od haopening?

Chosen solution

Hi again. I think I may have solved it. When I turned off Avast, Firefox worked fine. Because I had to refresh my PC I reinstalled the latest version of Avast (Avast 2015). There is a setting in Avast which seems to want to block Firefox. scan HTTPS in tools/web - I turned that off and all is OK now.

Read this answer in context 3

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Linux; Android 4.4.4; SGP312 Build/10.5.1.A.0.283) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.59 Safari/537.36

More Information

philipp
  • Top 25 Contributor
  • Moderator
5287 solutions 23361 answers

hello polarman, what kind of security software are you using on the laptop and is the date/time of the system clock set correctly?

hello polarman, what kind of security software are you using on the laptop and is the date/time of the system clock set correctly?

Question owner

Hi. Many thanks your help. Security is simply avast Av. System time was set for utc minus three hours as I live abroad usually but in UK at the moment. Changed time to match UK but still the same. Cant figure it out. All suggestions very welcome :)

Hi. Many thanks your help. Security is simply avast Av. System time was set for utc minus three hours as I live abroad usually but in UK at the moment. Changed time to match UK but still the same. Cant figure it out. All suggestions very welcome :)

Chosen Solution

Hi again. I think I may have solved it. When I turned off Avast, Firefox worked fine. Because I had to refresh my PC I reinstalled the latest version of Avast (Avast 2015). There is a setting in Avast which seems to want to block Firefox. scan HTTPS in tools/web - I turned that off and all is OK now.

Hi again. I think I may have solved it. When I turned off Avast, Firefox worked fine. Because I had to refresh my PC I reinstalled the latest version of Avast (Avast 2015). There is a setting in Avast which seems to want to block Firefox. scan HTTPS in tools/web - I turned that off and all is OK now.
philipp
  • Top 25 Contributor
  • Moderator
5287 solutions 23361 answers

great, thanks for reporting back. if this https scan feature by avast is not implemented properly firefox might detect that as some kind of a man-in-the-middle attack, since avast is tampering with the encrypted connection...

great, thanks for reporting back. if this https scan feature by avast is not implemented properly firefox might detect that as some kind of a man-in-the-middle attack, since avast is tampering with the encrypted connection...

Question owner

Yes...many thanks again your help. I would guess that the new Avast will catch a few of us out for this reason. Cheers and thanks

Yes...many thanks again your help. I would guess that the new Avast will catch a few of us out for this reason. Cheers and thanks