Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Logging in to Firefox Sync does not work because of "SecurityError: The operation is insecure"

  • 3 replies
  • 7 have this problem
  • 3166 views
  • Last reply by Subsurf

more options

Hello everybody,

I wanted to upgrade my Firefox Sync account from the old to the new version. Unfortunately the login page does not load on my laptop. On my Android devices everything is working fine, so I could already set up the new account from there, I just can't login to my new sync account on my laptop. I am running Firefox 33.1 on Windows 8.1 Pro 64bit.

The about:accounts landing page loads as normal, but clicking on the button to log in does not load the login form, the white box just stays empty. I asked my dear friend Google who gave me some answers (seems to be a common problem...), but none of them helped me.

The debugging console displays the error "SecurityError: The operation is insecure" directly after loading about:accounts?action=signin. Opening https://accounts.firefox.com/signin and https://accounts.firefox.com/signup also results in the same error and an empty white box. https://accounts.firefox.com/legal/privacy works as normal though.

I did not find a solution to work around that SecurityError up to now.

Chosen solution

I found another answer which finally solved my issue! Apparently the about:accounts page throws this error because I configured Firefox to always ask before accepting a cookie. https://github.com/mozilla/fxa-content-server/issues/1857

Weird stuff anyway but now I could work around it.

Read this answer in context 👍 0

All Replies (3)

more options

hello Subsurf, does it work when you launch the browser in firefox safe mode once for testing purposes?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Oh sorry forgot to mention, I workd through the answers provided by Google and already tried safe mode, switched to the standard theme and also removed all prefered languages except "en-us", but none of that helped.

more options

Chosen Solution

I found another answer which finally solved my issue! Apparently the about:accounts page throws this error because I configured Firefox to always ask before accepting a cookie. https://github.com/mozilla/fxa-content-server/issues/1857

Weird stuff anyway but now I could work around it.