X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes

Posted

my mozilla crashes even while on safe, I did disabled the add ons, I did re installed, I tried to find it this happened after some download, and run a malware software through several times. The first time I tried with safe, it lasted longer, I noticed a couple of times, that when I tried a new page I would not get the home page (which I listed as Google ) but got yahoo, so went looking for some strange software in the control panel, I did remove several that I barely used, but did not find anthing suspicious. Here is a copy of the report from today Crash ID: bp-c337a86b-ebc0-42f4-bf7c-c63942141111

my mozilla crashes even while on safe, I did disabled the add ons, I did re installed, I tried to find it this happened after some download, and run a malware software through several times. The first time I tried with safe, it lasted longer, I noticed a couple of times, that when I tried a new page I would not get the home page (which I listed as Google ) but got yahoo, so went looking for some strange software in the control panel, I did remove several that I barely used, but did not find anthing suspicious. Here is a copy of the report from today Crash ID: bp-c337a86b-ebc0-42f4-bf7c-c63942141111

Chosen solution

That report is an "out of memory" crash. It says 92% of system memory was in use, which is dangerous territory for Firefox. I'm guessing since you run XP that it doesn't make sense to upgrade your memory. You might be limited in how many tabs you can have open or what kind of media you run.

Regarding the Yahoo problem, does it appear on a new tab (Ctrl+t)? There is a setting for changing that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Some gotchas:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. You'll need to find that in the Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column click Extensions. Be skeptical and try disabling everything you can live without for 48 hours, and removing anything unrecognized.

If the change works during your session, but at the next startup is back to Yahoo: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; SearchToolbar 1.2; GTB7.5; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; BOIE8;ENUS)

More Information

jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Chosen Solution

That report is an "out of memory" crash. It says 92% of system memory was in use, which is dangerous territory for Firefox. I'm guessing since you run XP that it doesn't make sense to upgrade your memory. You might be limited in how many tabs you can have open or what kind of media you run.

Regarding the Yahoo problem, does it appear on a new tab (Ctrl+t)? There is a setting for changing that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Some gotchas:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. You'll need to find that in the Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column click Extensions. Be skeptical and try disabling everything you can live without for 48 hours, and removing anything unrecognized.

If the change works during your session, but at the next startup is back to Yahoo: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

That report is an "out of memory" crash. It says 92% of system memory was in use, which is dangerous territory for Firefox. I'm guessing since you run XP that it doesn't make sense to upgrade your memory. You might be limited in how many tabs you can have open or what kind of media you run. Regarding the Yahoo problem, does it appear on a new tab (Ctrl+t)? There is a setting for changing that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''newtab''' and pause while the list is filtered (3) Double-click the '''browser.newtab.url''' preference and enter your preferred page: * ''Page thumbnails (default)'' => about:newtab * ''Blank tab'' => about:blank * ''Built-in Firefox home page'' => about:home * ''Any other page'' => full URL to the page Press Ctrl+t to open a new tab and verify that it worked. Fixed? Some gotchas: ''If Firefox won't let you edit this setting:'' you may have something called SearchProtect on your system. You'll need to find that in the Control Panel. ''If Firefox lets you save your change but ignores it:'' one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column click Extensions. Be skeptical and try disabling everything you can live without for 48 hours, and removing anything unrecognized. ''If the change works during your session, but at the next startup is back to Yahoo:'' you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: [[How to fix preferences that won't save]]. Any luck?
FredMcD
  • Top 10 Contributor
4266 solutions 59816 answers

In the address bar, type about:crashes. Note: If any reports do not have BP in front of the numbers, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

In the address bar, type '''about:crashes. Note:''' If any reports do not have '''BP''' in front of the numbers, click it and select '''Submit'''. Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in.
FredMcD
  • Top 10 Contributor
4266 solutions 59816 answers

These were flagged in the crash report.

l3codecx.ax = MPEG Layer-3 Audio Codec for Microsoft DirectShow

odbcint.dll = Windows ?

xpsp2res.dll = Windows

icudt52.dll = IBM Corporation

These were flagged in the crash report. l3codecx.ax = MPEG Layer-3 Audio Codec for Microsoft DirectShow odbcint.dll = Windows ? xpsp2res.dll = Windows icudt52.dll = IBM Corporation

Question owner

bp-e768564d-e707-4eb2-a894-9fc192141111 11/11/2014 11:55 AM bp-44d8cd2e-ef4c-4aba-a56a-18d2b2141111 11/11/2014 11:55 AM bp-e9e30369-b590-4f6a-89df-d50bf2141111 11/11/2014 11:55 AM bp-ed22b92e-3708-44c3-97c3-7801d2141111 11/11/2014 11:11 AM bp-91a96df7-d5b5-49bf-ba40-1e7252141111 11/11/2014 10:48 AM bp-c337a86b-ebc0-42f4-bf7c-c63942141111 11/11/2014 10:19 AM bp-3c4a77cb-8f92-4501-bf5d-6d82a2141106 11/5/2014 4:23 PM bp-9ad25c09-9cd2-43ff-905b-d905e2141106

bp-e768564d-e707-4eb2-a894-9fc192141111 11/11/2014 11:55 AM bp-44d8cd2e-ef4c-4aba-a56a-18d2b2141111 11/11/2014 11:55 AM bp-e9e30369-b590-4f6a-89df-d50bf2141111 11/11/2014 11:55 AM bp-ed22b92e-3708-44c3-97c3-7801d2141111 11/11/2014 11:11 AM bp-91a96df7-d5b5-49bf-ba40-1e7252141111 11/11/2014 10:48 AM bp-c337a86b-ebc0-42f4-bf7c-c63942141111 11/11/2014 10:19 AM bp-3c4a77cb-8f92-4501-bf5d-6d82a2141106 11/5/2014 4:23 PM bp-9ad25c09-9cd2-43ff-905b-d905e2141106
FredMcD
  • Top 10 Contributor
4266 solutions 59816 answers

You have a high memory usage, and JavaScript was mentioned.

Total Virtual Memory 2147352576

Available Virtual Memory 2022391808

System Memory Use Percentage 92

Available Page File 13320192

Available Physical Memory 164495360


Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

You have a high memory usage, and JavaScript was mentioned. Total Virtual Memory 2147352576 Available Virtual Memory 2022391808 System Memory Use Percentage 92 Available Page File 13320192 Available Physical Memory 164495360 ------------------- '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.