Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

pdf forced dowload

  • 5 replies
  • 1 has this problem
  • 1 view
  • Last reply by CoryMH

more options

I want to use the Firefox viewer for pdf files and have selected that choice under tools/options/applications. However, pdf files immediately move to save file. I just want to use the viewer. Thanks.

All Replies (5)

more options

Hello,

You are using a very old version of Firefox. Please update to the latest (version 33.0.3) and see if you still have problems:

  • Help > About Firefox

Or download a new copy at:

After updating, are PDF's now opened in the viewer?


Unrelated: After updating Firefox, it might also be a good idea to update Flash for the security updates (go to one of the two links):

more options

Thanks for the quick response. I returned to v.21 because the new FF versions make the toolbar and bookmarks so small that my wife and I could not read them.

There are two other pdf files (application/force-download) and (x-unknown stream) that do not have the option to use adobe reader in Firefox.

more options

There are many security vulnerabilities that have been patched since version 21, see:

If the font is small in the toolbar and bookmarks, that can be fixed through your Windows settings. Please see the tutorial:


If pages themselves have small font, you can also use Firefox's zoom feature. This will help increase the size of web pages.

  • To make things bigger, press Ctrl and + at the same time.
  • To make things smaller, press Ctrl and - at the same time.
  • To reset the size back to normal, press Ctrl and 0 at the same time.

You can also use the NoSquint. add-on to change the default zoom level for all websites at once. After setting your global zoom level, you can still fine-tune the zoom on individual sites.

Using NoSquint:

  1. After installing NoSquint, make sure you have the Add-on Bar displayed:
    • Right-click the new tab button ("+") or a blank area of the tab bar to the right of it and choose Add-on Bar from the shortcut menu.
  2. Click the % on the Add-on Bar to call up site preferences, then click the Global Settings button, then the Zooming tab.
    • You can experiment with sizes larger than 125%, but it's not recommended that you go higher than 150% unless you have a large high-resolution monitor.

If there are particular sites that still present a problem, feel free to post their URLs.


As for those PDF files, what site are you downloading them from? Can they be viewed in Adobe Acrobat Reader after saving to your computer?

more options

I will try the FF update later today. Can I apply cited windows font adjustment only to FF? The other toolbar font in windows are fine.

more options

Edit: Found this extension that might be what you are looking for:

  • https://addons.mozilla.org/en-US/firefox/addon/theme-font-size-changer/
  • I find that changing the "Zoom" setting changes the entire Firefox window, including the web page font. If the page font becomes too large, see my previous post about NoSquint - once you adjust that "Zoom" setting you can adjust the settings in NoScript so that all your fonts are a comfortable size.

As for changing the Windows Font settings, I believe those font changes are global - changing it will affect all applications. I am surprised that you only experience the issue in newer versions of Firefox as it should be using the settings used by all of your applications.

<strike>The only method I know to change the toolbar font sizes requires the Stylish extension and for you to create a new style.

Please post back if you need more help with this.</strike>


As for those PDF files, what site are you downloading them from? Can they be viewed in Adobe Acrobat Reader after saving to your computer?

Modified by CoryMH