Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have Thunderbird on Windows 8.1 and it will not allow me to open an excel spreadsheet from an e-mail.

  • 20 replies
  • 1 has this problem
  • 66 views
  • Last reply by Toad-Hall

more options

If I receive an e-mail with an excel attachment on it or an attachment that has 'dat.' at the4 end of it, the attachment won't open when I try to open it. Most frustrating.

All Replies (20)

more options

From the menu bar select Tools-Options-Attachments-Incoming

What do you have specified there for an Excel file?

No menu bar with Tools? Press the alt key to make it appear.

more options

I have the xls and xlsx files listed and beside that I have the phrase 'always ask". Other than that, I am not sure what to look for. When I try to open the xls file, a box flashes in the top left hand corner of the screen and then goes off. It is so quick that I don't know what is on the screen.

more options

Maybe you have moved some programs around on your drive and that path is not good anymore. I would delete those entries and then try to open an Excel file. You should be asked what to open it with and you can navigate to where your Excel program is located.

more options

I have not moved any programs around to my knowledge. When I open it, it does not point me to an Excel file space. There is no mention of Excel at all.

more options

First question, do you have Excel or other software on your computer that can open these files. Secondly, did you delete the existing entries in the incoming attachment table?

more options

Yes I do have Excel on my computer but I can't seem to make it interface with Thunderbird. Secondly, I don't understand the nature of your second question. What existing entries am I supposed to delete?

more options

When I asked you to check the Tools-Options-Attachments-Incoming you said that you had a couple of entries there for Excel worksheets. Select them and from the drop down list select Delete this action. Then find an email with an Excel attachment and try to open it.

Modified by user01229325

more options

Nope, still didn't work. Would deleting and re-installing my Microsoft Office Professional Plus Program 2013 Help? (drawing at straws here).

more options

I doubt it.

What happens when you try to open the file after deleting the entries in the attachment table in Thunderbird?

more options

Nothing happened. A box flashed in the upper left hand corner (too fast for me to see what it was) and then nothing. It wouldn't open.

more options

That is strange. With no file attachment association in the Thunderbird table it should ask what you want to do with the file. You are sure you deleted all Excel file types from the table mentioned above?

more options

Yes, from the "attachments" folder, I deleted xls and the xlsx lines and then tried to open the two different attachments and all I got was the "Choose Helper Application" box. Didn't help much although I tried a few things in there.

more options

The helper app would be Excel. Did you navigate to where that is on your system and select it?

more options

I got into it. What I had to do though is to send the e-mail attachment to the desk top and then go to the Excel screen (or App I guess, in Windows 8.1) and then open the Excel and get the attachment from the desk top. That worked. It opened the spreadsheets from the three e-mails that I received.

more options

It seems as if there was no way that the Excel sheet could be directly opened from Thunderbird. Rather, I had to go a round about way to opening it.

more options

To get Thunderbird to open a dat Text file file using Excel.

Right click on attachment and choose 'Open' A window opens asking what to use. select 'Open with' click on the drop down selection and choose 'Other'. A small window opens showing a selection. If Microsoft Excel is not in the list, click on 'Browse' button a window opens showing your 'Program files'

If your OS is Win8.1 and 64bit version and Office 2010 32bit version, to find Office programs the default path may say: C:\Program Files\Microsoft Office\ This is the 64bit version path for Win8. It is also the standard directory if using Vista 32bit.

So if your OS is Win8.1 64bit version you need to choose the 32bit path: C:\Program Files (x86)\Microsoft Office\

locate and click on 'Microsoft Office' click on 'Office 12' folder The number eg: '12' depends on the version: I have 2007 so if you use 2010 then it will be in Office 14 folder - list is below to choose correct folder.

  • 9 = Office 2000
  • 10 = Office 2002/XP
  • 11 = Office 2003
  • 12 = Office 2007
  • 14 = Office 2010

Now you should see 'Excel.exe' , This is the file you are looking for. Select 'Excel.exe' and click on 'Open'

If you want Thunderbird to remember this and use it each time to open dat file, select the checkbox 'Do this automatically for files like this from now on. click on Ok

This will now open a dat file from the attachments in an email using excel. It will be listed in Tools-Options-Attachments-Incoming tab.

more options

I have Microsoft Office 2013. How do I adjust things to accommodate this one. I am not sure whether or not it is 32 or 64 bit. I did not see Windows Excel in the Program Files box.

more options

If Win8 64bit C:\Program Files (x86)\Microsoft Office\Office15\EXCEL.EXE

select : Program Files (x86) then : Microsoft Office then : Office15 then : Excel.exe

Otherwise: C:\Program Files\Microsoft Office\Office15\EXCEL.EXE select : Program Files then : Microsoft Office then : Office15 then : Excel.exe

It will be in one of the above locations.

more options

When I get to the "Choose Helper Application", I click on Windows and I get Windows 15. Then, when I click onto Windows 15, I get a message, "osprearm.exe"! Nothing else comes up in that column! I think that this is where the "excel" screen should come up...or not?

more options

re: When I get to the "Choose Helper Application", I click on Windows there were no instructions to click on 'Windows' nor 'windows15' these folders were never mentioned. You need to follow the instructions.

When you click on 'Other' it will open the 'Choose Helper Application' window. click on 'Browse' button a window opens showing all your 'Program files' etc Select: 'Program Files' folder select : 'Microsoft Office' folder select: 'Office15' folder select: Excel.exe file and click on 'Open'

If excel .exe is not in the 'Office15' folder stated above, Then you have win8 64bit OS, so need to look in the other directory. then check: Select: 'Program Files(x86)' folder select : 'Microsoft Office' folder select: 'Office15' folder select: Excel.exe file and click on 'Open'.