Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 8 replies
  • 9 have this problem
  • 1154 views
  • Last reply by anuswara

more options

bp-ce9b1f28-fc79-41f9-8c3b-4b37f2141031 bp-4b87f067-3cab-43bc-a0f0-766592141031 bp-94e6f181-6c1f-43e5-b4dd-8b9fb2141031 bp-5397ee38-aca2-4de3-953a-583de2141031

Chosen solution

You're welcome.

New Firefox releases might use more advanced features in the graphics display driver and this might cause issues if the driver isn't up to date or otherwise not compatible. Firefox doesn't always detect this and disable hardware acceleration automatically and you may have to do this yourself in case of issues.

Read this answer in context 👍 0

All Replies (8)

more options

These programs were flagged in the crash reports;

sgfxu32.dll = Graphics Adapter WDDM Software

nvwgf2um.dll = NVIDIA Compatible D3D10 Driver


Perform a System File Check to fix the corrupted system files http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

See if there are updates for your graphics drive drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

These were also flagged;

flvsniff.dll = Free Download Manager

fdmumsp.dll = Free Download Manager

more options

Hi,

SFC found no problems and the graphics drivers are already at the latest. In fact I upgraded the graphic drivers a week ago and it has been working fine until yesterday. Quit Download Manger too. However problem still happens.

Any other suggestions appreciated.

Greg

more options

BTW - Firefox Safe mode works OK.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Hi,

That seems to have fixed it. Can you explain why it used to work with HA enabled and now it does not?

Thanks,

Greg

more options

Chosen Solution

You're welcome.

New Firefox releases might use more advanced features in the graphics display driver and this might cause issues if the driver isn't up to date or otherwise not compatible. Firefox doesn't always detect this and disable hardware acceleration automatically and you may have to do this yourself in case of issues.

more options

sorry what GPU you have? I have the same issue at ff shutdown: GTX650 + latest driver. have I to buy a newer GPU to be able to leave H/W acceleration enabled in FF?

"New Firefox releases might use more advanced features in the graphics display driver and this might cause issues" please what newer features in FF36? I dont find them in ff36 changelog. do you have a list of GPUs not supported by FF? gtx650 is not supported starting from ff36 while it is supported until ff35? should Mozilla guarantee the compatibility with nvidia drivers or should nvidia guarantee the compatibility with latest FF releases?

Modified by anuswara