Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons Update HELP!

  • 2 replies
  • 1 has this problem
  • 34 views
  • Last reply by cor-el

more options

Hello everyone! I just started using Mozilla Firefox Web browser again, and I wanted to check if my add-ons were up to date. Well, it says that 2 of my add-ons, which are Java(TM) Platform SE 7 U67 (version 10.67.2.1) & Shockwave Flash (version 15.0.0.152) both are potentially vulnerable plugins.

I click on update now, and it directs me to these URLs: http://www.oracle.com/technetwork/to...4-1972960.html for Java & http://helpx.adobe.com/security/prod...apsb14-22.html for Shockwave Flash

I'm really not understanding where I am supposed to download these security fixes, or if there are even any? Also, how do I find out if those two versions are the latest? I'm so confused. I'm not too knowledgeable about Firefox & their features. When I go to my programs on my laptop, it says that my Java is up to date & so is my Adobe Shockwave. Is there a difference between those & the plug-ins?

If anyone can please help me I would greatly appreciate it! I'm afraid something terrible will happen if I do not fix these problems!

All Replies (2)

more options

Here is a screenshot of the add-ons that need to be updated.

more options

You can find the latest Flash player versions for Firefox on this page:


You can find the latest 32 bit Java versions on the Oracle website.

See Java Platform > Java SE 7u71/8u25 (JRE Download;32 bit for Windows)