Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Firefox 33 installation is being plaqued by a malicious website - how do I get rid of it?

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by jscher2000

more options

I have the current version of Firefox installed on my new laptop. Earlier this week, I tried downloading and installing a free font from what looked like an excellent source for fonts. However, instead of the font I was wanting to install, all I got was a mess of proograms that I did not want, and had no use for. One of them, snap.do, a Google-clone search site inserted itself into Firefox and began restoring all settings to their defaults. (I have taken care of that.)

Even after uninstalling all of the programs and running both an anti virus scan, an anti malware scan, and even after cleaning up my hard drive with CCleaner and rebooting, two problems remain. First, on every new web page (even within the same websites) up to four or five blank "Ad by SmartChoices|Close" lines appear, usually scattered through the web page. These must be closed out before page navigation becomes fully functional. Second, on some websites when I move from one sheet within a website to another, while the new page is loading, the download is redirected to a different website I absolutely have no interest in, and do not want showing up in my history.

I have checked, and these problems do not show up on Internet Explorer, so it looks like it is just Firefox that is plagued. Thus I have two questions: what is the best way to get rid of these problems? Second, how do I report a malicious website that clearly needs to be blocked?

Note: your educated guesses about my current browser & os are spot on. However, what does 5.1.30514.0 refer to?

All Replies (2)

more options

The plugin information listed on the forum is the description from below the actual plugin name. To see the full details, you can use the Add-ons page, Plugins section. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. If I had to guess, I'd say Silverlight.


One of your extensions looks to be the culprit behind the Smart Choices ads: "SMartOnes 4.0". I know you have been through the Windows Control Panel, Uninstall a Program looking for crap, but I'll still recommend one more check as part of this suggested cleaning procedure:

Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Finally, you can "mop up" remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware.

Are you able to get rid of the ads?

more options

Regarding the Snapdo on the new tab, you can fix that here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Some gotchas:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page.

If the change works during your session, but at the next startup is back to Snapdo: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save. Some utility software like Advanced SystemCare also will roll back browser settings (either between sessions or at Windows restart).

Any luck?