Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error Printing Shipping Labels

  • 22 replies
  • 9 have this problem
  • 124 views
  • Last reply by solkeys

more options

I have been printing shipping labels from PayPal for several years now, almost everyday and this just started Oct 16th or 17th. I can no longer print shipping labels using FireFox. The small window opens up and then hangs with a message Please wait....processing. I CAN print the same label using Chrome. I have reset Firefox, uninstalled and reinstalled it, updated to the latest and greatest Java and Adobe reader, disabled the firewall, but can't seem to get it to work.

All Replies (20)

more options

I think the small window is going to load a PDF. Is that your experience? Is Firefox set to use the Adobe Acrobat plugin as the viewer?


General suggestions for problems loading page from sites:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

You also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

I do believe the smaller label window is a PDF and I have tried both the plugin and the external reader with the same results. However, the actual label that prints is created using Java.

I did perform both your suggestions, but those had already been once before, including uninstalling Firefox. The cache showed minimum content and then 0 once I cleared it. The cookies were removed from the Paypal popup window previously and this time from the main (parent) window.

Results still the same. Adobe Acrobat 11.0.9.29 and Java Platform SE 8 U25 11.25.2.18.

Each time I attempt to open a label screen, it counts against the label and eventually shows maximum attempts. I will have two more labels created tomorrow that I can test with.

more options

Hmm, another user is reporting problems with Java 8. That might be the issue. I see some recent discussion along those lines on other sites, that Java 8 has stricter security that is not compatible with the Pitney Bowes site (somehow relevant to these labels):

I can't be sure it's completely up-to-date from a security perspective, but Java 7 release 71 is available on the following page -- you want the full 28 megabyte "offline" installer:

http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

(Release 72 looks very similar but from the description, most people should use 71 instead.)

I'm not sure whether you can install version 7u71 without first uninstalling 8u25.

more options

Thank you for your help. I'm going to uninstall Java 8 and install 71. Results pending.

more options

Yeah, still the same result.

more options

Here is the page source that comes up using Chrome:


<frameset rows='285,1,*' cols='*' framespacing='0' frameborder='No' border='0'>

<frame src='https://ibdswebp8-ext.pb.com/images/USPS/HTMLFolders/HTML19/hb26101d6-a3e0-498f-84b4-884812130c59.htm' name='mainFrame' scrolling='AUTO' noresize>

<frame src='https://ibdswebp8-ext.pb.com/images/USPS/HTMLFolders/HTML19/fb26101d6-a3e0-498f-84b4-884812130c59.htm' name='topFrame' scrolling='NO' noresize>

<frame src='https://ibdswebp8-ext.pb.com/images/USPS/HTMLFolders/HTML19/sb26101d6-a3e0-498f-84b4-884812130c59.htm' name='middleFrame' scrolling='YES' noresize>

</frameset> <noframes> <body> </body> </noframes>

Modified by drives

more options

In Firefox, apparently the onload function is not loading.

<body onload=javascript:document.location='https://ibdswebp8-ext.pb.com/images/USPS/HTMLFolders/HTML19/pb26101d6-a3e0-498f-84b4-884812130c59.htm'> Please wait ...........processing </body>

more options

Hi drives, thanks for diving into the code.

It sounds as though it may be a change in Firefox 33. I don't know whether there is a quick fix, for example, disabling Firefox's popup blocker, or whether the site will need to update how it is redirecting the page if Firefox no longer accepts that style of coding.

(As far as I know, it was never right to use javascript: in the value of the onload attribute; that was only used in the value of the href attribute.)

I'll keep this tab open in case I think of a workaround that isn't too complicated to use.

more options

It's strange: if I put that onload into a document, it redirects immediately, but of course it's just a sample label at this point.

https://www.jeffersonscher.com/res/onload.html

more options

Yep, works for me too, in Firefox. I opened a ticket with PayPal since that's who gets paid for all this. We'll see what they come up with.

more options

I am having the same problem. I don't uderstand the instruction what to do.

more options

PayPal was no help either, but no surprise. I loaded Firefox on another machine on our network and it would not load up the label either. So that pretty much eliminates anything going on with the PCs. The trouble, whatever it is, lies upstream, somewhere.

more options

Hi solkeys, maybe there is a solution or workaround in another thread, but I haven't seen it yet. You might have to use a different browser for the site.

more options

Another work around is to view the page source of the label window, copy the URL from the onload function, paste it back into a Firefox window, and it works just fine. At least it does for me. That said, using a different browser like Chrome, works too.

more options

A more automated approach to that workaround would be to run a script in Firefox's Web Console. If you want to try it:

(1) Select and copy this long line of script:

var f=document.body.onload.toString(); var dest=f.substr(f.indexOf("location=")+10); dest=dest.substr(0, dest.indexOf("'")); document.location.href=dest;

(2) While viewing the non-loading page, press Ctrl+Shift+k to open Firefox's web console in the lower part of the tab

(3) Next to the caret (>>) paste the script and press Enter to run it. It should find that URL and load it.

If the tab continues to be stuck, you could change the last command to open a new window/tab and see whether that works any better:

var f=document.body.onload.toString(); var dest=f.substr(f.indexOf("location=")+10); dest=dest.substr(0, dest.indexOf("'")); window.open(dest, "_blank");

If one of those works, you could convert it to a bookmarklet, which is a button on your Bookmarks Toolbar or Bookmarks Menu that runs a script instead of loading a page. Details to follow if relevant.

more options

The script in step 1 worked. How do we convert it to a bookmarklet?

more options

It did return these:

Error in parsing value for 'WIDTH'. Declaration dropped. fe909a2c1-30f3-4229-8bc1-6e3821499075.htm

Error in parsing value for 'HEIGHT'. Declaration dropped. fe909a2c1-30f3-4229-8bc1-6e3821499075.htm

more options

Does the popup window display the menu bar or Bookmarks Toolbar? If so...

To create a bookmarklet:

(1) Copy this version of the script:

javascript:var f=document.body.onload.toString(); var dest=f.substr(f.indexOf("location=")+10); dest=dest.substr(0, dest.indexOf("'")); document.location.href=dest; void 0;

(2) Right-click the destination (Bookmarks Toolbar or Bookmarks menu), and choose New Bookmark

(3) Paste the script into Location

(4) Assign any name you like in Name

(5) Click Add Bookmark

Then clicking the bookmark on the toolbar or selecting it from the menu should run the script against the currently displayed page.

more options

The popup window does not have the Bookmark Toolbar as shown in the attached screen shot.

more options

Hmm, I was afraid of that. If you normally display the Bookmarks Toolbar, you can change a setting to prevent popups from hiding it. I haven't tested this myself:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste open and pause while the list is filtered

(3) Double-click the dom.disable_window_open_feature.personalbar preference to switch its value from false to true.

Then, in the other tab/window, you can test the pop-up.

  1. 1
  2. 2