X
Tap here to go to the mobile version of the site.

Support Forum

Firefox opens all adobe files with firefox web browser. I disabled add-on, but it still does it. How can i disable this feature?

Posted

All adobe files now automatically open in firefox web browser, even when opening them from widows explorer. I want all adobe files to be opened in adobe reader as a default. Yet I disable the plugin Adobe Acrobat 11.0.9.29 and it still does this. I can't use firefox this way.

All adobe files now automatically open in firefox web browser, even when opening them from widows explorer. I want all adobe files to be opened in adobe reader as a default. Yet I disable the plugin Adobe Acrobat 11.0.9.29 and it still does this. I can't use firefox this way.

Additional System Details

Installed Plug-ins

  • Bitdefender QuickScan Web Netscape Plugin
  • Google Update
  • ActiveTouch General Plugin Container Version 105
  • Shockwave Flash 15.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.2.152
  • 5.1.30514.0
  • iTunes Detector Plug-in
  • Citrix Online App Detector Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Nitro PDF plugin for Firefox and Chrome
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 32.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0.3/WINNT/en-US/

Extensions

  • Bitdefender QuickScan 0.9.9.142 ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Bitdefender Wallet 2.0 (bdwteff@bitdefender.com)
  • TrafficLight 0.2.17 (trafficlight@bitdefender.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • SmartPrintButton 1.0 (quickprint@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 8-8-2013
  • driverDate2:
  • driverVersion: 9.18.10.3272
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.frecency_experiment: 1
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
  • browser.startup.homepage: https://www.google.com/maps/@44.1454465,-120.5834016,7z
  • browser.startup.homepage_override.buildID: 20140923175406
  • browser.startup.homepage_override.mstone: 32.0.3
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 32.0.3
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1413199203
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • plugin.importedState: True
  • plugin.state.nppdf: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1412569377

Misc

  • User JS: No
  • Accessibility: No
AliceWyman
  • Moderator
240 solutions 2597 answers

1) If Firefox is opening PDF files with the built-in viewer and you would rather use Adobe Reader, see How to disable the built-in PDF viewer and use another viewer

2) To reset Adobe Reader as the default PDF application, even when you open a PDF file using Windows Explorer:

Open Adobe Reader, go to Edit -> Preferences -> General and use the option, "Select Default PDF Handler". Select Adobe Reader XI, as shown below, then reboot. Ref:

1) If Firefox is opening PDF files with the built-in viewer and you would rather use Adobe Reader, see [[How to disable the built-in PDF viewer and use another viewer]] 2) To reset Adobe Reader as the default PDF application, even when you open a PDF file using Windows Explorer: Open Adobe Reader, go to Edit -> Preferences -> General and use the option, "Select Default PDF Handler". Select Adobe Reader XI, as shown below, then reboot. Ref: * [/questions/1014919#answer-618531]
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

Note that Firefox will only try to take over some file extensions if Firefox is set as the default browser, so you may want to consider to set another browser as such.

You may have to reset this pref and possibly disable the internal PDF Viewer.

  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer altogether.

See also:

Note that Firefox will only try to take over some file extensions if Firefox is set as the default browser, so you may want to consider to set another browser as such. You may have to reset this pref and possibly disable the internal PDF Viewer. *plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml You can set the pdfjs.disabled pref to true on the <b>about:config</b> page to disable the build-in PDF viewer altogether. See also: *Tools > Options > Applications *http://kb.mozillazine.org/File_types_and_download_actions
AliceWyman
  • Moderator
240 solutions 2597 answers

For the record, here's the bug report on Firefox associating itself with PDF files on Windows, even though Adobe Reader is already set as the default:

  • Bug 1049521 - Be less aggressive about non-primary file type associations in Firefox on Windows

(Read Bugzilla Etiquette before commenting in bugs)

For the record, here's the bug report on Firefox associating itself with PDF files on Windows, even though Adobe Reader is already set as the default: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1049521 Bug 1049521] - Be less aggressive about non-primary file type associations in Firefox on Windows (Read [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] before commenting in bugs)
AliceWyman
  • Moderator
240 solutions 2597 answers

kevincrath, Were you able to solve the problem using any of the suggested fixes, or do you still need more help?

Note that a fix for bug 1049521 was just uplifted to Firefox 33 so make sure you update Firefox to the latest version.

'''kevincrath, ''' Were you able to solve the problem using any of the suggested fixes, or do you still need more help? Note that a fix for [https://bugzilla.mozilla.org/show_bug.cgi?id=1049521 bug 1049521] was just uplifted to Firefox 33 so make sure you [[Update Firefox to the latest version|update Firefox to the latest version]].
Ron 0 solutions 6 answers

this problem still exists. I tried all fixes suggested and still will not open pdf files of any kind since update. win 7 ff update 33

this problem still exists. I tried all fixes suggested and still will not open pdf files of any kind since update. win 7 ff update 33

Modified by Ron

AliceWyman
  • Moderator
240 solutions 2597 answers

When you open a PDF file that you saved to your computer, by double-clicking the file, does it open with Adobe Reader or with Firefox?

If the PDF file opens with Adobe Reader then follow the instructions in How to disable the built-in PDF viewer and use another viewer to set Adobe Reader as the application for Portable Document Format (PDF) in your Firefox Options for Applications.

If the PDF file opens in Firefox when you open it from your hard drive, even though you have Firefox 33 installed, try uninstalling and reinstalling Firefox:

  1. Download the latest Firefox version (currently 33.1.1) from mozilla.org and save the setup file to your computer.
    • Note: You can use this link for the online (stub) installer or choose the full installer for your operating system and language from this page.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the Exit button Close 29 ).
  3. Uninstall Firefox from your computer.
  4. Reinstall Firefox using the setup file you downloaded before.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data.

When you open a PDF file that you saved to your computer, by double-clicking the file, does it open with Adobe Reader or with Firefox? If the PDF file opens with Adobe Reader then follow the instructions in [[How to disable the built-in PDF viewer and use another viewer]] to set Adobe Reader as the application for Portable Document Format (PDF) in your Firefox Options for Applications. If the PDF file opens in Firefox when you open it from your hard drive, even though you have Firefox 33 installed, try uninstalling and reinstalling Firefox: #Download the latest Firefox version (currently 33.1.1) from [https://www.mozilla.org mozilla.org] and save the setup file to your computer. #*Note: You can use [https://www.mozilla.org/firefox/new/?scene=2#download-fx this link] for the online (stub) installer or choose the full installer for your operating system and language from [https://www.mozilla.org/firefox/all/ this page]. #After the download finishes, close all Firefox windows (or open the Firefox menu [[Image:New Fx Menu]] and click the Exit button [[Image:Close 29]]). #[[Uninstall Firefox from your computer|Uninstall Firefox from your computer]]. #Reinstall Firefox using the setup file you downloaded before. <b>WARNING:</b> Do not use a third party uninstaller as part of this process. Doing so could permanently delete your [[Profiles|Firefox profile]] data.

Modified by AliceWyman

AliceWyman
  • Moderator
240 solutions 2597 answers

The above instructions were meant for kevincrath, the thread owner. (I mistook the post from xtroop as coming from the thread owner).

To xtroop: You have asked a question in a thread that doesn't belong to you. See Forum rules and guidelines: Do not re-use existing threads started by others, even if they are seemingly on the same subject. Ask a new question instead.

If you've already tried resetting Adobe Reader as the default PDF application (Open Adobe Reader, go to Edit -> Preferences -> General and use the option, "Select Default PDF Handler"; Select Adobe Reader XI, reboot) as well as the other suggestions in this thread then you should ask a new question.

The above instructions were meant for '''kevincrath''', the thread owner. (I mistook the post from xtroop as coming from the thread owner). To '''xtroop''': You have asked a question in a thread that doesn't belong to you. See [[Forum rules and guidelines]]: ''Do not re-use existing threads started by others, even if they are seemingly on the same subject. [/questions/new Ask a new question] instead.'' If you've already tried resetting Adobe Reader as the default PDF application (Open Adobe Reader, go to Edit -> Preferences -> General and use the option, "Select Default PDF Handler"; Select Adobe Reader XI, reboot) as well as the other suggestions in this thread then you should [/questions/new ask a new question].

Modified by AliceWyman