Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Buttons on other websites are missing, how to fix in version 32.0.3?

  • 6 replies
  • 5 have this problem
  • 2339 views
  • Last reply by cor-el

more options

The navigation buttons on websites are missing. In IE they appear. How do I fix this? I have Windows 8 on my laptop.

Chosen solution

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you can probably see by little boxes that show the hex code of the characters.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Read this answer in context 👍 2

All Replies (6)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu , choose History, and then Clear Recent History....
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

more options

No it did not. Most websites are fine, but there a few like the login for my online college, the Outlook Web App (my college email) and Verizon website. Where the icon buttons or pictures are supposed to be there are square boxes. I prefer FF over IE but when school starts and if this doesn't get fixed I'll have to switch. I don't like having two browsers on my system. Any other suggestions?

more options

Chosen Solution

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you can probably see by little boxes that show the hex code of the characters.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

more options

THAT DID IT! Thanks Cor-el!!

more options

Up until about 3 versions ago if the missing button issue was not a problem if you "unselected the allow other pages to choose their own fonts" box. Ever since then the boxes and icons are not displaying oin FF. Please fix this.

more options

It is possible that at that time the website wasn't using an icon font to display those icons, but was still using images and have changed to an icon font recently. In case a downloadable font is used to display icons then you always need to enable "Allow pages to choose their own fonts, instead of my selections above".