Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

open c won't turn on

  • 1 reply
  • 4 have this problem
  • 28 views
  • Last reply by guigs

more options

my zte open c died today. Battery was 1/3, and i plugged it into car charger, and it went blank, and is now unresponsive in every way, its not "bricked" it is a brick. i had the zte open for about 5months and it went the same way, except in that case the battery went flat, and the phone refused to charge or wake up.

Mozilla, ZTE SUCKS. sorry, i had high hopes, but this is bullshit. and i spent all last Friday/Sat, learning how to install andoid with gapps, so i could use audible, and it worked awesome for the week (except for camera didn't work) and of course the sound went weeks earlier.

Guess i'll get a Samsung, privacy doesn't matter much in australia now anyway,

oh the question, for wat its worth, any chances theres something to be done to reset or fix this brick, besides throwing it at a wall. err? i'd appreciate my money back, though i doubt i'll get it, or a phone that effn works for more than, oh i don't know, a yr might be nice, maybe two......

Modified by darthlotus

All Replies (1)

more options

HI darthlotus, I understand the frustration since the phone will not turn on. The testing we can do here in the forum are limited and if we do not succeed, please contact the place of purchase for the device to check out the hardware warranty.

  1. Let the phone charge on a charger, other than the car charger for a bit, do you see the battery on the screen after leaving it on the charger for at least half an hour to an hour?
  2. Have you replaced the battery since it went flat?
  3. After a charge, see if you can adb devices to see if it detects the driver.
  4. Are you using the factory image on the device, if you can get a charge you can flash the phone if there are any issues with the operating system: http://www.ztedevices.com/support/sma.../cba40ed6-d3ab-44c0-bdee-3a15803dc187.html

Hope this helps.