Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some websites don't display comments

  • 17 replies
  • 8 have this problem
  • Last reply by cor-el

more options

Some websites suddenly stopped displaying comments while others are fine. It seems to be the last update I installed (to 32.0.3). Also, I'm still on Windows XP (can't afford a new computer right now). Any suggestions?

I tried clearing the cache and starting Firefox in safe mode with all plugins disabled -- no change. One example is (I know they've disabled commenting on many articles, but even the ones that do list a comment total don't display them.) Another is They were both fine until yesterday afternoon (9/25/14) when I installed an update. I can still see comments on both sites in a Chrome browser, so it's definitely Firefox.

All Replies (17)

more options

CNN and use Disqus. I can still see the comments with 32.0.3 installed, but obviously that's no consolation to you!

Can you see Disqus comments on their own site?

more options

Thank you for the quick response. Yes, I can see comments on the Disqus site.

more options

can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

As noted: I already tried Safe Mode and still couldn't see comments.

more options

Could you check your connection setting in the Options dialog:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default setting of "Use system proxy settings" should piggyback on the IE/Windows "LAN" settings but you also could try "No proxy" to see whether that works any better.

more options

could you try disabling adbloch, ghostery & priv3 for the moment nevertheless and restart the browser once afterwards to see if the problem continues - they would have the ability to block certain types of content...

more options

I'm afraid none of these suggestions work. (Tried the Options and the add-ons) I had set Ghostery to allow Disqus (and, I could see comments on their site), but even with all three suggested add-ons disabled (and Firefox restarted) -- still no comments. However, on, the info bar at the bottom continually says: Transferring data from A CNN page does not display that message (and still doesn't display comments).

Modified by bets18

more options

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if any content is blocked and has a file size 0 (zero).

more options

There are a few (on that show 0 KB as size; two are Disqus related. Both have an orange triangle with 302 (Found) in the first column. They are:

File: embed.js Domain: Type: js


File: count.js Domain: Type: js

There's another that might be relevant. It has a green circle with 200 (OK) in the first column:

File: remote-login.php?action=js&host=.... (with a long string for the specific page) Domain: Type: js

EW uses Wordpress for comment IDs.

On a CNN page, the same "embed.js" and "count.js" lines appear with 0KB; the Domain naturally changes to:

So is js Java Script? I haven't changed anything in the last day (when this started occurring). I think there was a Java update maybe last week or so.

EDIT: The CNN page has one red square 404 (Not Found) line:

File: default.css Domain: Type: html Size: 0.55 KB

However, right below it is a green circle 200 (OK) line:

File: styles.css Domain: Type: css Size: 0.05 KB

The EW page is different. No red squares and no lines on cascading style re: disqus, but there are a couple of "wp" ones with orange triangle 304 (Not Modified). I can provide detail if relevant.

Modified by bets18

more options

Java and JavaScript are different languages, so do not confuse the two.

Do you see that orange triangle in the location/address bar as well as that would indicate a problem with blocked mixed content?

more options

The address bar on both sites displays a gray globe stating that they don't supply identity information.

Looking in the Web developer, the Console view only shows one error on the EW page:

x GET [HTTP/1.1 403 Forbidden 94ms]

more options

A 302 response is a redirect, and a 304 indicates that Firefox can use a file from the cache, so those are not likely to be a problem.

On the page I was viewing, I found the one that contained the actual comments. If I right-clicked it and opened it in a new tab, the comments section displayed there. I have attached a screen shot for reference.

more options

Thanks for the visual. However, neither page has a similar line. Looked just at HTML types -- none for disqus except the CSS line on the CNN page, noted before:

404 Not found; File: default.css Domain: Type: html Size: 0.55 KB

EDIT: On the Disqus site, where I can see comments, I do see that line with a 304 code.

Modified by bets18

more options

Any other suggestions? This is still unresolved, but weirdly, on the Entertainment Weekly site, I can now see comments on "recap" articles only. Everything else is still blank.

more options

I'm low on ideas. Just thinking about what could possibly filter content, could you check the status of your McAfee plugins and set them either to "Always Activate" or "Never Activate" if they are currently set to "Ask to Activate".

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then look for at least two McAfee plugins.

This change might not take effect in the same window. You can launch a new window using Ctrl+n for testing whether that had any effect.

more options

Thanks -- but no luck. Tried a few other plugins as well, but nothing changed. I appreciate the effort. It really makes no sense!

more options

Make sure that you aren't blocking the referrer.

This can also happen if links from a secure (https) page open an insecure (http) link and the server wants a referrer like with

Your System Details list shows that you have preferences that were used in previous Firefox versions and that are no longer supported in the current Firefox release.

Try to cleanup the prefs to have a fresh start and delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

Modified by cor-el