X
Tap here to go to the mobile version of the site.

Support Forum

Every time I open a new window the error console opens in the bottom half of the window. How do I turn it off?

Posted

The Error Console that opens with every new window is the one that was used in older versions of Firefox not the newer Web Console or Browser Console. Also, "devtools.errorconsole.enabled" is set to "false"

The Error Console that opens with every new window is the one that was used in older versions of Firefox not the newer Web Console or Browser Console. Also, "devtools.errorconsole.enabled" is set to "false"

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 11.11.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Autofill Engine for Gecko and Webkit-based web browsers
  • 5.1.30514.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Winamp Application Detector
  • VLC media player Web Plugin 2.1.0
  • GEPlugin
  • Nitro PDF plugin for Firefox and Chrome
  • NPAPI Plugin used by Delta SkyMiles Shopping Assistant
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

David Tenser 30 solutions 310 answers

Helpful Reply

Hi there,

Are you sure you don't have an extension installed that does this? Like you say, the Error Console has been replaced in recent versions of Firefox so it's strange that you would see it.

If nothing else works, would you mind trying Firefox Reset? More info about what it does and how to use it here: https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems

Hope this helps. Thanks!

- David

Hi there, Are you sure you don't have an extension installed that does this? Like you say, the Error Console has been replaced in recent versions of Firefox so it's strange that you would see it. If nothing else works, would you mind trying Firefox Reset? More info about what it does and how to use it here: https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems Hope this helps. Thanks! - David

Question owner

Thank you for your reply. I have a number of extensions installed but none that were installed recently or which have to do with any developer work. (It's my understanding that the error console is used primarily by developers).

I've been avoiding resetting Firefox because I don't want to have to reinstall all my extensions which is likely to be time consuming. I was hoping there was something within "about:config" or a similar location which would turn it off.

Thank you for your reply. I have a number of extensions installed but none that were installed recently or which have to do with any developer work. (It's my understanding that the error console is used primarily by developers). I've been avoiding resetting Firefox because I don't want to have to reinstall all my extensions which is likely to be time consuming. I was hoping there was something within "about:config" or a similar location which would turn it off.
cor-el
  • Top 10 Contributor
  • Moderator
17522 solutions 158442 answers

Helpful Reply

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

These add-ons can be a great help by backing up and restoring Firefox '''[https://addons.mozilla.org/en-US/firefox/addon/febe/ FEBE (Firefox Environment Backup Extension)]''' {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose. '''[https://addons.mozilla.org/en-US/firefox/addon/opie/ OPIE]''' {web link} Import/Export extension preferences

Question owner

I already use the default theme, so I tried turning off hardware acceleration. That didn't work. I then tried using Safe Mode and that did work. That would seem to narrow the problem to one of my extensions.

Attached are three screenshots. First is the screenshot of the Error Console you requested. Sometimes when I open a window the Error Console doesn't load fully load and instead I get a blank area where the Error Console data would normally be. See Screenshot #2. Screenshot #3 is of my installed extensions. In your experience, are any of them the likely cause of the problem. Knowing that might be helpful in determining the culprit.

In addition to possibly a problematic extension, could it be a plug-in?

I already use the default theme, so I tried turning off hardware acceleration. That didn't work. I then tried using Safe Mode and that did work. That would seem to narrow the problem to one of my extensions. Attached are three screenshots. First is the screenshot of the Error Console you requested. Sometimes when I open a window the Error Console doesn't load fully load and instead I get a blank area where the Error Console data would normally be. See Screenshot #2. Screenshot #3 is of my installed extensions. In your experience, are any of them the likely cause of the problem. Knowing that might be helpful in determining the culprit. In addition to possibly a problematic extension, could it be a plug-in?
cor-el
  • Top 10 Contributor
  • Moderator
17522 solutions 158442 answers

Plugins are not affected by Safe Mode, so if it doesn't happen in Safe Mode then it is caused by an extension and not by a plugin. If it still happens in Safe Mode then it is possible that a plugin is causing it.

Plugins are not affected by Safe Mode, so if it doesn't happen in Safe Mode then it is caused by an extension and not by a plugin. If it still happens in Safe Mode then it is possible that a plugin is causing it.
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Type '''about:addons'''<Enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.