X
Tap here to go to the mobile version of the site.

Support Forum

Won't let me change a file association to use Quicktime Plugin?

Posted

So i have a problem and i can't find a fix.

Here is an image to help explain because i'm told i'm bad at it.

http://i61.tinypic.com/24ytimu.jpg

As you can see, files with the .midi extension open in the plugin in firefox fine, but .mid files don't. I've followed several advices over the past several hours, including deleting the .mid entry from the mimetypes file. Nothing works. it won't let me associate it with the plugin so when i try to click it just downloads them.

Can someone, anyone, help me fix this?

So i have a problem and i can't find a fix. Here is an image to help explain because i'm told i'm bad at it. http://i61.tinypic.com/24ytimu.jpg As you can see, files with the .midi extension open in the plugin in firefox fine, but .mid files don't. I've followed several advices over the past several hours, including deleting the .mid entry from the mimetypes file. Nothing works. it won't let me associate it with the plugin so when i try to click it just downloads them. Can someone, anyone, help me fix this?

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Version 5.4.2.18903
  • 5.1.30514.0
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • GEPlugin
  • Yahoo Application State Plugin version 1.0.0.7
  • NPWLPG

Application

  • Firefox 32.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0.2/WINNT/en-US/

Extensions

  • about:addons Button 2.0 (aboutaddons@firefox)
  • Adblock Plus 2.6.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2 (adblockpopups@jessehakanen.net)
  • Add Bookmark Here ² 29.0.20140506 (abhere2@moztw.org)
  • Copy Containing Folder 1.0 ({c763bb53-9c24-4579-8ddc-72c3b6cb0f1c})
  • Download folder button 1.6 (downloadfolderbutton@zen-ben.com)
  • DownThemAll! 2.0.17 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • ExHentai Easy 2 0.2.6 (jid1-7NbXi2AqS1oUFw@jetpack)
  • Google Translator for Firefox 2.1.0.3 (translator@zoli.bod)
  • Greasemonkey 2.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • InvisibleHand 3.9.46 (canitbecheaper@trafficbroker.co.uk)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • Media Hint 0.1.13.1 (mediahint@jetpack)
  • NoScript 2.6.8.42 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Perapera Japanese 9.1.1 (peraperakun@gmail.com)
  • Personas Plus 1.7.3 (personas@christopher.beard)
  • SkipScreen 0.7.2 (SkipScreen@SkipScreen)
  • Switch plugins.click_to_play 0.9.1 (jid1-tsc5Jhe6AjgKhg@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Avira Browser Safety 1.3.2 (abs@avira.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 4-4-2011
  • driverDate2:
  • driverVersion: 8.15.10.2353
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.display.background_color: #000000
  • browser.display.foreground_color: #660000
  • browser.places.smartBookmarksVersion: 7
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140917194002
  • browser.startup.homepage_override.buildID: 20140917194002
  • browser.startup.homepage_override.mstone: 32.0.2
  • browser.tabs.drawInTitlebar: False
  • dom.ipc.plugins.java.enabled: True
  • dom.max_chrome_script_run_time: 40
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 32.0.2
  • font.internaluseonly.changed: False
  • font.name.serif.x-western: Tahoma
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1411470263
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.default.state: 2
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npunity3d: 0
  • privacy.cpd.downloads: False
  • privacy.cpd.extensions-dta: True
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_java: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1410675659

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4347 solutions 61135 answers

Helpful Reply

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

Deleting the '''mimeTypes.rdf''' will reset all download actions to the default settings. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the file. Then rename or delete it. Restart Firefox.

Question owner

it worked! thank you! aaand as soon as i tried to open one it tried to download it. same problem as before. It pulls up a new category right next to the midi files that won't let me use the qtplugin.

I'm starting to hate having upgraded from 31. Wonder if i could find it?

it worked! thank you! aaand as soon as i tried to open one it tried to download it. same problem as before. It pulls up a new category right next to the midi files that won't let me use the qtplugin. I'm starting to hate having upgraded from 31. Wonder if i could find it?

Modified by emilin_rose

FredMcD
  • Top 10 Contributor
4347 solutions 61135 answers

You are saying the problem returned?

I called for more help.

Open your Windows Control Panel. Go to the page that controls what program is called by what extension. What is listed under .midi and .mid files?

You are saying the problem returned? I called for more help. Open your Windows Control Panel. Go to the page that controls what program is called by what extension. What is listed under '''.midi''' and '''.mid''' files?

Question owner

Okay it says "windows media player". but even setting it to firefox didn't fix the issue. and again, no option there for the plugin.

I think maybe it might be the plugin itself? could that be it? I don't think it should be, i repaired, uninstalled/reinstalled and everything.

Okay it says "windows media player". but even setting it to firefox didn't fix the issue. and again, no option there for the plugin. I think maybe it might be the plugin itself? could that be it? I don't think it should be, i repaired, uninstalled/reinstalled and everything.
FredMcD
  • Top 10 Contributor
4347 solutions 61135 answers

Both of them, yes? Put it back to Windows Media Player. Firefox, itself, does not work on clips. It calls a plugin to do the job.

Both of them, yes? Put it back to Windows Media Player. Firefox, itself, does not work on clips. It calls a plugin to do the job.

Question owner

i should clarify, it WAS set to WMP, i changed it to firefox to see if it would work, when it didn't i changed it back.

i should clarify, it WAS set to WMP, i changed it to firefox to see if it would work, when it didn't i changed it back.
FredMcD
  • Top 10 Contributor
4347 solutions 61135 answers

One more thing, please go to the Chosen Solution flag and turn it off. I think helpdesk thinks no more help is needed.

One more thing, please go to the '''Chosen Solution''' flag and turn it off. I think helpdesk thinks no more help is needed.

Question owner

Thank you. i don't know when i clicked that again. Sorry.

Thank you. i don't know when i clicked that again. Sorry.
FredMcD
  • Top 10 Contributor
4347 solutions 61135 answers

It's the notice that questioners get. There is a VERY large button that says; Solved. But the button to just open the post is very small

It's the notice that questioners get. There is a '''VERY large''' button that says; '''Solved.''' But the button to just open the post is <sub>very small</sub>

Helpful Reply

Its still happening. I've tried deleting and editing the mimetypes file repeatedly. also the pluginreg file.

so far i found two lines in the mimetype that i can't understand but i think they MAY be the problem.

<NC:externalApplication RDF:resource="urn:mimetype:externalApplication:audio/midi"/>

If i could figure out where this "resource" is, maybe i could check it?

Its still happening. I've tried deleting and editing the mimetypes file repeatedly. also the pluginreg file. so far i found two lines in the mimetype that i can't understand but i think they MAY be the problem. <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:audio/midi"/> If i could figure out where this "resource" is, maybe i could check it?