Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Won't let me change a file association to use Quicktime Plugin?

  • 10 replies
  • 4 have this problem
  • Last reply by emilin_rose

more options

So i have a problem and i can't find a fix.

Here is an image to help explain because i'm told i'm bad at it.

As you can see, files with the .midi extension open in the plugin in firefox fine, but .mid files don't. I've followed several advices over the past several hours, including deleting the .mid entry from the mimetypes file. Nothing works. it won't let me associate it with the plugin so when i try to click it just downloads them.

Can someone, anyone, help me fix this?

All Replies (10)

more options

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

more options

it worked! thank you! aaand as soon as i tried to open one it tried to download it. same problem as before. It pulls up a new category right next to the midi files that won't let me use the qtplugin.

I'm starting to hate having upgraded from 31. Wonder if i could find it?

Modified by emilin_rose

more options

You are saying the problem returned?

I called for more help.

Open your Windows Control Panel. Go to the page that controls what program is called by what extension. What is listed under .midi and .mid files?

more options

Okay it says "windows media player". but even setting it to firefox didn't fix the issue. and again, no option there for the plugin.

I think maybe it might be the plugin itself? could that be it? I don't think it should be, i repaired, uninstalled/reinstalled and everything.

more options

Both of them, yes? Put it back to Windows Media Player. Firefox, itself, does not work on clips. It calls a plugin to do the job.

more options

i should clarify, it WAS set to WMP, i changed it to firefox to see if it would work, when it didn't i changed it back.

more options

One more thing, please go to the Chosen Solution flag and turn it off. I think helpdesk thinks no more help is needed.

more options

Thank you. i don't know when i clicked that again. Sorry.

more options

It's the notice that questioners get. There is a VERY large button that says; Solved. But the button to just open the post is very small

more options

Its still happening. I've tried deleting and editing the mimetypes file repeatedly. also the pluginreg file.

so far i found two lines in the mimetype that i can't understand but i think they MAY be the problem.

<NC:externalApplication RDF:resource="urn:mimetype:externalApplication:audio/midi"/>

If i could figure out where this "resource" is, maybe i could check it?