Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox says cannot create temp folder archive?

more options

I accidentally deleted Firefox from my computer the other day, and now when I try to download it, it comes up with an error box saying "7-zip: can not create temp folder archive" I have tried to download it in my specific language and still no luck. How can I fix this?

All Replies (7)

more options

In case this is a problem limited to the "stub" installer, can you grab a full installer from this page (scroll down to your preferred language):

more options

Three other thoughts:

(1) Try running the Firefox installer from a folder in your Windows profile where you also have your Windows temp folder. Normally the Downloads folder or Desktop will work.

(2) If you haven't tried shutting down and restarting Windows since this began, it could be worth a shot. Sometimes the Windows Installer accumulates too many deferred updates and stops working correctly until they are completed.

(3) If you haven't already tried clearing the Windows temp folder, you might also try that. Windows 7 includes a Disk Cleanup tool for this, as described in this article:

more options

None of these helped fixed the problem, sadly. I tried them all. Any other thoughts?

more options

You could try right-clicking the installer and using Run as Administrator. If that bypasses the error, it suggests there is a permissions issue using your Temp folder. I'm not sure it's a good idea to complete the installation using Run as Administrator if your Windows 7 user does not have local administrator rights on the machine. That could create problems running Firefox.

more options

I have same issue and have followed all the suggestions above ... and still get the error message. :(

more options

As jscher had mentioned, moving the install file to another folder may give a different set of permissions. It may be the rights to the folder it is trying to unzip to: is it possible for you to try to take ownership of the temp folder? Instructions on how to do this:

Another case that had uninstalled windows 7 zip still had the same error, since the stub installer uses it to unpack it and the download from the official site still gives errors, is there enough space on the computer?

" You need to untick read attributes on the temp folder." and trying to download a new stub file were other recommendations.

What is the name of the stub installer? Knowing what build can help further investigate if it is a stub issue.

more options

Discovered the problem from your recent post about "can't initialize plug-ins" ... What are the permissions on your Temp folder?

My "C:\Users\Bill\AppData\Local\Temp" permissions were not the "full control" that it needed to be for both User\Bill and for Administrator.