X
Tap here to go to the mobile version of the site.

Support Forum

Is Mozilla "hijacking" my startup page by overriding it and substituting the Mozilla Startup Page whenever I start Firefox??

Posted

Recently, I customized my startup page (as I have many times in the past.) Since then, however, each time I start Firefox it opens with the Firefox Startup Page, including the Firefox logo/icon. Even though I've rebooted my pc and reset my startup page quite a few times in an effort to overcome the problem (sometimes using Options and others by dragging the tab to the Home icon) the Mozilla Startup Page trumps me and replaces my customized choice. What's the deal? Is Mozilla intentionally overriding users' choices and imposing its own, preferred Mozilla Startup Page or is it the result of an unrelated "hijacker"?

Thank you.

Recently, I customized my startup page (as I have many times in the past.) Since then, however, each time I start Firefox it opens with the Firefox Startup Page, including the Firefox logo/icon. Even though I've rebooted my pc and reset my startup page quite a few times in an effort to overcome the problem (sometimes using Options and others by dragging the tab to the Home icon) the Mozilla Startup Page trumps me and replaces my customized choice. What's the deal? Is Mozilla intentionally overriding users' choices and imposing its own, preferred Mozilla Startup Page or is it the result of an unrelated "hijacker"? Thank you.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Live Update v1.3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 32.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0.1/WINNT/en-US/

Extensions

  • Ads Removal 1.0.0 (adremoveext@adremoveext.net)
  • Favicon Restorer 1.4 (faviconrestorer@masserog.it)
  • FavIconReloader 0.8 (FavIconReloader@mozilla.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI MOBILITY RADEON 9000
  • adapterDescription2:
  • adapterDeviceID: 0x4c66
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'9.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 11-10-2005
  • driverDate2:
  • driverVersion: 8.20.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 2
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140911151253
  • browser.startup.homepage_override.buildID: 20140911151253
  • browser.startup.homepage_override.mstone: 32.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 32.0.1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1410607713
  • places.history.expiration.transient_current_max_pages: 53667
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np32dsw_1203133: 0
  • plugin.state.np32dsw_1213153: 0
  • plugin.state.npdeployjava: 0
  • privacy.donottrackheader.enabled: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1409521441

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23471 answers

Helpful Reply

hello, you have a user.js file in your profile that may overwrite your custom preferences. go to the firefox menu ≡ > help ? > troubleshooting information > profile folder - "show folder", then a new window will open up. in this window look out for a file named user.js (it might be used to overwrite your custom settings). in case it is present , delete or rename this file and restart firefox afterwards.

How to fix preferences that won't save

hello, you have a user.js file in your profile that may overwrite your custom preferences. go to the firefox menu ≡ > help ? > troubleshooting information > profile folder - "show folder", then a new window will open up. in this window look out for a file named '''user.js''' (it might be used to overwrite your custom settings). in case it is present , delete or rename this file and restart firefox afterwards. [[How to fix preferences that won't save]]

Question owner

Thanks for your prompt response - - and instx geared for a neophyte like myself. I'll take a shot and hopefully your advice will solve the problem which, while minor, is annoying.

Thanks for your prompt response - - and instx geared for a neophyte like myself. I'll take a shot and hopefully your advice will solve the problem which, while minor, is annoying.

Question owner

Followed Phillipp's instx. Selected Troubleshooting Information and then, before I found Profile Folder, I scrolled down the page and, just above something about Javascript, found the following: "user.js Preferences

Your profile folder contains a user.js file, which includes preferences that were not created by Firefox."

I then scrolled back up the page, found and selected Profile Folder and selected that. A window opened, but there was no file named "user.js". I did locate a file "user" and selected it. Within that file there was a reference to user.js. I renamed the "user" file and then closed the window and restarted Firefox.

Sorry, but the above action did not solve the problem. Any other thoughts? Would a Firefox reset do the trick? Thanks again.

Followed Phillipp's instx. Selected Troubleshooting Information and then, before I found Profile Folder, I scrolled down the page and, just above something about Javascript, found the following: "user.js Preferences Your profile folder contains a user.js file, which includes preferences that were not created by Firefox." I then scrolled back up the page, found and selected Profile Folder and selected that. A window opened, but there was no file named "user.js". I did locate a file "user" and selected it. Within that file there was a reference to user.js. I renamed the "user" file and then closed the window and restarted Firefox. Sorry, but the above action did not solve the problem. Any other thoughts? Would a Firefox reset do the trick? Thanks again.

Modified by mporter24

FredMcD
  • Top 10 Contributor
4260 solutions 59646 answers

Type about:config in the address bar and press Enter. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Type browser.newtab.url and press enter. browser.newtab.url tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any web page or about: page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

Type '''about:config''' in the address bar and press '''Enter.''' If a warning screen comes up, press the '''Be Careful''' button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Type '''browser.newtab.url''' and press enter. '''browser.newtab.url''' tells Firefox what to show when a new tab is opened. If you want, right click and select '''Modify'''. You can change the setting to; '''about:home''' (Firefox default home page), '''about:newtab''' (shows the sites most visited), '''about:blank''' (a blank page), or you can enter any '''web page''' or '''about: page''' you want. The same instructions are used for the new window setting, listed as '''browser.startup.homepage'''.

Helpful Reply

The more I try to prevent the Mozilla/Firefox Startup Page from taking over or hijacking my preferred/customized startup page, the more I'm being convinced that Mozilla is intentionally trying to force its users to adopt the Mozilla/Firefox Startup Page as their own startup page. It appears to me to be a calculated effort by Mozilla to expand the recognition of its corporate "brand", just like Microsoft would do.

So, I don't think that the problem I initially posed is the result of a software glitch. Instead, this may simply be another example of arrogance by a successful organization. Perhaps I'm wrong; perhaps I'm not.

The more I try to prevent the Mozilla/Firefox Startup Page from taking over or hijacking my preferred/customized startup page, the more I'm being convinced that Mozilla is intentionally trying to force its users to adopt the Mozilla/Firefox Startup Page as their own startup page. It appears to me to be a calculated effort by Mozilla to expand the recognition of its corporate "brand", just like Microsoft would do. So, I don't think that the problem I initially posed is the result of a software glitch. Instead, this may simply be another example of arrogance by a successful organization. Perhaps I'm wrong; perhaps I'm not.

Question owner

Fred. Though I'm getting more pessimistic that I will find a way to work around the Mozilla/Firefox Startup Page, I welcome your reply and will try to implement it your suggested (possible) solution. I'll report back on the outcome.

Fred. Though I'm getting more pessimistic that I will find a way to work around the Mozilla/Firefox Startup Page, I welcome your reply and will try to implement it your suggested (possible) solution. I'll report back on the outcome.

Question owner

Fred. I followed your instructions and typed "home" in as the modified value. Unfortunately (as I expected), the Mozilla/Firefox Startup Page showed up instead of the page I wanted. That showed up in the first tab.

My objective is to have the webpage of my choice ("customized" per Mozilla's instx) appear at the startup of my pc. It does not. Mozilla's Startup Page continues to get to the head of the queue.

Thanks anyhow.

Fred. I followed your instructions and typed "home" in as the modified value. Unfortunately (as I expected), the Mozilla/Firefox Startup Page showed up instead of the page I wanted. That showed up in the first tab. My objective is to have the webpage of my choice ("customized" per Mozilla's instx) appear at the startup of my pc. It does not. Mozilla's Startup Page continues to get to the head of the queue. Thanks anyhow.
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23471 answers

hello, your assumption that this would be something that is done deliberately by mozilla is certainly incorrect. please try to reset firefox and see if this can address the issue...

hello, your assumption that this would be something that is done deliberately by mozilla is certainly incorrect. please try to [[Reset Firefox – easily fix most problems|reset firefox]] and see if this can address the issue...

Question owner

Thanks Phillipp and Fred. While I haven't solved the problem, I can either use another browser or live with it. I'll probably do the latter.

I do appreciate the effort.

Thanks Phillipp and Fred. While I haven't solved the problem, I can either use another browser or live with it. I'll probably do the latter. I do appreciate the effort.
FredMcD
  • Top 10 Contributor
4260 solutions 59646 answers

I followed your instructions and typed "home"

about:home (Firefox default home page),

''I followed your instructions and typed "home" '' '''about:home''' (Firefox default home page),
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.


There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences ---- There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

While I do appreciate your input and that of Phillipp and Fred, I'm fast approaching my point of incompetency regarding pc's. When I start to pull back the curtain of confusion (about:config) to see the wizard, I start to worry that I may change a value or other datapoint and not be able to logon with my pc. So, as noted above, I'll either learn how to live with Mozilla/Firefox's Startup Page or find another browser. Annoying, but no big deal.

FYI, while there was a "perfs" file and a "perfs-1" file, neither had a ".js" extension. When I selected those files, they were identified as JS Script files and showed a ".js" at the end of each's respective path. I thought about it, but decided to abandon the quest rather than risk going down a road that I would not be able to navigate upon return.

While I do appreciate your input and that of Phillipp and Fred, I'm fast approaching my point of incompetency regarding pc's. When I start to pull back the curtain of confusion (about:config) to see the wizard, I start to worry that I may change a value or other datapoint and not be able to logon with my pc. So, as noted above, I'll either learn how to live with Mozilla/Firefox's Startup Page or find another browser. Annoying, but no big deal. FYI, while there was a "perfs" file and a "perfs-1" file, neither had a ".js" extension. When I selected those files, they were identified as JS Script files and showed a ".js" at the end of each's respective path. I thought about it, but decided to abandon the quest rather than risk going down a road that I would not be able to navigate upon return.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

You can try to delete both prefs.js and prefs-1.js files in case there is a problem with the files. The numbered prefs-1.js file shouldn't be there and indicates that there was a problem at the time this file got created and should be removed anyway. Deleting the prefs.js file will reset all preferences to the default value and you will have to redo changes made in Firefox/Tools > Options.

You can try to delete both prefs.js and prefs-1.js files in case there is a problem with the files. The numbered prefs-1.js file shouldn't be there and indicates that there was a problem at the time this file got created and should be removed anyway. Deleting the prefs.js file will reset all preferences to the default value and you will have to redo changes made in Firefox/Tools > Options.

Question owner

In my last post, I indicated that neither the "prefs" nor the "prefs-1" files showed a ".js" after their names. That being said, you suggest that I delete two files: "prefs.js" and "prefs-1.js". Are we referring to the same files?

In my last post, I indicated that neither the "prefs" nor the "prefs-1" files showed a ".js" after their names. That being said, you suggest that I delete two files: "prefs.js" and "prefs-1.js". Are we referring to the same files?
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23471 answers

like mentioned before, i'd recommend that you proceed with a reset of firefox: Refresh Firefox - reset add-ons and settings

like mentioned before, i'd recommend that you proceed with a reset of firefox: [[Reset Firefox – easily fix most problems]]
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Yes, that are the correct files. Windows hides some file extensions by default. Among them are .html and .ini and .js and .txt, so you may only see file name without file extension. You can see the real file type (file extension) in the properties of the file via the right-click context menu in Windows Explorer.

Yes, that are the correct files. Windows hides some file extensions by default. Among them are .html and .ini and .js and .txt, so you may only see file name without file extension. You can see the real file type (file extension) in the properties of the file via the right-click context menu in Windows Explorer.