Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My browser is never secure it changes on me, how do i fix this?

  • 2 replies
  • 6 have this problem
  • 2689 views
  • Last reply by cor-el

more options

I just recently changed from Google Chrome to Mozilla/Firefox. I love it, but i cant get a secure browser when i log into Facebook or any of the games. What do i do to fix this? I get a grey triangle next to a battery in my browser.I hope this makes sense. Oh I have a notebook with Windows 8. Thank you so much I hope you can help me with this crazy problem.

Chosen solution

The gray triangle with ! in it indicates that the connection to the site is secure, but some content in the page was not retrieved over a secure connection. The content is still displayed because it is not considered highly dangerous -- for example, it could be some photos that were embedded from a site using HTTP instead of HTTPS. This mixed display content warnings differs from the mixed active content block, for which you see a "shield" icon in the address bar, and if you approve it, an orange triangle.

Sometimes Firefox will give a "false" mixed display content warning on some sites when you use the Back button. This seems to be an issue with cached files. To bypass the cache, you can reload the page fresh from the server using Ctrl+Shift+r (instead of a regular reload). If you find that this is your problem, there may be a workaround (modifying how Firefox caches pages).

If that is not the problem, do you want to give the URL of a page that shows completely secure in other browsers but gives a mixed content warning in Firefox? This might not work for pages like the FB news feed which are different for everyone...

Read this answer in context 👍 5

All Replies (2)

more options

Chosen Solution

The gray triangle with ! in it indicates that the connection to the site is secure, but some content in the page was not retrieved over a secure connection. The content is still displayed because it is not considered highly dangerous -- for example, it could be some photos that were embedded from a site using HTTP instead of HTTPS. This mixed display content warnings differs from the mixed active content block, for which you see a "shield" icon in the address bar, and if you approve it, an orange triangle.

Sometimes Firefox will give a "false" mixed display content warning on some sites when you use the Back button. This seems to be an issue with cached files. To bypass the cache, you can reload the page fresh from the server using Ctrl+Shift+r (instead of a regular reload). If you find that this is your problem, there may be a workaround (modifying how Firefox caches pages).

If that is not the problem, do you want to give the URL of a page that shows completely secure in other browsers but gives a mixed content warning in Firefox? This might not work for pages like the FB news feed which are different for everyone...

more options

If there is mixed passive content (e.g. images) then Firefox shows an exclamation mark instead of "Site Identity Button" (globe/padlock) on the location/address bar.

See also: