X
Tap here to go to the mobile version of the site.
Top Contributor Feature will be unavailable for a short amount of time today until further notice.

Support Forum

Why are sites saying I need to upgrade Firefox when it is up to date?

Posted

Yahoo is using the basic mail as I am using an unsupported browser and need to upgrade also face book says the same but my firefox is up to date. 31.0 ?

Yahoo is using the basic mail as I am using an unsupported browser and need to upgrade also face book says the same but my firefox is up to date. 31.0 ?

Chosen solution

What Mac OS version do you currently run?

The FBSMTWB in the user agent is caused by a Fast Browser Search infection in the past that likely locked the user agent at that time and is likely caused by the general.useragent.override pref that you can inspect and modify on the about:config page.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 14.0 r0
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Garmin Communicator Plug-in Version 4.1.0.0
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 FBSMTWB

More Information

philipp
  • Top 25 Contributor
  • Moderator
5123 solutions 22710 answers

Helpful Reply

hello Zenagp, your useragent (the information the browser sends to websites to identify its version) - apparently mistakenly - shows you're on firefox version 3.6. probably some sort of toolbar or adware has overwritten it. please refer to this article in order to reset the user-agent settings in firefox: Websites say that Firefox is outdated or incompatible even though it's the latest version

hello Zenagp, your useragent (the information the browser sends to websites to identify its version) - apparently mistakenly - shows you're on firefox version 3.6. probably some sort of toolbar or adware has overwritten it. please refer to this article in order to reset the user-agent settings in firefox: [[Websites say that Firefox is outdated or incompatible even though it's the latest version]]
ideato 893 solutions 6250 answers

Helpful Reply

Hello Zenagp and philipp,

Zenagp note also that you you cannot go beyond Firefox 3.6.28 (today latest stable version is 31.0), for your Mac OS X 10.4, see:Firefox no longer works with Mac OS X 10.4 or PowerPC processors.

thank you

Hello Zenagp and philipp, Zenagp note also that you you cannot go beyond Firefox 3.6.28 (today latest stable version is 31.0), for your Mac OS X 10.4, see:[https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-10-4-or-powerpc Firefox no longer works with Mac OS X 10.4 or PowerPC processors]. thank you
cor-el
  • Top 10 Contributor
  • Moderator
16605 solutions 149932 answers

Chosen Solution

What Mac OS version do you currently run?

The FBSMTWB in the user agent is caused by a Fast Browser Search infection in the past that likely locked the user agent at that time and is likely caused by the general.useragent.override pref that you can inspect and modify on the about:config page.

What Mac OS version do you currently run? The FBSMTWB in the user agent is caused by a Fast Browser Search infection in the past that likely locked the user agent at that time and is likely caused by the <b>general.useragent.override</b> pref that you can inspect and modify on the <b>about:config</b> page.

Modified by cor-el

James
  • Top 25 Contributor
  • Moderator
1492 solutions 10403 answers

As of Firefox 4.0 you needed Intel and OSX 10.5+ up until Firefox 16.0.2. https://www.mozilla.org/en-US/firefox/4.0/system-requirements/

The minimum since Firefox 17.0 has been Mac OSX 10.6+ /firefox/17.0/system-requirements/ https://www.mozilla.org/en-US/firefox/17.0/system-requirements/

As of Firefox 4.0 you needed Intel and OSX 10.'''5'''+ up until Firefox '''16.0.2'''. https://www.mozilla.org/en-US/firefox/4.0/system-requirements/ The minimum since Firefox 17.0 has been Mac OSX 10.'''6'''+ /firefox/17.0/system-requirements/ https://www.mozilla.org/en-US/firefox/17.0/system-requirements/

Modified by James