X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is asking me to add an exception for security for a website that has told me its certificate is valid.

Posted

I am running Firefox 31.0 on a Windows 8.1 o/s. When I attempt to access my email provider in its' "secure" mode, I am advised that the connection is untrustworthy. (Parenthetically, this does not occur on my other two systems running respectively, Windows 7 and Windows XP.) I am asked to provide an authorization for an 'exception' prior to completing the connection. The option of making the exception permanent is NOT available, so I go through this every time I begin a new internet session. I have contacted the email provider and been advised that their digital certificate is valid. So, as I see it there are three problems: (1) if the certificate is valid, as is suggested by the provider, why does Firefox not recognize this, (2) why does the exception window not allow me the option to make the exception status enduring, and (3) why is this problem present only on my Windows 8.1 system?

I am running Firefox 31.0 on a Windows 8.1 o/s. When I attempt to access my email provider in its' "secure" mode, I am advised that the connection is untrustworthy. (Parenthetically, this does not occur on my other two systems running respectively, Windows 7 and Windows XP.) I am asked to provide an authorization for an 'exception' prior to completing the connection. The option of making the exception permanent is NOT available, so I go through this every time I begin a new internet session. I have contacted the email provider and been advised that their digital certificate is valid. So, as I see it there are three problems: (1) if the certificate is valid, as is suggested by the provider, why does Firefox not recognize this, (2) why does the exception window not allow me the option to make the exception status enduring, and (3) why is this problem present only on my Windows 8.1 system?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Shockwave Flash 14.0 r0
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23470 answers

hello nwjack, there are many different factors that can interfere with an encrypted connection so it won't be possible to answer your questions generally. what is the address of the site where this is happening and what error code (under technical details) are you getting?

hello nwjack, there are many different factors that can interfere with an encrypted connection so it won't be possible to answer your questions generally. what is the address of the site where this is happening and what error code (under technical details) are you getting?
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158555 answers

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored. If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate. If that didn't help then remove or rename secmod.db (secmod.db.old) as well.