Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

2014 Firefox Flash issue is hanging up because of computers memory, see it in the task manager

  • 9 replies
  • 5 have this problem
  • 238 views
  • Last reply by AliceWyman

more options

Ok this Firefox/Flash issue has been a problem for a few years now and it seems the Mozilla want to keep sidestepping this issue by blaming the users. I dont have the answer but can maybe point in the right direction.

Its late 2014 and and this issue is still a LARGE PROBLEM!

The reason our computers are locking up, or hanging is because when Firefox needs to use the flash plugin, it has a bug which start to eat away at the amount of storage space available on any given computer. You can 1st open your TASK MANAGER. Then open the Firefox browser. Next in the task manager and find the line for (firefox.exe), also monitor the 2 lines for (flashplayerplugin). But mainly the firefox.exe, and in that line NOTE to the MEMORY USAGE. This is the problem. Now open YOUTUBE in the browser and watch a few videos. as you do this the memory will grow and grow and grow to Gigabyte, thus overloading a computers memory and lagging and locking-up will occur. You need to close the Firefox browser to get the memory to stop increasing. People who have 8GB or less of memory are most effected, and Firefox developers who say for you to go to the Flash Help page and uncheck to HARDWARE ACCELERATION are just lazy and stupid, because they still to this date have never addressed this issue. WE CANNOT UNCHECK THAT BOX. because our computer memory locks up and doesnt allow it to be unchecked, so your answer of telling us to do this is not a solution... CAN ANYBODY HEAR ME IN THE FIREFOX DEV TEAM, probably not they are satill asleep or playing on their phones. Try setting up a minimum computer and bringing this problem as I described, then find US A FIX FOR THIS 4YR OLD ISSUE!!!

Here is a solution one person suggests, but it will not work for me because my lack of a large amount of computer memory hardware will still not allow me/us to UN-CKECK THE HARDWARE ACCELERATION BOX...

START (( Hi, I solved this shit.

Flash video/content crashes instantly, so it makes it impossible to right-click it and enter the settings to disable hardware acceleration. This issue wasn't solved for over 2 years in other forum posts, but I finally did it. You have to temporarily DISABLE all your recording and playback devices in the windows' sound menu. this will let you play flash content (it did help me), just enough to disable hardware acceleration. I am surprised Mozilla survived despite being unable to debug their own software - no respect to customers ad their time. )) END

As i said this still did not work for me, but right clicking on any flash video will allow you options... So instead of going into SETTINGS on trying to unckeck HARDWARE ACC., Instead I went into Global Settings>Advanced> and deleted all (Browsing Data and Settings).

Next I right clicked on the video, and unchecked LOOP and PLAY options. This seems to have decreased the memory build up in the TASK MANAGER somewhat.

I run the latest updates of FLASH (14.0.0.179), versions of Firefox (31.0), on a win7 64bt unit that has a z97 intel motherboard with 8Gb of memory.

Maybe just 1 smart and un-lazy Firefox Developer can follow up on this Flash bug issue... I mean its almost 2015 and its still here and you are losing browser supporters, and eventually your jobs, wake up now!

Hope this feedback helps, have a nice day.

seb6000

All Replies (9)

more options

Hi seb6000, Sorry you are having problems.

We are not Firefox Devs here. We are only fellow users of Firefox volunteering our time to help one another.

If you have found a memory leak it may be worth filing a bug for that, however the problem may be down to Flash Player behaviour and FlashPlayer is third party software from the company Adobe so it may be more appropriate to file a bug with Adobe. The initial steps worth attempting would be to try turning off the hardware acceleration and protected modes.

If it is possible to solved the issue by turning off hardware acceleration it may be an issue that only affects certain hardware and not everyone. There is also the possibility that updating; or conversely; rolling back graphics drivers could help

Note that once hardware acceleration is turned off it should stay off until you change the setting again, and that you probably need to restart Firefox before any change of setting takes effect.

You could also consider trying disabling Flash Players protected mode to see if that helps

more options

same answers as always but never a solution... on the Moz site this applies to all the next same answers from others too.. but thanks for repeating yourselves a lot.. in every forum post u may not be the Moz Developers but this is the place on the Moz site where civilians come to find answers and repeating your same answers on every post for this problem is no solution and eventually will close the Firefox browser and your jobs with it, even if u only volunteer.

more options

You can provide feedback to the Mozilla developers here: https://input.mozilla.org/en-US/feedback

more options

You will not get a solution unless you either troubleshoot or file a bug, and it is difficult to effectively file a bug unless you have tried troubleshooting the issue.

more options

Adobe's Flash plugin for Windows has been a pain at times ever since they released 11.3

more options

@seb6000

You are absolutely correct same old school answers given without the problem being addressed.

Bottom line this is a plugin-container.exe related issue. It does NOT happen in IE or Chrome! It is not a flash issue!

I have found that deleting certain prefetch files regularly CAN prevent this. This resolved my Firefox flash player crashes. This can either be accomplished with a cmd or a cmd wrapped in a vbs to hide the cmd window ( note the full screen gaming will be interrupted ). Or you can use my code and do it via exe's which will not effect full screen mode. Like i said ALL my prefetch code is POSTED so I don't want to here no cry baby whiners; you can compile the code yourself!

Another viable option is to disable the plugin-container.exe. it pretty simple to do.

If anyone is interested in this they can click my name and in my profile you can dig through my blogs. There are companion videos that lay it all out in detail step by step the long way.

As always I WILL put a disclaimer unlike others stating this may or may not work for your situation.

Best Regards

[Personal attack removed by moderator. Please read Forum rules and guidelines, thanks.]

Modified by Chris Ilias

more options

Carm,

I have CCleaner setup on my win7 unit and i added that folder a long time ago to delete all prefetch files. So when I hit CLEAN it clears that folder, and I never have a build up on my computer or browser, but thanks for trying.

more options

for anyone who wants to see the memory build up in your TASK MANAGER>Processes>firefox.exe

It happens to me mostly when I have 2 or 3 tabs open in firefox, and then both have ebay and youtube opened. When I watch just youtube it seems ok, build ebay seems to cause it more so than any other site

My memory build up in the task manager will got over 2GB and start the lagging/stuttering bad, before i need to close the browwwwwwwser, hit my CCleaner to clear the system then restart the process again

more options

seb6000, In your first post you wrote,

Maybe just 1 smart and un-lazy Firefox Developer can follow up on this Flash bug issue...

This forum is for Firefox support, not for reporting bugs to Firefox developers. That being said, you can look through this google search result for Mozilla bug reports involving Firefox, Flash settings, and hardware acceleration, to see what bugs have already been reported. You could also set up an account at bugzilla.mozilla.org (if you haven't already) and file a bug report with specific steps to reproduce and what you've tried.


I also noticed that in your first post you wrote,

Flash video/content crashes instantly, so it makes it impossible to right-click it and enter the settings to disable hardware acceleration.

This is for the benefit of others reading, who are having problems turning off hardware acceleration in Flash settings:

See the Mozilla Support article, Flash Plugin - Keep it up to date and troubleshoot problems (under the Playing Flash videos makes Firefox hang section). It links to this Adobe help page where you can right-click on a supplied Flash logo (instead of trying to right-click on problematic Flash content on webpages) to access Flash settings:

http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

Modified by AliceWyman