X
Tap here to go to the mobile version of the site.

Support Forum

Right click lot of option (play, mute) nothing work

Posted

Hello everybody, i'am using firefox 31 in mint 17 and i have a problem.

When i right click on a link i have too much option (like this : https://support.cdn.mozilla.net/media/uploads/images/2013-04-03-10-07-53-1b8c34.png ) The "open link in new tab" doesn't work.

Other thing, in "manage search engine" window, when i click "Get more search engines" link ... the link doesn't work .... there is nothing

Below, actions i did to solve my problem (without success) :

  • Start firefox in Safe mode (with add on disable) = same problem
  • reset firefox = same problem
  • uninstall firefox, remove the ~/.mozilla, install firefox = same problem
  • create another user in mint, and try with this new user = same problem

I don't know what to do :(

Any ideas ?

Thank you

Hello everybody, i'am using firefox 31 in mint 17 and i have a problem. When i right click on a link i have too much option (like this : https://support.cdn.mozilla.net/media/uploads/images/2013-04-03-10-07-53-1b8c34.png ) The "open link in new tab" doesn't work. Other thing, in "manage search engine" window, when i click "Get more search engines" link ... the link doesn't work .... there is nothing Below, actions i did to solve my problem (without success) : * Start firefox in Safe mode (with add on disable) = same problem * reset firefox = same problem * uninstall firefox, remove the ~/.mozilla, install firefox = same problem * create another user in mint, and try with this new user = same problem I don't know what to do :( Any ideas ? Thank you

Modified by cor-el

Chosen solution

I just found the solutio, you will not believe your eyes go !!!

Since there was no search engine defaults to my firefox, I found the following link which allowed me to add: http://www.linuxmint.com/searchengines/anse.php?sen=Google&c=y

Once I added the Google search engine (I did not have any, I guess another that google would have worked too), right click on firefox works great.

I still do not understand ... it's good to know for the knowledge base;)

Have a nice evenin

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

More Information

Question owner

A litle news :

If i download firefox from mozilla.org and i load it with "./forefox", everything works fine (right clik open in new tab, manage search engine)

What's wrong with the package from Mint ? Did i forget another paquet (i juste install firefox paquet) ?

Thanl you

A litle news : If i download firefox from mozilla.org and i load it with "./forefox", everything works fine (right clik open in new tab, manage search engine) What's wrong with the package from Mint ? Did i forget another paquet (i juste install firefox paquet) ? Thanl you
cor-el
  • Top 10 Contributor
  • Moderator
12146 solutions 112809 answers

Helpful Reply

Such issues with the right-click context menu are usually caused by a extension that isn't working properly.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Such issues with the right-click context menu are usually caused by a extension that isn't working properly. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
FredMcD
  • Top 10 Contributor
850 solutions 12497 answers

Open your add-ons manager. Disable a few add-ons, then Restart Firefox. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Open your add-ons manager. Disable a few add-ons, then '''Restart Firefox'''. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

Question owner

Thank you for yours suggests but i have the problem too.

With the mint package i have 2 add-on : - Mint Search Enhancer - Stylish

I'v disabled but there are no change :(

I dont know what is the difference between Firefox Mint Package and Firefox downloaded from Mozilla.

may be he lacks a mint package? which one ?

thank you

Thank you for yours suggests but i have the problem too. With the mint package i have 2 add-on : - Mint Search Enhancer - Stylish I'v disabled but there are no change :( I dont know what is the difference between Firefox Mint Package and Firefox downloaded from Mozilla. may be he lacks a mint package? which one ? thank you

Chosen Solution

I just found the solutio, you will not believe your eyes go !!!

Since there was no search engine defaults to my firefox, I found the following link which allowed me to add: http://www.linuxmint.com/searchengines/anse.php?sen=Google&c=y

Once I added the Google search engine (I did not have any, I guess another that google would have worked too), right click on firefox works great.

I still do not understand ... it's good to know for the knowledge base;)

Have a nice evenin

I just found the solutio, you will not believe your eyes go !!! Since there was no search engine defaults to my firefox, I found the following link which allowed me to add: http://www.linuxmint.com/searchengines/anse.php?sen=Google&c=y Once I added the Google search engine (I did not have any, I guess another that google would have worked too), right click on firefox works great. I still do not understand ... it's good to know for the knowledge base;) Have a nice evenin