X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes at startup or shortly after

Posted

Hi

Whenever I open Firefox 31 (on mavericks) it crashes at startup or after browsing a minute or two. Already tried:

- disabled HW acceleration - disabled add-ons - re-installed ff - deleted profile

problem still exists. I get the following error message:

AdapterDeviceID: 0x6741 AdapterVendorID: 0x1002 Add-ons: %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:31.0 BuildID: 20140716183446 CrashTime: 1408087029 EMCheckCompatibility: true EventLoopNestingLevel: 1 FramePoisonBase: 7ffffffff0dea000 FramePoisonSize: 4096 InstallTime: 1408083991 Notes: AdapterVendorID: 0x1002, AdapterDeviceID: 0x6741 ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SecondsSinceLastCrash: 217 StartupTime: 1408086927 Theme: classic/1.0 Throttleable: 1 Vendor: Mozilla Version: 31.0 useragent_locale: de

can anyone help? thanks

Hi Whenever I open Firefox 31 (on mavericks) it crashes at startup or after browsing a minute or two. Already tried: - disabled HW acceleration - disabled add-ons - re-installed ff - deleted profile problem still exists. I get the following error message: AdapterDeviceID: 0x6741 AdapterVendorID: 0x1002 Add-ons: %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:31.0 BuildID: 20140716183446 CrashTime: 1408087029 EMCheckCompatibility: true EventLoopNestingLevel: 1 FramePoisonBase: 7ffffffff0dea000 FramePoisonSize: 4096 InstallTime: 1408083991 Notes: AdapterVendorID: 0x1002, AdapterDeviceID: 0x6741 ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SecondsSinceLastCrash: 217 StartupTime: 1408086927 Theme: classic/1.0 Throttleable: 1 Vendor: Mozilla Version: 31.0 useragent_locale: de can anyone help? thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Bietet Informationen über den Standardwebbrowser
  • Mit dem QuickTime Plug-in können Sie eine Vielzahl von Multimedia-Inhalten auf Webseiten anzeigen. Weitere Informationen erhalten Sie auf der Web-Site für QuickTime.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.07
  • iPhoto6
  • Amazon MP3 Downloader Plugin 1.0.17
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Office Live Update v1.0

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/Darwin/de/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flip4mac wmv plugin: 0
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
Lutherus Shyrilser 0 solutions 1 answers

We're sorry to hear that Firefox is crashing when you open it. Please do the following to give us crash IDs that will help us understand more about the crash.

  1. (OS X 10.6 or previous) Click the Finder icon in the dock. Your home folder will be selected. In the right side of the window, click the Library folder to open it. Then open the "Application Support" folder, the "Firefox" folder, the "Crash Reports" folder and finally the "submitted" folder.
    (OS X 10.7 or above) Click the Finder icon in the dock. On the menu bar, click the Go menu, hold down the option or alt key and select Library. A window will open containing your Library folder. Then open the "Application Support" folder, the "Firefox" folder, the "Crash Reports" folder and finally the "submitted" folder.
  2. Open the 5 most recent files with a text editor and copy the IDs.
  3. Paste each ID with bp- into the reply window on the forums.

Thanks in advance!

You can find more information and troubleshooting steps in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

We're sorry to hear that Firefox is crashing when you open it. Please do the following to give us crash IDs that will help us understand more about the crash. #'''(OS X 10.6 or previous)''' Click the '''Finder''' icon in the dock. Your home folder will be selected. In the right side of the window, click the Library folder to open it. Then open the "Application Support" folder, the "Firefox" folder, the "Crash Reports" folder and finally the "submitted" folder.<br>'''(OS X 10.7 or above)''' Click the '''Finder''' icon in the dock. On the menu bar, click the '''Go''' menu, hold down the '''option''' or '''alt''' key and select '''Library'''. A window will open containing your Library folder. Then open the "Application Support" folder, the "Firefox" folder, the "Crash Reports" folder and finally the "submitted" folder. #Open the 5 most recent files with a text editor and copy the IDs. #Paste each ID with '''bp-''' into the reply window on the forums. Thanks in advance! You can find more information and troubleshooting steps in the [[Firefox crashes]] article.

Question owner

Hi, thanks for your reply. Here are the 5 recent crash ID's:

bp-253c9758-0987-4dba-9de2-eac2e2140815 bp-85511633-1eac-4179-8fe1-a70832140815 bp-d17309f0-6405-45ad-b253-96a4f2140815 bp-e15fd213-17c1-410f-a702-1115d2140815 bp-80e18730-1fcf-4d56-8bf3-359f22140815

Hi, thanks for your reply. Here are the 5 recent crash ID's: bp-253c9758-0987-4dba-9de2-eac2e2140815 bp-85511633-1eac-4179-8fe1-a70832140815 bp-d17309f0-6405-45ad-b253-96a4f2140815 bp-e15fd213-17c1-410f-a702-1115d2140815 bp-80e18730-1fcf-4d56-8bf3-359f22140815
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Your crash reports show several causes;

Signature js::types::TypeObject::getProperty(js::ExclusiveContext*, jsid)

Signature nsSVGElement::Init()

Signature isalloc_validate | ozone_size

Signature MarkInternal<JSObject>

Signature nsSVGElement::Init()

Your crash reports show several causes; Signature js::types::TypeObject::getProperty(js::ExclusiveContext*, jsid) Signature nsSVGElement::Init() Signature isalloc_validate | ozone_size Signature MarkInternal<JSObject> Signature nsSVGElement::Init()
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Press the '''Alt''' or '''F10''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Hi, HW acceleration is already disabled. didn't solve the issue. I also tried:

- disabled add-ons - re-installed ff - deleted profile - re-installed java

still same error :( could it be related to hardware?

Hi, HW acceleration is already disabled. didn't solve the issue. I also tried: - disabled add-ons - re-installed ff - deleted profile - re-installed java still same error :( could it be related to hardware?
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Open Firefox to; Testing plugins - MozillaZine Knowledge Base

Do you have another web browser? See if there is any problem.

Suggestion; Some of your crash reports seem to look like a problem with Java Script. Open your computer program list and remove it.

Open Firefox to; '''[http://kb.mozillazine.org/Testing_plugins Testing plugins - MozillaZine Knowledge Base]''' Do you have another web browser? See if there is any problem. Suggestion; Some of your crash reports seem to look like a problem with Java Script. Open your computer program list and remove it.

Question owner

Hi Fred, first of all thanks for your help!

1. Removing Java allowed me to surf for 5 mins without crash, when istalling it agian - immediate crases are back 2. Indeed, Safari crashes as well - but not as often as ff

when I reset the mac with a TimeMachine backup, everythings fine for a few hours before the crashes are back again... I don't get it

Hi Fred, first of all thanks for your help! 1. Removing Java allowed me to surf for 5 mins without crash, when istalling it agian - immediate crases are back 2. Indeed, Safari crashes as well - but not as often as ff when I reset the mac with a TimeMachine backup, everythings fine for a few hours before the crashes are back again... I don't get it
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Okay, sounds like the problem is the computer itself. Or one of its programs / data files. Out of date, corrupted, whatever.

Please list all of the crash reports for the last few days.

Remove Java

Set all plugins to Disable. Don't worry about those for now.

Okay, sounds like the problem is the computer itself. Or one of its programs / data files. Out of date, corrupted, whatever. Please list all of the crash reports for the last few days. Remove Java Set all plugins to '''Disable.''' Don't worry about those for now.

Question owner

Update:

The iMac had a faulty RAM module which I removed, i also re-installed mavericks. Also java is uninstalled and no plug-in is running. Still FF crashes on certrain webpages. The only workaround I currently have is to use Safari as it's stable since I removed the faulty RAM.

So I'll live with that for now.

Update: The iMac had a faulty RAM module which I removed, i also re-installed mavericks. Also java is uninstalled and no plug-in is running. Still FF crashes on certrain webpages. The only workaround I currently have is to use Safari as it's stable since I removed the faulty RAM. So I'll live with that for now.
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Post your latest crash reports. Also, tell us that web sites you were on. When the Firefox Crashed window comes up, there is a space for user comments.

Post your latest crash reports. Also, tell us that web sites you were on. When the '''Firefox Crashed''' window comes up, there is a space for user comments.

Question owner

Hi, latest crash reports:

bp-ffd34e3d-6293-47b5-b0bd-511f42140818 bp-249d6064-aeca-48c7-8f21-8e7a42140818

website where FF crash occours all the time after a second or two: http://www.auto-motor-und-sport.de/

fine with other browsers

Hi, latest crash reports: bp-ffd34e3d-6293-47b5-b0bd-511f42140818 bp-249d6064-aeca-48c7-8f21-8e7a42140818 website where FF crash occours all the time after a second or two: http://www.auto-motor-und-sport.de/ fine with other browsers
FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Loads okay for me.

Loads okay for me.

Modified by FredMcD

FredMcD
  • Top 10 Contributor
4270 solutions 59887 answers

Signature nsSVGElement::Init()

if you have SVG, disable it.

Signature nsSVGElement::Init() if you have SVG, disable it.
guigs 1072 solutions 11697 answers

Hi Cominottom, Thank you for your question, this is a response to the "escalate" tag. I understand that Firefox crashes on a specific website and that you have removed java, disabled hardware acceleration, have tried a new profile and disabled extensions and removed faulty RAM.

The only hint is the signature, and the line it breaks in is when the page is getting the boolean info of the SVG. However there are no svg elements on the page. However the page does require javascript. I am wondering if it has to do with the graphic drivers, since there was an update to your hardware. Upgrade your graphics drivers to use hardware acceleration and WebGL

Just an observation: The previous config for the Raedon was:

layers.acceleration.force-enabled = true 

gfx.direct2d.force-enabled = true

where currently you have : gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d9: 3 layers.acceleration.disabled: True

Can you try to create a new profile for the new hardware set up to see if there is an improvement? Profile Manager - Create, remove, or switch Firefox profiles

Looking forward to your reply!

Hi Cominottom, Thank you for your question, this is a response to the "escalate" tag. I understand that Firefox crashes on a specific website and that you have removed java, disabled hardware acceleration, have tried a new profile and disabled extensions and removed faulty RAM. The only hint is the signature, and the line it breaks in is when the page is getting the boolean info of the SVG. However there are no svg elements on the page. However the page does require javascript. I am wondering if it has to do with the graphic drivers, since there was an update to your hardware. [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Just an observation: The previous config for the Raedon was: layers.acceleration.force-enabled = true gfx.direct2d.force-enabled = true where currently you have : gfx.blacklist.direct2d: 3 gfx.blacklist.layers.direct3d9: 3 layers.acceleration.disabled: True Can you try to create a new profile for the new hardware set up to see if there is an improvement? [[Use the Profile Manager to create and remove Firefox profiles]] Looking forward to your reply!