X
Tap here to go to the mobile version of the site.

Support Forum

Secure Connection fail when using https://www.website.com; Error code: sec_error_bad_signature)

Posted

Why, when I use Internet explorer, I can utilize https, but unable to use it in mozilla?

Why, when I use Internet explorer, I can utilize https, but unable to use it in mozilla?

Additional System Details

Installed Plug-ins

  • VLC media player Web Plugin 2.1.3
  • Shockwave Flash 14.0 r0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Next Generation Java Plug-in 11.5.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • WinZip Courier Plugin for Mozilla Firefox

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

christ1
  • Top 25 Contributor
2174 solutions 15942 answers

Click the site identity button - More Information - View Certificate https://support.mozilla.org/en-US/kb/how-do-i-tell-if-my-connection-is-secure

Look for 'Issued By' and post that information.

Note that some anti-virus/firewall software and programs like Sendori, FiddlerRoot, or BrowserProtect can intercept your secure connections and send their own certificate instead of the website's certificate.

Click the site identity button - More Information - View Certificate https://support.mozilla.org/en-US/kb/how-do-i-tell-if-my-connection-is-secure Look for 'Issued By' and post that information. Note that some anti-virus/firewall software and programs like Sendori, FiddlerRoot, or BrowserProtect can intercept your secure connections and send their own certificate instead of the website's certificate.
cor-el
  • Top 10 Contributor
  • Moderator
17570 solutions 158915 answers

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.


Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar. *https://support.mozilla.org/kb/Secure+Connection+Failed Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored. If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate. If that didn't help then remove or rename secmod.db (secmod.db.old) as well. ----