X
Tap here to go to the mobile version of the site.

Support Forum

So I guess click-to-play doesn't work on FF 31.0?

Posted

Just updated to FF 31.0 & even tho click-to-play is set to "true" and I've got all plugins set to "Ask to activate", it's not working; worked just fine with v. 30.

Just updated to FF 31.0 & even tho click-to-play is set to "true" and I've got all plugins set to "Ask to activate", it's not working; worked just fine with v. 30.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Google Update
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • GEPlugin
  • NPWLPG
  • Amazon MP3 Downloader Plugin 1.0.17
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

Sourjobraato Banerjee 14 solutions 232 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Please check if all your plugins are up-to-date. To do this, go to the [http://mozilla.com/plugincheck Mozilla Plugin Check site]. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow ''Update'' button or a red ''Update now'' button, please update these immediately. To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Question owner

Thanks for the suggestion, Banerjee; I just checked at the link you gave & all plugins are up-to-date (I figured they were since I try really hard to keep on top of that). But click-to-play (even tho it's turned on supposedly) is still not working; it worked just great 'till I updated from FF 30 to 31 a few days ago. So now I've got irritating flash ads playing again, sigh. I miss FF 30. Oh well, thanks anyway.

Thanks for the suggestion, Banerjee; I just checked at the link you gave & all plugins are up-to-date (I figured they were since I try really hard to keep on top of that). But click-to-play (even tho it's turned on supposedly) is still not working; it worked just great 'till I updated from FF 30 to 31 a few days ago. So now I've got irritating flash ads playing again, sigh. I miss FF 30. Oh well, thanks anyway.
cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159054 answers

What plugin isn't working?

Do you see the Lego block icon at the left end of the location/address bar?

What plugin isn't working? Do you see the Lego block icon at the left end of the location/address bar?

Modified by cor-el

Helpful Reply

All plugins are working; it's the click-to-play feature for plugins that has stopped working; it was working just fine with FF 30 & stopped as soon as I updated to FF 31. So I guess it must be a version 31 glitch. Thanks anyway.

All plugins are working; it's the '''click-to-play feature''' for plugins that has stopped working; it was working just fine with FF 30 & stopped as soon as I updated to FF 31. So I guess it must be a version 31 glitch. Thanks anyway.

Question owner

P.S. No, don't see any Lego block icon; don't have a clue what that is??

P.S. No, don't see any Lego block icon; don't have a clue what that is??
jscher2000
  • Top 10 Contributor
8794 solutions 71948 answers

Usually you will see a "Lego-like" icon to the left of the URL in the address bar when a page wants to use a plugin. This should appear even if the other two indications are not visible: grayed plugin area or "infobar" sliding down below the toolbar area.

Edit: Adding a screen shot.

Usually you will see a "Lego-like" icon to the left of the URL in the address bar when a page wants to use a plugin. This should appear even if the other two indications are not visible: grayed plugin area or "infobar" sliding down below the toolbar area. ''Edit: Adding a screen shot.''

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159054 answers
See: *https://support.mozilla.org/kb/why-do-i-have-click-activate-plugins

Question owner

@jscher2000: no, don't see that Lego plugin block to the left of the location bar; what I do see is that little padlock or whatever it is. And you know what else is weird about all this: I can't get click-to-play to work on my Dell computer since I updated to FF 31, but I updated FF to 31 on my Toshiba laptop and click-to-play is working just fine (got the plugin block to the left of the location bar) & I've got the same exact plugins (all set to "ask to activate") on both computers! So apparently it's not a version 31 glitch, but why why why has it stopped working on my Dell?! (Only thing that's happened recently with the Dell is had to have a new video card installed.)

@jscher2000: no, don't see that Lego plugin block to the left of the location bar; what I do see is that little padlock or whatever it is. And you know what else is weird about all this: I can't get click-to-play to work on my Dell computer since I updated to FF 31, but I updated FF to 31 on my Toshiba laptop and click-to-play is working just fine (got the plugin block to the left of the location bar) & I've got the same exact plugins (all set to "ask to activate") on both computers! So apparently it's not a version 31 glitch, but why why why has it stopped working on my Dell?! (Only thing that's happened recently with the Dell is had to have a new video card installed.)
Rabimba_Karanjai 4 solutions 8 answers
  1. Open FireFox.
  2. Type about:config into the address bar and hit Enter.
  3. If you receive a warning about modifying settings, click the I'll be careful, I promise button to proceed.
  4. In the search bar that appears at the top of the page, enter plugins.click_to_play. The configuration setting should appear on a single line.
  5. It is porbably disabled in your case "false". Right-click the configuration setting and select Toggle. The value column should change from false to true.
  6. Restart Firefox. Click to Play is now enabled.

Remember your settings should say "true".

Revert back if you still have problem.

# Open FireFox. # Type about:config into the address bar and hit Enter. # If you receive a warning about modifying settings, click the I'll be careful, I promise button to proceed. # In the search bar that appears at the top of the page, enter plugins.click_to_play. The configuration setting should appear on a single line. # It is porbably disabled in your case "false". Right-click the configuration setting and select Toggle. The value column should change from false to true. # Restart Firefox. Click to Play is now enabled. Remember your settings should say "true". Revert back if you still have problem.

Question owner

@Rabimba_Karanjai: guess I didn't make it clear enuff above: I had already done all that a long time ago on both computers; when I updated to FF 31 on my Dell, click-to-play stopped working; I did all you suggested *again* on the Dell, but click-to-play is not working. Thanks anyway though.

@Rabimba_Karanjai: guess I didn't make it clear enuff above: I had already done all that a long time ago on both computers; when I updated to FF 31 on my Dell, click-to-play stopped working; I did all you suggested *again* on the Dell, but click-to-play is not working. Thanks anyway though.
jscher2000
  • Top 10 Contributor
8794 solutions 71948 answers

Hi officerripley, could you clarify what you mean by "not working" -- all plugins set to "Ask to Activate" are activated automatically? Or blocked automatically?

To rule out extensions as a possible culprit, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

Hi officerripley, could you clarify what you mean by "not working" -- all plugins set to "Ask to Activate" are activated automatically? Or blocked automatically? To rule out extensions as a possible culprit, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled Note: plugins still run After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (''not'' Reset) Any difference?

Question owner

@jscher2000 - By "not working", yes all plugins set to "ask to Activate" are activated automatically. As you suggested I tested in FF's Safe Mode as you specified, but no difference; plugins are still auto. activating; most irritating is FlashPlayer ads; it was so nice with FF 30 to be able to click on only the FlashPlayer stuff I wanted to watch. Oh well, thanks anyway.

@jscher2000 - By "not working", yes all plugins set to "ask to Activate" are activated automatically. As you suggested I tested in FF's Safe Mode as you specified, but no difference; plugins are still auto. activating; most irritating is FlashPlayer ads; it was so nice with FF 30 to be able to click on only the FlashPlayer stuff I wanted to watch. Oh well, thanks anyway.
cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159054 answers

Try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases.

See Re-initializing the plugins database:

Try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases. See Re-initializing the plugins database: *https://support.mozilla.org/kb/troubleshoot-issues-with-plugins-fix-problems

Question owner

An update, an hour after testing FF in safe mode as suggested, some sites have just started asking to activate FlashPlayer; not all sites unfortunately--xfinity & amazon for instance are still autoplaying Flash stuff--but some sites asking are better than none. Thanks for the help everyone!

An update, an hour after testing FF in safe mode as suggested, some sites have just started asking to activate FlashPlayer; not all sites unfortunately--xfinity & amazon for instance are still autoplaying Flash stuff--but some sites asking are better than none. Thanks for the help everyone!
cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159054 answers
Are you sure that a Flash player is used and not an HTML5 media player with an audio or video element? *https://developer.mozilla.org/Web/Guide/HTML/Using_HTML5_audio_and_video *https://developer.mozilla.org/HTML/Element/video *https://developer.mozilla.org/HTML/Element/audio
jscher2000
  • Top 10 Contributor
8794 solutions 71948 answers

Following on cor-el's comment: if you right-click the media player, if Firefox is handling it natively, you often get an ordinary right-click context menu, while if a plugin is playing it, you usually get a short menu mentioning the name of the plugin.

Following on cor-el's comment: if you right-click the media player, if Firefox is handling it natively, you often get an ordinary right-click context menu, while if a plugin is playing it, you usually get a short menu mentioning the name of the plugin.
Arcticias 0 solutions 1 answers

Helpful Reply

I had this same issue. I was rummaging around config files and menus when I stumbled upon these options in about:addons. Once I changed them to ask to activate everything started working just like it used to. If I set plugins.click_to_play to false and still have the plugins set to ask to activate they will continue to ask to activate. Not sure if this is intended or a feature, but it works!

I had this same issue. I was rummaging around config files and menus when I stumbled upon these options in about:addons. Once I changed them to ask to activate everything started working just like it used to. If I set plugins.click_to_play to ''false'' and still have the plugins set to ask to activate they will continue to ask to activate. Not sure if this is intended or a feature, but it works!