Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox ver 31 latest doesn't play videos -

  • 29 replies
  • 82 have this problem
  • 6050 views
  • Last reply by jscher2000

more options

Firefox will not play videos in or out of U-Tube. . All videos play in I.E. ver 11.0.10 without an issue

In Firefox I get a large black square that reduces to a black bar and then when I place the cursor in the area where the video should be I see a flashing rotating circle.

Just updated Firefox Ver 31RC1 today 7-16-14 Flash Plugin = Ver 14.0.0.145 Quicktime plugin = Ver Version: 7.7.5.0 Windows 7-64 All updates loaded

Application Basics


Name: Firefox Version: 31.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Crash Reports for the Last 3 Days


Report ID: bp-4ae398ae-dc97-42ba-8287-e8f502140715 Submitted: 2 days ago

All Crash Reports

Extensions


Name: Adblock Plus Version: 2.6.3 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Address Bar Search Version: 1.2 Enabled: true ID: {badea1ae-72ed-4f6a-8c37-4db9a4ac7bc9}

Name: BetterPrivacy Version: 1.68 Enabled: true ID: {d40f5e7b-d2cf-4856-b441-cc613eeffbe3}

Name: DownloadHelper Version: 4.9.22 Enabled: true ID: {b9db16a4-6edc-47ec-a1f4-b86292ed211d}

Name: F.B. Purity - Cleans Up Facebook Version: 9.9.1 Enabled: true ID: fbp@fbpurity.com

Name: Garmin Communicator Version: 4.1.0 Enabled: true ID: {195A3098-0BD5-4e90-AE22-BA1C540AFD1E}

Name: Logitech Device Detection Version: 1.23.0.5 Enabled: true ID: DeviceDetection@logitech.com

Name: MAFIAAFire Redirector Version: 0.9d Enabled: true ID: MafiaaFire@mafiaafire.com

Name: MapsGalaxy Version: 6.58.4.18298 Enabled: true ID: 39ffxtbr@MapsGalaxy_39.com

Name: Skype Click to Call Version: 7.2.15747.10003 Enabled: true ID: {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}

Name: Adobe DLM (powered by getPlus(R)) Version: 1.6.2.63 Enabled: false ID: {E2883E8F-472F-4fb0-9522-AC9BF37916A7}

Name: Advanced SystemCare Surfing Protection Version: 1.0 Enabled: false ID: ascsurfingprotection@iobit.com

Name: Hyperwords Version: 6.5.3 Enabled: false ID: {9A752782-D706-479b-98F8-3F66BF921692}

Graphics


Adapter Description: NVIDIA GeForce GTS 250 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 1024 ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 0 Enhanced Contrast: 50 Device ID: 0x0615 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 3-4-2014 Driver Version: 9.18.13.3523 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x10de WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTS 250 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind: true accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 4 browser.cache.memory.capacity: 65536 browser.display.show_image_placeholders: true browser.display.use_document_fonts: 0 browser.history_expire_days.mirror: 180 browser.places.importBookmarksHTML: false browser.places.smartBookmarksVersion: 7 browser.search.param.yahoo-fr: chr-greentree_ff&type=380920&ilc=12 browser.search.useDBForOrder: true browser.sessionstore.upgradeBackup.latestBuildID: 20140714151536 browser.startup.homepage: http://www.msn.com/ browser.startup.homepage_override.buildID: 20140714151536 browser.startup.homepage_override.mstone: 31.0 browser.tabs.warnOnClose: false browser.urlbar.autocomplete.enabled: true dom.max_script_run_time: 1800 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 31.0 font.internaluseonly.changed: false font.minimum-size.x-western: 14 font.size.fixed.x-western: 14 font.size.variable.x-western: 14 gfx.direct3d.checkDX10: false gfx.direct3d.last_used_feature_level_idx: 1 network.cookie.prefsMigrated: true network.http.max-connections: 48 network.http.max-connections-per-server: 16 network.http.max-persistent-connections-per-proxy: 16 network.http.max-persistent-connections-per-server: 8 network.http.pipelining.maxrequests: 8 network.http.request.max-start-delay: 0 places.database.lastMaintenance: 1405542420 places.history.expiration.transient_current_max_pages: 104858 places.history.expiration.transient_optimal_database_size: 167772160 places.last_vacuum: 1296747843 plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf plugin.expose_full_path: true plugin.importedState: true plugin.state.flash: 1 plugin.state.nppl: 0 plugin.state.npqtplugin: 1 print.print_printer: Adobe PDF print.printer_Epson_Stylus_Photo_R200_(M).print_bgcolor: false privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1404830167

user.js Preferences


Your profile folder contains a user.js file, which includes preferences that were not created by Firefox.

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.6 Version in use: 4.10.6

NSS Expected minimum version: 3.16.2 Basic ECC Version in use: 3.16.2 Basic ECC

NSSSMIME Expected minimum version: 3.16.2 Basic ECC Version in use: 3.16.2 Basic ECC

NSSSSL Expected minimum version: 3.16.2 Basic ECC Version in use: 3.16.2 Basic ECC

NSSUTIL Expected minimum version: 3.16.2 Version in use: 3.16.2

Experimental Features


All Replies (9)

more options

I think you already did this, but just in case:

Could you switch Flash to "Always Activate" to see whether the click-to-play feature is causing the problem? Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Scroll down to Shockwave Flash and change "Ask to Activate" to "Always Activate" (the default is "Always Activate").

When you load or reload a page using Flash, Firefox should now run it automatically.


On some systems, Flash does not work properly in its default configuration. These are some common workarounds:

(1) Disable hardware graphics acceleration in Flash

See this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable the plugin's protected mode feature

This involves creating or editing a settings file. The following pages/posts provide different ways to do that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.


If you do remove Flash again:

Since Firefox can't use a 64-bit plugin -- I mean specifically Firefox, and not third party variations on Firefox -- some alternate player might have been in use while Flash was missing. After removing Flash, to see how videos are playing, try right-clicking the display area and checking the pop-up context menu. It may indicate a different plugin, or it might be playing in Firefox's native HTML5 player. If it's a different plugin, perhaps there is a conflict?

more options

Update to above. When I first downloaded Flash for FireFox, the videos played. It wasn't until I rebooted my system that the videos in FireFox STOPPED playing agian????

I don't know if I should start a new thread or continue this one. I unloaded (removed) the Adobe Flash Player 14 Plugin from my system that loaded today and I am able to play videos that failed with this installed. here is an example of a video that now plays.

http://msnvideo.msn.com/?channelindex=2&from=en-us_msnhp#/video/5dc0433b-50ae-e97d-5449-c5f34520db34

I can also VIEW videos from the Weather channel.

Adobe Flash Player 14 ActiveX is still loaded on my system

I can't view any of the videos posted in Facebook and non of the ones I've tried from U-Tube.

It appears that there is a conflict with the 32 bit plugin.

more options

I reloaded Flash via FireFox. All videos Played I set Flash to Alweay Activate All Videos played I closed and reopened FireFox All videos played I rebooted my computer Opened FireFox ALL videos FAILED to play I set all plugins to ASK EXCEPT Flash and Logitech device detection ALL Videos FAILED to play I disabled all Extensions EXCEPT Troubleshooting and Logictech device detection All videos FAILED to play I Removed Flash Player 14 Plugin from my system Most Videos PLAYED, some asked for flash

I tried right clicking, but most times the player wasn't shown (attached). I did see two with the HTML5.

This video did NOT pla in Facebook using FireFox, but when I opened it's link using FireFox it played with HTML5.

https://www.youtube.com/watch?v=QlB_tP5aOpU

This is something that started with ver 30. Prior to that I had NO ISSUES playing videos. There was a Flash update the same day as there was a FireFox update.

more options

Hi kensch, when I set Shockwave Flash to "Never Activate", which makes it invisible to websites, the MSN video site uses Firefox's built-in HTML5 player. (Many sites support HTML5 because iPhone doesn't have Flash.)

You indicated:

"Update to above. When I first downloaded Flash for FireFox, the videos played. It wasn't until I rebooted my system that the videos in FireFox STOPPED playing agian????"

If you have Advanced SystemCare, it apparently has a feature to make some settings changes in Firefox on system startup. That might be a factor.

Otherwise, I can't think of anything that occurs when you restart Windows that should affect Firefox.

Modified by jscher2000

more options

I disabled Advanced SystemCare from starting on boot via msconfig, but that didn't seem to help. I will have play more after Imy eye is better. THANK YOU for your help

more options

I have this same problem. I have removed all add-ons and plug-ings. I'll go back to Safari until I hear back.

more options

Hi Kirk R Holz, are on you Mac? Make sure you have the Shockwave Flash plugin installed and activated. If it no longer appears on your Add-ons page in the Plugins section, you can re-download it here:

http://get.adobe.com/flashplayer/

more options

Nope, videos play fine in Safari before and after reinstalling Flash Plug-in.

Still no video on Facebook in Firefox v32.0.3 (with no add-ons).

Yes I'm on Mac OS X 10.9.5

Modified by Kirk R Holz

more options

Hi Kirk R Holz, is the problem only with Facebook video, or is Flash failing on other sites that use it, such as YouTube?

Regarding the "no add-ons" part of your posts, is there where you've checked:

If you open the Add-ons page using either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins.

Is "Shockwave Flash" present and set to "Always Activate"?

In the left column, click Extensions.

Is this the area that has no Add-ons?

  1. 1
  2. 2