X
Tap here to go to the mobile version of the site.

Support Forum

Updated to Firefox v.30, now I can't attach files to my Gmail or download files from websites. The troubleshooting stuff doesn't work. What's wrong?

Posted

Shortly after my PC (WinXP SP3) auto-updated to Firefox 30, I found that I could no longer attach files to my Gmail. Clicking on the paperclip icon would make the screen blink, then nothing. No list of files, no selecting files to attach.

Further testing showed that I could no longer right-mouse click on an image and save it. The right-mouse click will bring up the menu, but when I select "Save Image As" again, the screen blinks, and nothing happens.

When I tried attaching my resume to an online application, the website's "Browse" button won't bring up a file-listing to select my resume.

I have tried all the actions suggested in similar posts: I have disabled my anti-virus, I have cleared cookies, I have reset Firefox, I have restarted my router. Nothing has fixed the issue.

I do not have this problem when using IE8

Shortly after my PC (WinXP SP3) auto-updated to Firefox 30, I found that I could no longer attach files to my Gmail. Clicking on the paperclip icon would make the screen blink, then nothing. No list of files, no selecting files to attach. Further testing showed that I could no longer right-mouse click on an image and save it. The right-mouse click will bring up the menu, but when I select "Save Image As" again, the screen blinks, and nothing happens. When I tried attaching my resume to an online application, the website's "Browse" button won't bring up a file-listing to select my resume. I have tried all the actions suggested in similar posts: I have disabled my anti-virus, I have cleared cookies, I have reset Firefox, I have restarted my router. Nothing has fixed the issue. I do not have this problem when using IE8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Google Update
  • DivX Web Player version 3.2.1.977
  • DivX VOD Helper Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Version 5.3.1.18536
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5.146
  • GEPlugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • npmnqmp 989898989877
  • Veoh Web Video Player Browser Plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Rhapsody Player Engine Plugin

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 9.0.2021.112 (wrc@avast.com) (Inactive)
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Move Media Player 7 (moveplayer@movenetworks.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6600
  • adapterDescription2:
  • adapterDeviceID: 0x0141
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 6.14.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1405383613
  • places.history.expiration.transient_current_max_pages: 53646
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1405383608

Misc

  • User JS: No
  • Accessibility: No
I.T_guy 1 solutions 6 answers

The problem may be because you accidentally changed the internet settings for the whole computer somehow and did not realize it. This could have been done by several ways, including but not limited to, fooling around with the Internet Explorer settings.

I use Firefox regularly but I fixed this problem by opening Internet Explorer and doing these steps.

Tools -> Internet Options -> Advanced

When in the Advanced tab, did these two things 1) Click "Restore Advanced Settings" and than 2) Click Reset (and OK to all the message warnings)


In some cases the attach file lies under your browser meaning it is open you just cant see it. Check if you resize your browser page if that helps.

The problem may be because you accidentally changed the internet settings for the whole computer somehow and did not realize it. This could have been done by several ways, including but not limited to, fooling around with the Internet Explorer settings. I use Firefox regularly but I fixed this problem by opening Internet Explorer and doing these steps. Tools -> Internet Options -> Advanced When in the Advanced tab, did these two things 1) Click "Restore Advanced Settings" and than 2) Click Reset (and OK to all the message warnings) In some cases the attach file lies under your browser meaning it is open you just cant see it. Check if you resize your browser page if that helps.

Question owner

I'm afraid resetting the Internet Options as you described didn't work. However, two things:

1. After completing the actions you described, I restarted my PC but the problem was still there. However, later I restarted my PC in Safe Mode with Networking. I found that while I was in safe mode, I could both download files and attach files to my GMail, which I could not do before. Unfortunately, when I restarted my PC in regular mode, the problem was still there.

I have an extension called "DownThemAll". When I was first trying the troubleshooting I disabled this extension along with all my other extensions to no avail. However, after I reset my Internet Options, I found that I can download files using "DownThemAll". I still cannot attach files to my GMail, though.

Any further suggestions would be greatly appreciated.

I'm afraid resetting the Internet Options as you described didn't work. However, two things: 1. After completing the actions you described, I restarted my PC but the problem was still there. However, later I restarted my PC in Safe Mode with Networking. I found that while I was in safe mode, I could both download files and attach files to my GMail, which I could not do before. Unfortunately, when I restarted my PC in regular mode, the problem was still there. I have an extension called "DownThemAll". When I was first trying the troubleshooting I disabled this extension along with all my other extensions to no avail. However, after I reset my Internet Options, I found that I can download files using "DownThemAll". I still cannot attach files to my GMail, though. Any further suggestions would be greatly appreciated.
iamjayakumars 489 solutions 5951 answers

Check your Flash enabled on Gmail.com or not

Check your Flash enabled on Gmail.com or not
danallenfirefox 1 solutions 18 answers

All the buttons in gmail work except the attach file icon. Inserting an image works. Just no attach a file. Only Firefox affected. Attach file in gmail with IE works.

All the buttons in the attached image work, except the paperclip.

All the buttons in gmail work except the attach file icon. Inserting an image works. Just no attach a file. Only Firefox affected. Attach file in gmail with IE works. All the buttons in the attached image work, except the paperclip.
jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Helpful Reply

For now, you need to create an exception to pop-up blocking for Gmail. Here's how:

While you have the compose window on the screen, click the padlock in the address bar.

  • If the pop-up permission is listed there as Block, try changing it to Allow.
  • If the pop-up permission is not listed there, click More Information to launch the Page Info dialog, then click Permissions in the top bar. Scroll down to "Open pop-up windows", uncheck the box for "Set default" then click Allow and close the dialog.

Then try the paper clip again. Success?

Unfortunately, that is "Google-wide" and not limited to mail, so... other pop-ups are possible that you've never noticed before.

Google indicates on their forums that they're working on fixing this, so you might check in a couple days whether you can block pop-ups on Google again.

For now, you need to create an exception to pop-up blocking for Gmail. Here's how: While you have the compose window on the screen, click the padlock in the address bar. * If the pop-up permission is listed there as Block, try changing it to Allow. * If the pop-up permission is not listed there, click More Information to launch the Page Info dialog, then click Permissions in the top bar. Scroll down to "Open pop-up windows", uncheck the box for "Set default" then click Allow and close the dialog. Then try the paper clip again. Success? Unfortunately, that is "Google-wide" and not limited to mail, so... other pop-ups are possible that you've never noticed before. Google indicates on their forums that they're working on fixing this, so you might check in a couple days whether you can block pop-ups on Google again.