X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't recognize latest javascript

Posted

I just installed the latest javascript, removed the old, restarted and firefox still doesn't "recognize the address" When I open Tools, Add-Ons, check to see if plug-ins are up-to-date, a message at the top says "Firefox has prevented the unsafe plug in Java Deployment Toolkit, but further down the page it shows thumbs up up to date.

I just installed the latest javascript, removed the old, restarted and firefox still doesn't "recognize the address" When I open Tools, Add-Ons, check to see if plug-ins are up-to-date, a message at the top says "Firefox has prevented the unsafe plug in Java Deployment Toolkit, but further down the page it shows thumbs up up to date.

Modified by Noah_SUMO

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.60.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 14.0 r0
  • Google Update
  • 5.1.30214.0
  • GEPlugin
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AddThis 3.5.9 ({3e0e7d2a-070f-4a47-b019-91fe5385ba79})
  • AVG Security Toolbar 18.1.7.644 (avg@toolbar)
  • NoScript 2.6.8.33 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Pin It button 1.1 (pinterest@robertnyman.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • HP Smart Web Printing 4.51 (smartwebprinting@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon(TM) HD 6520G
  • adapterDescription2:
  • adapterDeviceID: 0x9647
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 10-13-2011
  • driverDate2:
  • driverVersion: 8.910.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon(TM) HD 6520G Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.casesensitive: 1
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 30.0
  • font.name.serif.x-western: Aharoni
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • javascript.options.ion.chrome: True
  • javascript.options.mem.log: True
  • javascript.options.mem.notify: True
  • javascript.options.strict: True
  • javascript.options.typeinference.chrome: True
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.external.javascript: True
  • places.database.lastMaintenance: 1405125403
  • places.history.expiration.transient_current_max_pages: 93294
  • places.history.expiration.transient_optimal_database_size: 149269708
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npgoogleupdate: 2
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1403668684

Misc

  • User JS: No
  • Accessibility: No
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 solutions 40140 answers
To avoid confusion: http://kb.mozillazine.org/JavaScript_is_not_Java http://kb.mozillazine.org/Java http://kb.mozillazine.org/JavaScript
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

cor-el

For extensions I do have Ad Block Plus and No Script which I find useful. Would you say deleting these is the only way to get javascript back? How valuable do you find those 2 extensions?

cor-el For extensions I do have Ad Block Plus and No Script which I find useful. Would you say deleting these is the only way to get javascript back? How valuable do you find those 2 extensions?
jscher2000
  • Top 10 Contributor
8688 solutions 71030 answers

Hi CS777, you probably have noticed the NoScript icon on the toolbar. If you see the red circle-slash symbol over the blue S, NoScript is blocking some or all scripts on the page. Use the button to approve the scripts you want to run and let the page reload. Usually you can figure out which ones are important on the first or second try, although in some cases it is not obvious and the list is flooded with advertising, tracking, sharing, and other servers that obscure the important ones. If you do not find that the benefits of using NoScript outweigh the burden of constantly approving sites, then it might not be the best extension for you.

Hi CS777, you probably have noticed the NoScript icon on the toolbar. If you see the red circle-slash symbol over the blue S, NoScript is blocking some or all scripts on the page. Use the button to approve the scripts you want to run and let the page reload. Usually you can figure out which ones are important on the first or second try, although in some cases it is not obvious and the list is flooded with advertising, tracking, sharing, and other servers that obscure the important ones. If you do not find that the benefits of using NoScript outweigh the burden of constantly approving sites, then it might not be the best extension for you.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

I'm not using them myself, but it is always possible that such extensions block wanted data. If you do use them then it is up to you to be aware that things can get blocked and if necessary allow specific objects on websites in the extension.

I'm not using them myself, but it is always possible that such extensions block wanted data. If you do use them then it is up to you to be aware that things can get blocked and if necessary allow specific objects on websites in the extension.
jscher2000
  • Top 10 Contributor
8688 solutions 71030 answers

Hi CS777, I see from your other post that disabling NoScript and Adblock Plus did not solve the problem.

After disabling extensions, you may need to exit and start Firefox up again to make sure that they are turned off. In that case, you would see a link for that purpose on the Add-ons page after clicking the Disable button.

Is there a particular site where you have this problem? Maybe it's a problem with the site or with a plugin the site wants to use? Please provide a link or get as specific as possible.

Hi CS777, I see from your other post that disabling NoScript and Adblock Plus did not solve the problem. ''After disabling extensions, you may need to exit and start Firefox up again to make sure that they are turned off. In that case, you would see a link for that purpose on the Add-ons page after clicking the Disable button.'' Is there a particular site where you have this problem? Maybe it's a problem with the site or with a plugin the site wants to use? Please provide a link or get as specific as possible.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB

Question owner

These 2 are definitely disabled, I've restarted several times, it's not site-specific. It's random. When I want to go forward on page by using an arrow button, or a page number, or "Next", or drop down menu for loading the next page, I get blocked.

These 2 are definitely disabled, I've restarted several times, it's not site-specific. It's random. When I want to go forward on page by using an arrow button, or a page number, or "Next", or drop down menu for loading the next page, I get blocked.

Question owner

My screenshot button isn't working

My screenshot button isn't working

Question owner

From CS777

More info: My Firefox 30.0 Options, Content, doesn't show a button for Enable Javascript.

Also, going through "about:config does show Javascript as true.

And, after finishing an auto update for Java, Java's page says "Verify Java and Find Out of Date Versions Verify and Continue. When I click Verify and Continue, Firefox blocks me says it doesn't recognize the address and the address bar shows javascript:;

From CS777 More info: My Firefox 30.0 Options, Content, doesn't show a button for Enable Javascript. Also, going through "about:config does show Javascript as true. And, after finishing an auto update for Java, Java's page says "Verify Java and Find Out of Date Versions Verify and Continue. When I click Verify and Continue, Firefox blocks me says it doesn't recognize the address and the address bar shows javascript:;
jscher2000
  • Top 10 Contributor
8688 solutions 71030 answers

In order to generate that error on Oracle's test page (https://www.java.com/en/download/installed.jsp), I need to switch a preference to a non-default setting. Try switching it back to its default value of false:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste java and pause while the list is filtered

(3) Scroll down and double-click the network.protocol-handler.external.javascript preference to switch it from true back to the default of false. Then reload the test page and try again.

In order to generate that error on Oracle's test page ([https://www.java.com/en/download/installed.jsp]), I need to switch a preference to a non-default setting. Try switching it back to its default value of false: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''java''' and pause while the list is filtered (3) Scroll down and double-click the '''network.protocol-handler.external.javascript''' preference to switch it from true back to the default of false. Then reload the test page and try again.

Question owner

Finally!----I got through to verifying Java. I tested another site I had trouble with this morning and it works. Hopefully, this will fix every occurrence.

So, why is it working now that that particular line is checked false? I notice on that page every other javascript line is either true or is numbered. How do you think the problem originated?

Thanks for your help and will keep the info for future reference.

Finally!----I got through to verifying Java. I tested another site I had trouble with this morning and it works. Hopefully, this will fix every occurrence. So, why is it working now that that particular line is checked false? I notice on that page every other javascript line is either true or is numbered. How do you think the problem originated? Thanks for your help and will keep the info for future reference.
James
  • Moderator
1595 solutions 11242 answers

Do you actually need the Java plugin for any website as it is not used much anymore and is not needed for the separate JavaScript in Firefox to work.

Do you actually need the Java plugin for any website as it is not used much anymore and is not needed for the separate JavaScript in Firefox to work.

Question owner

My problem was solved a few minutes ago (see above), but I'm not savvy enough to understand your question. I've never known how much I've ever needed Java. Seems like it's always been there and I've gone ahead with auto updates.

The JavaScript problem started a few months ago, have no idea what changed, so now I don't know if or how I can prevent this from happening again. Any ideas?

Also, my print screen button won't work. It's also the End button. It has worked in the past; again, don't know what changed.

Can you help me with this or should I start a new thread?

My problem was solved a few minutes ago (see above), but I'm not savvy enough to understand your question. I've never known how much I've ever needed Java. Seems like it's always been there and I've gone ahead with auto updates. The JavaScript problem started a few months ago, have no idea what changed, so now I don't know if or how I can prevent this from happening again. Any ideas? Also, my print screen button won't work. It's also the End button. It has worked in the past; again, don't know what changed. Can you help me with this or should I start a new thread?
jscher2000
  • Top 10 Contributor
8688 solutions 71030 answers

Hi CS777, to answer your question about that preference, it relates to the protocol at the beginning of the link. For example, on the Java test page, the link was like this:

<a href="javascript:" onclick="some script to run">

(Normally, the value of the href attribute start with the http: or https: protocol, or sometimes ftp: or mms: for specialized applications.)

When you click a link that uses the javascript: protocol, and the network.protocol-handler.external.javascript preference is at its default value of false, Firefox first runs the script specified in the onclick attribute. If that doesn't leave the page or cancel further action by the link, Firefox then runs the script specified in the href attribute. This is all handled internally by Firefox.

However, when you set the preference to true, Firefox doesn't do anything itself and instead tries to open the link with an external program. Since Firefox isn't aware of any external program to handle javascript: protocol links, you get an error page.

Hi CS777, to answer your question about that preference, it relates to the protocol at the beginning of the link. For example, on the Java test page, the link was like this: &lt;a href="javascript:" onclick="''some script to run''"> (Normally, the value of the href attribute start with the http: or https: protocol, or sometimes ftp: or mms: for specialized applications.) When you click a link that uses the javascript: protocol, and the '''network.protocol-handler.external.javascript''' preference is at its default value of false, Firefox first runs the script specified in the onclick attribute. If that doesn't leave the page or cancel further action by the link, Firefox then runs the script specified in the href attribute. This is all handled internally by Firefox. However, when you set the preference to true, Firefox doesn't do anything itself and instead tries to open the link with an external program. Since Firefox isn't aware of any external program to handle javascript: protocol links, you get an error page.
jscher2000
  • Top 10 Contributor
8688 solutions 71030 answers

On Print Screen, yes, a new question is a good idea.

On Print Screen, yes, a new question is a good idea.

Question owner

I've never been to that page to set it to true. Something changed a few months ago. Any idea what it could be?

I've never been to that page to set it to true. Something changed a few months ago. Any idea what it could be?
jscher2000
  • Top 10 Contributor
8688 solutions 71030 answers

It would take a long time to type out all the possible guesses and I'm not sure it would be very useful...

If it happens again, check for a user.js file containing a reference to that preference as described in this article: How to fix preferences that won't save. That wouldn't tell you who/what created the file, but it would explain how the change got injected.

It would take a long time to type out all the possible guesses and I'm not sure it would be very useful... If it happens again, check for a user.js file containing a reference to that preference as described in this article: [[How to fix preferences that won't save]]. That wouldn't tell you who/what created the file, but it would explain how the change got injected.