Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 15 replies
  • 10 have this problem
  • 211 views
  • Last reply by user633449

more options

I've been having 2-3 firefox crashes a week since 30.0. I think most are related to Flash but disabling Flash Safe Mode like another thread suggested, broke other things, specifically audio.

The real problem however, is that none of the past like 20 Crashes have been saved on Firefox crash reports on about:crashes. The last one saved is from June 30th. I think I've asked about this on someone else's thread but never got a response.

All Replies (15)

more options

Have you tried Resetting Firefox? Refresh Firefox - reset add-ons and settings

more options

I have. All that did was ruin things further since it removes add-ons and such other settings I've worked years getting right. That's why it did right after a windows backup. I've since reverted since it didn't solve issues. Firefox is even crashing on a brand new laptop. Less often on there, but still 3-5 times a week. Prior to 30.0, it crashed maybe once every 3 months.

more options

Can you please scan for malware? There is a common virus causing Firefox crashes, Troubleshoot Firefox issues caused by malware

more options

I understand your suggestion since most computer users are ignorant fools that click on everything. I do work in IT. I run Malware Bytes every week. I've tried every "obvious" solution to fix this issue. The last crash logs are hinting at Adobe Flash issues (not sure exactly what, otherwise I'd obvioulsy fix it), but again my REAL issue is that it's not saving the Crash Reports. Even after I did that Reset it crashed a few hours later and there was nothing under the Crash Report.

Modified by Kougeru

more options

Can you post your latest crash report? Also, have you actually submitted the crash reports when the window appears, or is the window not appearing?

more options

By submitting I'm assuming you're talking about the check box for "Tell Mozilla about the crash so they can fix it" since that's the only thing I can think of. I have that checked of course.

Do I just copy and paste the link from the crash report? From June 30th https://crash-stats.mozilla.com/report/index/09ae3e29-04e1-4a26-8dba-5fb422140630

I have 3 reports from June, the 12th, 17th, and 30th. I've crashed like 40 times in June but those are the only reports it saved.
more options

Crashed again this morning and it made TWO crash reports, neither of which are helping me at all as they seem to have less information than normal.

https://crash-stats.mozilla.com/report/index/bp-38733f26-d11b-4b70-92c5-32a412140708

https://crash-stats.mozilla.com/report/index/bp-53a4f762-b5ec-47a0-a9ae-094b42140708

more options

Both of those crashes are caused by your graphics card, have you tried disabling hardware acceleration? Turning off hardware acceleration

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need close and restart Firefox after toggling this setting.

more options

I tried that for 2 weeks and it crashed just as often. The crashes I just linked are actually 1 crash. It only crashed once but made two reports for some reason. All the reports from June are listing Adobe issues. I tried disabling hardware acceleration in every section available on my browser, and the crashes still occurred multiple times a week. I reactivated since it wasn't resolving the issues.

Here's another from June https://crash-stats.mozilla.com/report/index/a2ebd549-de9a-48c6-9e67-cedaa2140622

more options

That crash you just gave me shows [@ gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*) ], which means it's caused by hardware acceleration. please try to disable it again

more options

Actually, I just checked my options and Hardware Acceleration is still unchecked

edit: "That crash you just gave me shows" I'm assuming you're referring to today's crash. I don't see that on my June reports

Modified by Kougeru

more options

That last report is a problem with the Flash plugin. a2ebd549-de9a-48c6-9e67-cedaa2140622

  • Firefox 30.0 Crash Report [@ hang | WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________ ]

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:

more options

https://crash-stats.mozilla.com/report/index/2688dce6-f6da-4c78-a943-7830f2140714

https://crash-stats.mozilla.com/report/index/709e4cc4-57bd-4b7f-878a-088f92140711

https://crash-stats.mozilla.com/report/index/5dabd41f-f1b4-43a5-8680-bfda62140714

hardware acceleration is still turned off. I'm running the absolute latest drivers. I'm a gamer, so I'm always running the latest unless there's some major issue with them. I have tried reverting to older drivers as well, no luck with that either.

As I've mentioned in my first post (though I called it safe mode instead of protect mode), I've already tried disabling Protect Mode for flash and that just caused even more issues than it solved....oh wait, it didnt solve any because I still got crash issues related to Flash. And as I've already mentioned again, I have hardware acceleration disabled everywhere possible.

I don't mean to be rude, but I've already tried all the solutions on your FAQ and similar threads. Copy and paste responses clearly are not working.

I would honestly assume it as a driver issue or something if not for the fact that other browsers like Chrome dont crash, even if I leave them running for a week straight with flash videos loaded.

Firefox didn't use to crash until your big update changing the layout to look more like Chrome.

I've seen lots of people with the same or similar issues. Most of them just don't care enough so they just stop using FF and use chrome instead. Firefox has so many features that chrome doesn't, features I need, and add-ons I need, so I can't just "switch to chrome".


TLDR; NO HARDWARE ACCELERATION. PROTECT MODE does NOT help. Fresh install of Firefox does NOT help.

more options

You have a ton of extensions, have you tried using a new profile for testing? Profile Manager - Create, remove, or switch Firefox profiles