X
Tap here to go to the mobile version of the site.

Support Forum

Cookie exception list is empty, even when there are exceptions

Posted

With Firefox 30.0, when I add cookie exception, it disappears from the list after restart. However the exception works (I have set some cookies as allowed). So, it seems they are just not showed.

With Firefox 30.0, when I add cookie exception, it disappears from the list after restart. However the exception works (I have set some cookies as allowed). So, it seems they are just not showed.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/Linux/en-US/

Extensions

  • Mozilla-laajennus Voikon käyttöön 2.0.1 ({b676e3ff-cda7-4e0c-b2b8-74e4bb40a67a})
  • NoScript 2.6.8.29 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.9 (ubufox@ubuntu.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 8600 GT/PCIe/SSE2
  • adapterDeviceID: GeForce 8600 GT/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 331.38
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- GeForce 8600 GT/PCIe/SSE2
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind: True
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140608211622
  • browser.startup.homepage: https://www.google.fi/
  • browser.startup.homepage_override.buildID: 20140608211622
  • browser.startup.homepage_override.mstone: 30.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 103617
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True

Misc

  • User JS: No
  • Accessibility: No
Pavel.kais 0 solutions 4 answers

Hello user 225

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello user 225 '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu: *In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. *In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on ''Help'' (or click on ''Help'' in the Menu bar, if you don't have a Firefox button) then click on ''Restart with Add-ons Disabled''. If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode".<br> [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

This didn't fix the problem. And I don't think the safe mode even work correctly. Flash player was not disabled in safe mode (I think others were).

This didn't fix the problem. And I don't think the safe mode even work correctly. Flash player was not disabled in safe mode (I think others were).
Pavel.kais 0 solutions 4 answers

Hey user255,

To find the correct solution to your problem, we require some more non-personal information from you. Please do the following:

  • For Firefox versions previous to 29.0: Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.
  • For Firefox 29.0 and above: Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

Hey user255, To find the correct solution to your problem, we require some more non-personal information from you. Please do the following: *'''For Firefox versions previous to 29.0''': Click the Firefox button at the top left, then click the ''Help'' menu and select ''Troubleshooting Information'' from the submenu. If you don't have a Firefox button, click the Help menu at the top and select ''Troubleshooting Information'' from the menu. *'''For Firefox 29.0 and above''': Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. Now, a new tab containing your troubleshooting information should open. *At the top of the page, you should see a button that says "Copy text to clipboard". Click it. *Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]]. Thanks in advance for your help!

Question owner

Application Basics


Name: Firefox Version: 30.0 User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Mozilla-laajennus Voikon käyttöön Version: 2.0.1 Enabled: true ID: {b676e3ff-cda7-4e0c-b2b8-74e4bb40a67a}

Name: NoScript Version: 2.6.8.29 Enabled: true ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Troubleshooter Version: 1.1a Enabled: true ID: troubleshooter@mozilla.org

Name: Ubuntu Firefox Modifications Version: 2.9 Enabled: true ID: ubufox@ubuntu.com

Important Modified Preferences


accessibility.typeaheadfind: true browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20140608211622 browser.startup.homepage: https://www.google.fi/ browser.startup.homepage_override.buildID: 20140608211622 browser.startup.homepage_override.mstone: 30.0 dom.mozApps.used: true extensions.lastAppVersion: 30.0 network.cookie.lifetimePolicy: 2 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1404159848 places.history.enabled: false places.history.expiration.transient_current_max_pages: 103617 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.offlineApps: true privacy.clearOnShutdown.passwords: true privacy.clearOnShutdown.siteSettings: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1404159848

Graphics


Adapter Description: NVIDIA Corporation -- GeForce 8600 GT/PCIe/SSE2 Device ID: GeForce 8600 GT/PCIe/SSE2 Driver Version: 3.3.0 NVIDIA 331.38 GPU Accelerated Windows: 0/1 Basic Vendor ID: NVIDIA Corporation WebGL Renderer: NVIDIA Corporation -- GeForce 8600 GT/PCIe/SSE2 windowLayerManagerRemote: false AzureCanvasBackend: cairo AzureContentBackend: cairo AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.4 Version in use: 4.10.4

NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSUTIL Expected minimum version: 3.16 Version in use: 3.16

Application Basics ------------------ Name: Firefox Version: 30.0 User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: Mozilla-laajennus Voikon käyttöön Version: 2.0.1 Enabled: true ID: {b676e3ff-cda7-4e0c-b2b8-74e4bb40a67a} Name: NoScript Version: 2.6.8.29 Enabled: true ID: {73a6fe31-595d-460b-a920-fcc0f8843232} Name: Troubleshooter Version: 1.1a Enabled: true ID: troubleshooter@mozilla.org Name: Ubuntu Firefox Modifications Version: 2.9 Enabled: true ID: ubufox@ubuntu.com Important Modified Preferences ------------------------------ accessibility.typeaheadfind: true browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20140608211622 browser.startup.homepage: https://www.google.fi/ browser.startup.homepage_override.buildID: 20140608211622 browser.startup.homepage_override.mstone: 30.0 dom.mozApps.used: true extensions.lastAppVersion: 30.0 network.cookie.lifetimePolicy: 2 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1404159848 places.history.enabled: false places.history.expiration.transient_current_max_pages: 103617 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.offlineApps: true privacy.clearOnShutdown.passwords: true privacy.clearOnShutdown.siteSettings: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeOnShutdown: true storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1404159848 Graphics -------- Adapter Description: NVIDIA Corporation -- GeForce 8600 GT/PCIe/SSE2 Device ID: GeForce 8600 GT/PCIe/SSE2 Driver Version: 3.3.0 NVIDIA 331.38 GPU Accelerated Windows: 0/1 Basic Vendor ID: NVIDIA Corporation WebGL Renderer: NVIDIA Corporation -- GeForce 8600 GT/PCIe/SSE2 windowLayerManagerRemote: false AzureCanvasBackend: cairo AzureContentBackend: cairo AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0 JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.4 Version in use: 4.10.4 NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC NSSUTIL Expected minimum version: 3.16 Version in use: 3.16
cor-el
  • Top 10 Contributor
  • Moderator
17679 solutions 159906 answers

If you keep tabs open with those sites when you close Firefox then cookies are stored in the sessionstore.js file as part of the session data.

In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

If you keep tabs open with those sites when you close Firefox then cookies are stored in the sessionstore.js file as part of the session data. In case you are using "Clear history when Firefox closes": *do not clear the Site Preferences *Edit > Preferences > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/remove-browsing-search-and-download-history Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data. Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.

Question owner

Please reread the question.

Please reread the question.

Question owner

See attached image. This is what I see when I start Firefox (with using about:blank as home page).

As you can see, cookies should be cleared when I close Firefox. But some of them aren't (also visible in the pic). That is because of the cookie exceptions I have set are working. However, as you can see, exception list appears to be empty!

That prevents me to manage the exceptions, which is my current problem.

See attached image. This is what I see when I start Firefox (with using about:blank as home page). As you can see, cookies should be cleared when I close Firefox. But some of them aren't (also visible in the pic). That is because of the cookie exceptions I have set are working. However, as you can see, exception list appears to be empty! That prevents me to manage the exceptions, which is my current problem.
christ1
  • Top 25 Contributor
2197 solutions 16057 answers

This doesn't make sense to me. You allow all cookies already, so what do you need exceptions for, assuming there are certain cookies you want to keep? I don't know why not all your cookies are being removed upon shutdown, but I doubt it has got something to do with exceptions you may have set (or not).

What would make sense to me is to block cookies by default, and create an exception ('allow') for e.g. accounts.google.com.

This doesn't make sense to me. You allow all cookies already, so what do you need exceptions for, assuming there are certain cookies you want to keep? I don't know why not all your cookies are being removed upon shutdown, but I doubt it has got something to do with exceptions you may have set (or not). What would make sense to me is to block cookies by default, and create an exception ('allow') for e.g. accounts.google.com.
Pavel.kais 0 solutions 4 answers

Well user255 , cor-el is right. Your troubleshooting information shows : privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.offlineApps: true privacy.clearOnShutdown.passwords: true privacy.clearOnShutdown.siteSettings: true privacy.sanitize.migrateFx3Prefs: true

Please do the above-mentioned process just as cor-el said. Save and Restart Firefox. https://support.cdn.mozilla.net/media/uploads/images/2014-07-01-10-43-26-911af7.png https://support.cdn.mozilla.net/media/uploads/images/2014-07-01-10-43-33-0471f9.png

Well user255 , cor-el is right. Your troubleshooting information shows : privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.offlineApps: true privacy.clearOnShutdown.passwords: true privacy.clearOnShutdown.siteSettings: true privacy.sanitize.migrateFx3Prefs: true Please do the above-mentioned process just as cor-el said. Save and Restart Firefox. https://support.cdn.mozilla.net/media/uploads/images/2014-07-01-10-43-26-911af7.png https://support.cdn.mozilla.net/media/uploads/images/2014-07-01-10-43-33-0471f9.png

Question owner

OMG!? Is my English really that bad?

Last time; my problems isn't that my cookies are removed, or saved. My problem is cookie exception list stays empty even when I add items to it!

So, my cookies are just like I set them, right cookies are preserved and right cookies are removed. But the cookie exception list goes empty, when it should show the exceptions I have set.

Clearing "Site Preferences" or not, does nothing to the problem!

OMG!? Is my English really that bad? Last time; my problems isn't that my cookies are removed, or saved. My problem is cookie exception list stays empty even when I add items to it! So, my cookies are just like I set them, right cookies are preserved and right cookies are removed. But the cookie exception list goes empty, when it should show the exceptions I have set. Clearing "Site Preferences" or not, does nothing to the problem!

Modified by user255

Question owner

"You allow all cookies already, so what do you need exceptions for, assuming there are certain cookies you want to keep?"

Yes, I have set example google.com as allowed.


"I don't know why not all your cookies are being removed upon shutdown, ..."

I have said many times they are not removed, because I have set the exceptions!


"... but I doubt it has got something to do with exceptions you may have set (or not)."

YES!


"What would make sense to me is to block cookies by default, and create an exception ('allow') for e.g. accounts.google.com."

But I need cookies temporarily from many sites. So, this isn't option.

"You allow all cookies already, so what do you need exceptions for, assuming there are certain cookies you want to keep?" Yes, I have set example google.com as allowed. "I don't know why not all your cookies are being removed upon shutdown, ..." I have said many times they are not removed, because I have set the exceptions! "... but I doubt it has got something to do with exceptions you may have set (or not)." YES! "What would make sense to me is to block cookies by default, and create an exception ('allow') for e.g. accounts.google.com." But I need cookies temporarily from many sites. So, this isn't option.
Dotateer 0 solutions 1 answers

Helpful Reply

I had the same problem. Here is what helped me: Install SQLite Manager https://addons.mozilla.org/en-US/firefox/addon/sqlite-manager/ Open SQLite Manager. Open the file permissions.sqlite. This is where the cookie exceptions are stored. Go to the table moz_hosts and delete all rows where the value in the column 'permission' is '-1' Restart firefox! If this doesn't work try to delete other suspicious entries or the file itself.

I had the same problem. Here is what helped me: Install SQLite Manager https://addons.mozilla.org/en-US/firefox/addon/sqlite-manager/ Open SQLite Manager. Open the file permissions.sqlite. This is where the cookie exceptions are stored. Go to the table moz_hosts and delete all rows where the value in the column 'permission' is '-1' Restart firefox! If this doesn't work try to delete other suspicious entries or the file itself.

Modified by Dotateer

Legacy2000 0 solutions 2 answers

Dotateer, thank you for taking the time to understand user255's question, and for providing a relevant solution.

I had the same problem, and since I clear exceptions periodically anyways, I took the shortcut and deleted the permissions.sqlite file. My exceptions list is now functioning properly.

Dotateer, thank you for taking the time to understand user255's question, and for providing a relevant solution. I had the same problem, and since I clear exceptions periodically anyways, I took the shortcut and deleted the permissions.sqlite file. My exceptions list is now functioning properly.