Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bricked ZTE Open C quite hard

  • 31 replies
  • 3 have this problem
  • Last reply by amfg

more options

Hello, I've received my ZTE Open C (EU version) this Wednesday. Since I ran into some issues with Gaia in ff 1.3, I wanted to update it. I've followed guide from mdn ( ) and updated from git successfully. I've also created backup /system and /data dirs with adb pull. Problems arose today, when ff hung up on some application. I had to restart it, unfortunately by taking off battery. After restart, ff couldn't detect my sim card. It didnt change after more restarts (I tried to move sim a bit, no luck) so I decided it has to be software issue rather than hardware. I did device reset (or whatever it is called there). The process lasted for more than two hours and there was no progress bar. So I pulled battery out. Of course, device got "soft bricked". I was able to access bootloader, but trying to update from official on my SD card resulted in verification error, although it was ok last evening. I read a few article with people being in similar situation. I decided to go for . I followed the (pretty simple) guide. Unfortunately, after reboot zte lagged on Firefox OS screen. Now I can't access phone by adb. When I try to start bootloader, after a 5 seconds of FFOS logo I get white screen, which won't go away. My last remaining hope is that booting with VOL_DOWN pressed still works - I AM ABLE to connect with fastboot. I feel like I am only one mistake away from turning this phone into complete brick. Please, help me find the light.

Update ======================== I tried first step from the last link again, so I can provide you with output - After executing script (flashing system.img and booting into recovery.img), I am now in system recovery. Adb can NOT detect my device. Aside from menu I get usual errors (which I had before it got bricked) + 1 extra (about /system) - Trying to "apply update from sdcard" (official which has worked once) adds following lines -

Update ======================== I found this link (somewhere, I have probably closed the source tab already). File inside was called, so I copied it on my sd card, put it back into zte and tried to apply update. Output was something I have expected -

Update ======================== Phone won't boot now with battery. It doesn't do a thing. (OK, it boots, after 5 minutes) With battery removed I tried `fastboot flash system system.img` - system.img is from package. Unfortunately, the process of flashing hangs. I gave it 5 hours while I slept. -

Modified by amfg

All Replies (11)

more options

Still not fixed.

more options

Hi amfg, There was another thread that I was following where a contributor made a reference to a third party installer for 1.4 on the zte open c. It is indeed not the same issue and this is a third party version, not "official"

It made me think it may be a port or usb issue? Does it also not connect using fastboot on another computer with a new sdk download? It looks like this may have fixed the protocol error from other devices?

more options

I have read and I assume your phone is recognizable using the Zte Open C upgrade tool if not I do not know what to tell you


Obviously do steps 1,2 and make sure Erase CEFS is checked download this and extract it below!U4AhAZzL!fpZzukjLZ-zrtRQag3oPev88l2mwieCSe3ycJR69koU

more options

I wasn't responding for a while because I am really fed up with this.

@jeradw00: unfortunately, I cannot make Upgrade Tool work. It simply doesn't find my device. I tried going into fastboot, adb and also tried booting into whatever is default now and not booting at all (only charging). It seems It cannot recognize it, although adb&fastboot tools are able to show the device

more options
more options

I installed that package, rebooted, connected phone (turned off) and fired upgrade tool - it couldnt find it. So I booted phone into fastboot, no luck either. So I booted into recovery (when I simply restart phone and go volup, adb cant find it. So i have to fastboot boot recovery.img from "FFOS_EU_EBAY_P821A10V1.0.0B06_LOG_DL" package), and no luck in recovery. Upgrade tool shows "Searching" whole time.


I actually got an idea I could pull / off the phone so we can see what's really there. I got bunch of "Failed to copy" IO Errors, but I got a few files that might be interesting

/tmp/recovery.log output of tree from copied dir

Content of /cache is single .img file (which is probably my doing but I dont think it matters) From recovery.log, I find these lines interesting

Opening update package... I:read key e=3 I:1 key(s) loaded from /res/keys Verifying update package... I:verify_file returned 1 E:signature verification failed Installation aborted.

This suggests there is some (pgp?) key inside /res/keys. Unfortunately, I dont see this key anywhere (since I got only /cache, /tmp and /sys out of that pull)

So I tried fastboot boot system.img (system.img being from that FFOS package mentioned before) and it (most likely) hung

>fastboot boot system.img creating boot image... creating boot image - 377489408 bytes downloading 'boot.img'... FAILED (data transfer failure (Too many links)) finished. total time: 6268.242s

I have to quote @nhirata: Ok, the good news is that you still have access.

I don't see how this is a good news since I can't do a thing.

Modified by amfg

more options


i am not going to lie the only way i got around this was with the software tool - i could not get around it using adb or sideload or recovery - i always got the verification failure as well. - to be frankly honest like i said on my 1st post - if the software does not work i do not know what to tell ya. If you have exhausted all usb ports and tried another computer - via usb package and the other package - i do not know the answer, i am sorry man.

I am sure there has to be someone a lot smarter than me on this site that can get you somewhere further.

I would like to know if anyone has used that package successfully above as i honestly thought amfg was going to be singing and dancing, little did i know that would not be the case.

more options

By the way, I tried connecting the phone to different computer (original asus, second one was toshiba), no luck either. I could do exactly the same things with the same results, but not anything more. Upgrade tool did not recognize phone under any circumstances.

I am thinking of buying Flame but hell, if I end up in the same mess, I will be a lot angrier. I still cannot accept $100 laying on my shelf.

more options

i take it your in android mode? i had the same problem, i converted back to ffos and Upgrade tool recognized it instantly

more options

Hey I came across this - when you get some time look into this - it also shows Windows 8 computers have issues with adb and how to get around it - since I do not know if you have windows 8 on both the computers or a lower version I figured why not - on top of that there are some roms and recoveries and things you may want to look into.

Modified by jeradw00

more options

darthlotus: No, it is running firefox OS. jeradw00: No, I have windows7 on both computers I have tried.

  1. 1
  2. 2