Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

google says my cookies are disabled, but they're not and so i can't access my google account - help! I have looked at an achived question and tried all that

  • 7 replies
  • 14 have this problem
  • Last reply by wuergler

more options

I can't log in to google as it says to enable cookies but they are enabled, I also have problems with Twitter it logs me in but will not let me send a tweet. I have tried all of the solutions in this and still have the same problem.

All Replies (7)

more options
more options

Thanks I tried both of those already without success.

more options

You can also check if DOM Storage is enabled.

You can inspect and manage the permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can inspect and manage the permissions for all domains on the about:permissions page.

more options

If what a site says it wants are cookies, why should that mean that DOM storage is required?

more options

DOM storage is similar to cookies and only stored differently and do not have the size limits of 4096 that cookies have and follows the same settings (exceptions) as set to cookies.

more options

And Google cannot say what it means?

more options

You should be able to access your Google account with just normal session cookies enabled. I've tested this (actually always did) with

  • cookies allowed for session for and
  • no third-party cookies allowed (avoid sites where that would be necessary anyway ...)
  • no local storage ( set to false, although some doubt there are any benefits of this)

So I suspect you may have a problem with preferences that won't save. Although in my case, if I have a cookie problem I just delete and redo, such as deleting and reentering an exception or another cookie setting in your preferences > privacy settings.